Jump to content

[SOLVED] Enabling graphics acceleration makes the display black until waking up from sleep


3 posts in this topic

Recommended Posts

EDIT: I resolved the issue, I just had to change the framebuffer. I had tried every framebuffer earlier, but now that I tried them again after resolving the issue I tackled previous to this one it works!

Hello again, I've been wrestling with this issue for a while now and I was hoping to get some more help with it.

I'm in the post-install section of making a hackintosh on a Lenovo ThinkPad X1 Extreme Gen 3 (Serial 20TK001JUS) with OpenCore by following Dortania's guide and using supplementary research when necessary.

I've got macOS installed on my computer already (Thank you, Slice and 1Revenger1!) but have made no progress with this second issue: When I try to go enable graphics acceleration on my laptop the screen just goes black after the verbose log. No apple logo or loading bar, just a black screen with the IPS backlight on. It stays this way for 4-6 minutes, at which point the computer falls asleep. if I then press the power button then the login screen pops up as if nothing happened.
If I'm lucky I can log in blindly and use the Apple menu in the top left corner to put the computer to sleep using keyboard controls, but if the "You restarted your computer because of a problem" dialog appears this essentially becomes impossible.

 

Laptop: Lenovo X1 Extreme Gen 3 (20TK001JUS)
CPU: Intel i9-10885h (Comet Lake)

iGPU: Intel UHD 630 (devID 9BC4)

dGPU: NVIDIA GeForce GTX 1650 Ti with Max-Q Design (Turing Architecture)
Mobo: WM490 chipset
RAM: 32 GB DDR4 @ 2933 MHz
Builtin screen resolution: 1080p (1920x1080)


Versions:
OS: MacOS Catalina 10.15.7
OpenCore: 0.6.8

UEFI BIOS: N2VET29W (Most recent version at the time of writing)

I've been using a 2015 MacBookPro to create and modify the boot USB.

 

EFI & other resources:
https://drive.google.com/drive/folders/1-k29SMOAdNiBwyDAHl3-RjI8jFt6bRkF?usp=sharing
Product Specification from Lenovo:

https://psref.lenovo.com/syspool/Sys/PDF/ThinkPad/ThinkPad_X1_Extreme_Gen_3/ThinkPad_X1_Extreme_Gen_3_Spec.pdf

 

!!IMPORTANT!! some of the items in the Google Drive folder may suggest I had a Macmini8,1 SMBIOS and others a MacBookPro16,3 SMBIOS. This is because I messed up my configs when creating the reference materials. Changing the SMBIOS doesn't affect the problem, though.

 

If I could receive some more assistance on this I would highly appreciate it. Thanks!

Edited by xefyr0
Solved the issue
Posted (edited)
53 minutes ago, Hervé said:

Try faking Coffee Lake iGPU id 3E9B; that's what member @vadammt did and he reports full graphics acceleration on his i7-10750H platform.

https://www.insanelymac.com/forum/topic/347429-booting-opencore-ends-with-unsupported-pch-and-gioscreenlockstate/?do=findComment&comment=2756667

Thank you, but that didn't work, sorry.

Edited by xefyr0
  • xefyr0 changed the title to [SOLVED] Enabling graphics acceleration makes the display black until waking up from sleep
×
×
  • Create New...