Jump to content

Fresh OpenCore setup hangs on black screen before install.


3 posts in this topic

Recommended Posts

CPU: i7-3960X Sandy Bridge-E

GPU: Nvidia 680 8mb gfx

Motherboard: Rampage IV Black, chipset is X79.

I had this PC dual-booting via Clover+Mojave and Windows for years until the hard-drive died. Then I decided to start over with OpenCore 0.6.8 and Big Sur. I’m using new install media, nothing copied or inherited from Clover. But I can’t even get to the installer. The system hangs with a single cursor underscore on a black screen. I’ve built several Hackintoshes, but this is the first with OpenCore or Big Sur.

I have a SandyBridge-E, and I followed the guide for Sandy Bridge-E at dortania.github.io/.../ivy-bridge-e.html. I’m using all debug kexts. I used the sanity checker, and now it seems valid. Actually the sanity checker told me to add values to my config.plist UEFI/input and UEFI/output. When I did, I got “OC” errors so I deleted those. Now the OC errors no longer appear, but it still no installer. One problem I observed years before with Clover is that not every USB port is bootable. I’ve tried multiple ports now, all stop at black screen. On my boot USB, OC dumps a opencore-datetime.txt file, but it contains 200k of junk binary.

By checking the page https://dortania.github.io/OpenCore-Install-Guide/troubleshooting/boot.html , I assume that OpenCore is failing after BOOTx64.efi is loaded, and before “OpenCore loads and shows you all possible boot options”. First guess, invalid config.plist, EFI drivers, or Graphics Output Protocol.

Boot arguments are “-v debug=0x100 keepsyms=1 alcid=1 nvda_drv_vrl=1”

 

Here is the gist of my config.plist

OpenCore log file 00

The last 2 lines before halting are:Driver HfsPlus.efi at 0 is being loaded...OCB Arch filtering 0(37892)-> CFB79018(37982) caps 4 - Success

Edited by Charlweed
CPU is Sandy Bridge-E

I'm returning to the guides. There is discrepancy between the Sandy-Bridge specific pages and the general. The specific page is out-of date in some details, for example SSDT-UNC0.aml is no longer available in RehabMan's repositories. I found a copy elsewhere. I also added the delete dictionaries under ACPI.

None of the above made a difference.

 

I replaced HfsPlus.efi with OpenHfsPlus.efi and updated the config.plist. That was enough to get to what I guess is the console-based "picker". I expected a GUI though. I selected the first option, which I assume is the installer I made months ago. And it very slowly got to the stage "ACPI Executed 3 blocks of module-level"

And now it is hanging there. I think I will start over again with OpenCore and Mojave, just because I know that OS can be installed on this CPU + motherboard.

×
×
  • Create New...