Jump to content

Atheros AR928x working with Big Sur


4 posts in this topic

Recommended Posts

Just got my old Atheros PCIe AR928x wireless card working with Big Sur.

 

Download and run the OpenCore Legacy Patcher 0.0.22 https://github.com/dortania/OpenCore-Legacy-Patcher/releases

 

Select option 3 Change Model. Enter iMac11,2. Press 'Enter'

 

Select option 1 Build OpenCore. This will build you an EFI folder and save it. At the bottom of the terminal window it will display the saved location. Copy the location.

 

On the Finder Menu Select 'Go' then select 'Go to Folder'. Paste the previously copied location and click 'Go'.

 

Select the EFI folder and navigate to the Kext folder

 

Copy the IO80211HighSierra.kext. Paste into your Main EFI Kext folder. You will need Clover Configurator or something similar to display your main EFI folder

 

Open your config plist using 'ProperTree' https://github.com/corpnewt/ProperTree . Do a Snapshot/Clean Snapshot then Save and Reboot. You will have working wifi.

 

Hope I haven't oversimplified this.

 

 

Edited by antic
  • Like 1

No need, stricto sensu, of tools such as CC or OCC to mount the EFI partition and access the bootloader's EFI folder. A simple diskutil command in Terminal suffices:

sudo diskutil mount <diskXsY>

where <diskXsY> is the EFI partition shown with diskutil list command.

 

Example:

admin@E6230 ~ % diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *256.1 GB   disk0
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk0s1      <-- this is the EFI partition
   2:                 Apple_APFS ⁨Container disk1⁩         255.9 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +255.9 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume ⁨Big Sur - Data   ⁩       106.4 GB   disk1s1
   2:                APFS Volume ⁨Preboot⁩                 583.0 MB   disk1s2
   3:                APFS Volume ⁨Recovery⁩                1.1 GB     disk1s3
   4:                APFS Volume ⁨VM⁩                      2.1 GB     disk1s4
   5:                APFS Volume ⁨Catalina - Data   ⁩      89.8 GB    disk1s5
   6:                APFS Volume ⁨Catalina⁩                11.3 GB    disk1s6
   7:                APFS Volume ⁨Big Sur⁩                 15.1 GB    disk1s7
   8:              APFS Snapshot ⁨com.apple.os.update-...⁩ 15.1 GB    disk1s7s1

admin@E6230 ~ %
admin@E6230 ~ %
admin@E6230 ~ % sudo diskutil mount disk0s1
Password:
Volume EFI on disk0s1 mounted
admin@E6230 ~ %

 

In essence, that's what the various tools actually so.

  • 2 weeks later...

this doesn't work in Clover 5133 with Big Sur 11.2.3

 

ANYONE HAVE A SURE FIX??

 

Would be greatly appreciated

 

UPDATE FOUND A FIX:

Check my post

Edited by makk
×
×
  • Create New...