Jump to content

DisplayPort audio on NVIDIA not working with AppleALC


1 post in this topic

Recommended Posts

I'm in the process of modernizing my High Sierra hackintosh Alienware m15 R1. I was using VodooHDA 2.8.9, and I was getting all audio outputs activated all the time, that is the Speakers and Headphones in the Realtek ALC289 codec, 4 HDMI outputs through the NVIDIA GTX 1080 Ti (connected to the laptop through the Alienware Graphics Amplifier) and the internal Intel HDMI output.

After some work I was able to move to AppleALC, but now only the internal audio works, and only if I inject the layout through the Device/Audio/Inject Clover option. If I use Device/Properties it works sometimes but sometimes it doesn't. Although, as said, I've been unable to make the HDMI outputs appear, also using hackingtool the NVIDIA Audio device does not seems to be properly detected. Using DPCIManager I can see all devices when using VoodooHDA but only the NVIDIA and the Realtek when using AppleALC.

 

My reason to update to AppleALC is that, with VodooHDA 2.8.9, Codecommander does not work and I cannot fix the headphones distortion. With AppleALC I can use alc-verb and have undistorted output through them. I've tried VoodooHDA 2.9.2, the devices are detected but I was unable to get Audio through any of the HDMI outputs.

 

I found a post somewhere saying that they had the same problem and fixed it by changing ResetHDA to false but it didn't work for me.

 

I've attached the config.plist (removed SMBIOS) with the configuration that works sometimes, if I remove the Device/Properties for the HDA and change Inject to 11 it works consistently.

Screen Shot 2021-04-02 at 5.32.34 PM.png

Screen Shot 2021-04-02 at 5.52.47 PM.png

config.plist

×
×
  • Create New...