Jump to content

Keyboard/mouse issue, Big Sur and AsRock B560m-HDV


9 posts in this topic

Recommended Posts

Hi all,

 

I'm working on my first Hackintosh build, but I'm running into some problems. I followed the OpenCore guide(s), twice, but I've run into a few issues. The first one was a blank screen right before the installer. I "fixed" that for now by adding "-igfxvesa" to my boot args. I hope there will be some way to be able to remove this later, once everything is installed. I'd love to hear more about this if anyone has any insight. But anyway, onto the real problem.

 

Now I can get to the installation screen, but I'm stuck without a working keyboard and mouse. I've tried with and without USBInjectAll.kext and XHCI-unsupported.kext, making sure to update my config.plist with each new combination, but no luck. I've tried moving the peripherals to different USB ports, but got the same result each time. I've tried with Big Sur and Catalina, but both behave the same way. XHCI handoff is enabled in my BIOS, and all of the other recommended settings are as close as I could get them, based on the OpenCore Dortania guide. 

 

I didn't see any obvious errors in the logs, but I'm not really sure what I'm looking for, to be honest. My hardware is as follows:

 

MB: AsRock B560m-HDV (I think this might have been a mistake, but I can't afford another new MB)

CPU: Intel i3-10100

RAM: 2 x 16gb DDR4-3000

GPU: No dGPU, only onboard Intel UHD 630

SSD: WD SN550 500gb

WIFI/BT: N/A

OS: Big Sur (I tried Catalina too) 

Bootloader: OpenCore 0.6.7 (DEBUG)

 

I'm also attaching my (sanitized) EFI folder here. I would really appreciate any help. Thank you in advance!

 

EFI.zip

i used SSDT-USB-Reset.aml 

removed SSDT-RHUB.aml

enabled USBInjectAll.kext 

removed XHCI-unsupported.kext

 

i have the same board and managed to get through the installation by doing the above.  my problem is framebuffer settings and for now also using igfxvesa flag.. let me know if you get past your usb issues. 

 

Edited by eXwhY
On 3/26/2021 at 9:48 PM, zmian said:

I'm not sure where to get SSDT-USB-Reset.aml from. Do you have any pointers?

 

i just found it in the results folder when I used SSDT time.   https://dortania.github.io/Getting-Started-With-ACPI/ssdt-methods/ssdt-easy.html#so-what-can-t-ssdttime-do . I'm not really that familiar with it to know whether mine will work with yours coz my CPU is 10400 and 10400F. but just in case, i am attaching mine. 

SSDT-USB-Reset.aml

  • 2 weeks later...

Sweet, that worked! I ended up creating my own SSDT-USB-Reset.aml by running SSDTTime. Had to install Windows just for that, but it worked out. Thank you :)

Currently installing right now. Did you ever get the display issue figured out?

  • 2 weeks later...

I've tried dozens and dozens of different configurations trying to get the framebuffer working. Tried 0x3E9B0007 and 0x3E9B0000 as framebuffer, with 0x9BC8, 0x3E9B, 0x3E98, etc. as the device-id. Tried connector mapping, tried patching bus-ids. Tried all sorts of stolenmem and fbmem settings. So far nothing has worked at all.

 

The best I've been able to manage is to see that the Intel driver is attached to the PCI device when I connect over VNC, but nothing out of any of the connectors at all. Still stuck using VESA mode if I want to see any output on my monitor.

 

If anyone has any luck with Comet Lake UHD 630, please let me know.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...