Jump to content

New Hackintosher, really struggling here...


6 posts in this topic

Recommended Posts

Hi all, 

 

I'm not sure if I'm formatting my requests poorly... I've started another thread previously and not getting much help. I see a lot of very patient and helpful responses to other noobs. Please let me know if there's any way I can provide better info on my machine's issues:

 

I finally got my machine running, but it's down again after an attempt to install my new sapphire vega 64 gpu. I followed AudioGod's latest guides for Clover and was able to install Catalina. The only issue I was having was that bluetooth was working fine for 15 min or so and then stopped working. If I tried to go into bluetooth or airdrop sys prefs it would freeze the machine. I was planning to try and get a custom DSDT but wanted to wait for the GPU install

 

When I attempted to install the vega 64, I disabled the internal gfx card at one point, but realized that was not necessary so I re-enabled it. I double checked that I grabbed the correct EFI that was for vega cards. I had previously removed  agdpmod=pikera from the boot args (when I was using only the IGPU), but tried re-adding it. Throughout my trouble shooting ended up getting stuck in quite a bit to the point that bios was freezing So I had to clear the cmos and reset bios settings. Now I've removed the Vega 64, put all settings back to the way they were, but can no longer get into catalina.

 

Here's my EFI  - I believe the only thing I changed was adding usbinjectall to get my keyboard working

I'm on F12J bios from audiogod with the recommended bios settings.

 

What it's currently doing - zooming through the terminal lines in verbose, no clear indication of errors, and then Internal gfx shuts off and monitor loses signal. I can t 

Here's a video of the verbose log

 

MB: Aorus Z390 pro wifi 

CPU: Intel i9-9900k 

RAM: 2 x 32GB HyperX Predator RBG 3600MHz DDR4 

GPU: Radeon Sapphire RX Vega 64

SSD: Samsung EVO 970 Plus 2TB

WIFI/BT: Fenvi T919

OS: Catalina 

Bootloader: Clover 

 

 

thanks so much!

Don't worry, it's always frustrating at the beginning, there are a lot of things that can go wrong, that's why it's a hack(intosh.)

 

I don't have a Z390 board, but there are good guides for it using both Clover and OpenCore;

 

https://www.insanelymac.com/forum/topic/337837-glasgoods-macos-mojave-successguide-for-aorus-z390-pro/

 

https://github.com/vpoola88/gigabyte-z390-i-aorus-pro-wifi-hackintosh

 

https://github.com/cmer/gigabyte-z390-aorus-master-hackintosh

 

To start though there are a few things you can clean up that may help. The USB patches in your config.list and the USBInjectAll.kext are trying to do the same thing. I don't know if that's creating a conflict. Creating a USBmap.kext is best, https://dortania.github.io/OpenCore-Post-Install/usb/intel-mapping/intel.html provides an excellent guide which works for Clover and OpenCore. To start though try one or the other, or perhaps neither to start. Same applies to the SSDT-6-A M I.aml in the ACPI folder, that's also for USB (try without it as well.)

 

Unless you have some custom patched applied to the DSDT.aml I would remove it. Clover will apply the DSDT patches you have entered in the config.list on the fly at boot to the info it extracts from the bios.

 

-wegnoegpu should likely go if you are sticking with the Vega. It may be easier though to get it running with the internal graphics and then start adding extra layers of possible hardware problems. Otherwise the Vega should work well.

 

You may want to try removing the OcQuirks.efi, OcQuirks.plist and OpenRuntime.efi. Those are features from OpenCore brought over to Clover to deal with Big Sur. You shouldn't need them for Catalina.

 

Bios resets are typically a RTC issue. That may be coming from a bad DSDT. Check what patches some of the others with a Z390 have used.

 

Less is usually more at this point, get it booting, then fix the outstanding issues.

 

The smbios Macmini 8,1 you've selected is a bit odd. Again I'd have a look at the smbios used by others with the Z390. I see a bunch of other users going with iMacs for the smbios.

 

It looks like you are pretty close already though, good luck.

 

 

 

 

Hey J Lamp!

 

Let me know if I can buy you a beer or a kombucha or something :D I tried working through a bunch of your suggestions and got the system back up and running. Still having some issues though. After 20 min to an hour the machine freezes. I'm not sure if it's a time thing or it's tied to certain processes. It's been happening while I'm using sketchup. I'm also playing music through an external audio (m audio) box. It also freezes sometimes when I open the system report. Also the bluetooth is buggy. sometimes airdrop says it's working but the file doesn't actually go through. Also bluetooth mouse and keyboard (one uses a dongle, one does not) are both a bit glitchy and stop working after a while. I went and found some additional fenvi drivers and put them in my efi folder, but they don't seem to have solved the issue. 

 

Is there a way to generate a report to try and hone in on why it's freezing like this?

 

Also attempted to follow a few guides on usb mapping, but their mobos were so different than mine, it didn't really add up - it seems like I can barely have any ports working as they all count as two. And hackintool was misreading the type of port on many of them - is that normal? 

 

Here's a link to my hackintool usb ports (not the map version just a live view) and my new efi: https://drive.google.com/drive/folders/1vR4NSIde9Sk-yUZYMCnuBSIID5rdS4B7?usp=sharing

 

 

@jmills0823 - Hi take a look here - This guy took over the thread from Glasgood and he knows his stuff on the Gigabyte z390 pro and pro wifi including USB port mapping, as a matter of fact on the Thread he has fully working EFI Folder examples all you need to do is enter your own data (S/N, ROM SmUUID etc) in the config.plist and he even indicates where the data should be entered in the config.plist all you'll need to do is to pick an EFI Folder to suit your specs or your needs. Good luck.

 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...