Jump to content

Filevault stops system occasionally for about 30 seconds


6 posts in this topic

Recommended Posts

Hi guys, I have an annoying problem with Filevault. If I use the system without Filevault enabled, everything runs smoothly. If I enable Filevault, I get occasional system freezes with spinning beach ball that last about 30 - 60 seconds. Afterwards everything continues to work fine until the next freeze. The freezes seem to occur at times of high I/O usage, i.e. copying of large files to the system drive etc. The freezes occured on every Catalina Version I used: 10.15.4 - 10.15.7.

 

If I had to guess, I said that maybe Filevault did not envrypt the whole drive but instead did some sort of quick format and the freezes are the times when it has to encrypt the particular region on the drive the data should be written to. On the other hand, enabling Filevault takes about an hour and it says specifically that the system drive is encrypted at that time, so I would not expect that it was a quick format.

 

Or, maybe, Filevault has some sort of behavior that checks permissions and stuff with the system until it allows data to be written?

 

Did anybody see this kind of freeze as well?

Link to comment
Share on other sites

You didn't mention your specs, bootloader, etc. 

 

I assume you're using Clover. 

 

The problem mentioned here: 

If you follow up the problem on the same page, you'll find the solution:

Download AppleUiSupport.efi (and if you use PS2 keyboard then AppleKeyFeeder.efi too), delete all your FileVault drivers and add only these two files. 

Edited by kushwavez
Link to comment
Share on other sites

I am not sure that is the same problem as mine. I had the terribly slow boot, too, when I first installed Catalina but I solved this as you suggested by deleting the Filevault drivers and adding AppleUISupport. The version installed on my system right now is exactly the same as the one in the GitHub archive you linked.

 

My problem is different as the system boots fine but hangs occasionally while I am using it.

Link to comment
Share on other sites

Oh I see, I misunderstood then, sorry, but at least the enormously long boot time is solved.

 

You still didn't mention your specs and bootloader, but I think the problem has nothing to do with FileVault if you are using the right drivers for it.

I have FileVault enabled myself on all of my hacks on Clover, I had no such problems with it.

 

As for your guess, I can't really explain well how it works, but no, it's not encrypting your data if you're copying, so it should be not a problem.

FV encrypts your whole drive at once, and it's decrypting your drive once you boot from it. So if you're in the system, it's in decrypted state.

Edited by kushwavez
Link to comment
Share on other sites

My bad, forgot my specs: Clover 5107, Haswell CPU, Gigabyte Z87-G43 MB, R290X graphics. Clover is not up to the current version. Since updating to 5130 would take more than just a litte config tweaking, I will move to OC at last. I wanted to use OC for a while anyway and just did not find the time. But now I have to work on it either way, so this is the time for a complete overhaul. Hopefully this will fix the system hangs.

Link to comment
Share on other sites

 Share

×
×
  • Create New...