Jump to content

WAKE WITH ONE KEY PRESS BIG SUR NOT WORKING. HELP !!!


dMatik
 Share

3 posts in this topic

Recommended Posts

Hi all, so I'm running Big Sur 11.2 on an Asus x99 Deluxe (msr unlocked and nvram whitelist patch applied to the bios) with an Intel 5820k and RX580 video card. All is working flawlesly but there is something I can't figure it out. On MacOS catalina and earlier, using darkwake=1 or darkwake=2 boot arg, when hack was sleeping with one single keyboard or mouse or power button key press the display came alive, after updating to big sur, i need two key strokes, two mouse button push or two power button push, the first triggers darkwake as seen from log and the second triggers darkwake to full wake. I can replicate this behavior on macos catalina by using darkwake=3 or no darkwake boot arg.

 

After trying darkwake=0, darkwake=1, darkwake=2 and wasn't working, i've tried to add wake type property to my xhc device (witch u can see in my custom dsdt), doesn't work either. After that tried to create a fake acpi device and use usbwakefixup.kext, and, no success, still need one keypress to wake the system and another one to wake the monitor. (I have to mention, the latter two work on catalina without any darkwake argument, one key press, system wakes and display is on)

 

Done some digging and found the "darkwake deciphered post" in witch there was a code snipped from iopmrootdomin.cpp but the guide is based on old code.

 

The IOPMrootDomain.cpp code from the guide (idk what xnu vers):

 

// gDarkWakeFlags
enum {
	kDarkWakeFlagHIDTickleEarly      = 0x01,// hid tickle before gfx suppression
	kDarkWakeFlagHIDTickleLate       = 0x02,// hid tickle after gfx suppression
	kDarkWakeFlagHIDTickleNone       = 0x03,// hid tickle is not posted
	kDarkWakeFlagHIDTickleMask       = 0x03,
	kDarkWakeFlagAlarmIsDark         = 0x0100,
	kDarkWakeFlagGraphicsPowerState1 = 0x0200,
	kDarkWakeFlagAudioNotSuppressed  = 0x0400
};

Now i've entered in terminal uname -av to see what xnu version bigsur 11.2 uses and is :xnu-7195.81.3~1/RELEASE_X86_64 x86_64, found the file here " https://github.com/apple/darwin-xnu/blob/main/iokit/Kernel/IOPMrootDomain.cpp " and is seems there are some changes

 

// gDarkWakeFlags
enum {
	kDarkWakeFlagPromotionNone       = 0x0000,
	kDarkWakeFlagPromotionEarly      = 0x0001, // promote before gfx clamp
	kDarkWakeFlagPromotionLate       = 0x0002, // promote after gfx clamp
	kDarkWakeFlagPromotionMask       = 0x0003,
	kDarkWakeFlagAlarmIsDark         = 0x0100,
	kDarkWakeFlagAudioNotSuppressed  = 0x0200,
	kDarkWakeFlagUserWakeWorkaround  = 0x1000
};

Even tried darkwake=4096 and still no success.

 

I'll attach my efi with another mlb/serial/rom changed, maybe is something wrong with my dsdt but tried even without it and hotpatch via ssdt and same behaviour.

 

Here is a snipped from the log yesterday, first two lines are the first keypress and the third is the second key press when the display wakes up.

 

2021-02-03 13:54:20.345292+0200 0x75       Default     0x0                  0      0    kernel: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: ?
2021-02-03 13:54:20.345293+0200 0x75       Default     0x0                  0      0    kernel: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: ?
2021-02-03 13:54:31.368148+0200 0x395      Default     0x0                  67     0    powerd: [powerd:sleepWake] Wake reason: "<private>"  identity: "<private>"

Also my sysyem never reports "wake reason" from xhci device, that was the behaviour since el capitan, maybe someone knows why, idk.

 

So I'm stuck, hope to find some help here, thank you all for your time!

 

 

 

 

EFI.zip

Link to comment
Share on other sites

I don’t think anybody knows of a fix for that I’m afraid.

Nothing works to resolve usb wake issues under Big Sur so until the OC team come up with a fix for it your just going to have to get used to it and click that mouse twice.

  • Like 1
Link to comment
Share on other sites

same, not such a big issue but tought someone found something about it to pin point it out. Something has changed for sure, I also have a genuine macbook pro 11.1 and that kid is waking from sleep waay faster than in catalina. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...