Jump to content
7 posts in this topic

Recommended Posts

The recent website update has broken intra-site links.  Prior to the update, the links were specified as

 

Before Update: https://www.insanelymac.com/forum/topic...

 

After the update, links became

 

After update: https://www.insanelymac.com/topic...

 

'/forum' was dropped from the updated links.

 

It looks like the fix should be to restore '/forum' to the links where '/forum' is missing.  Note that this fix should only be performed for intra-site links and not for links that reference locations external to insanelymac.

On 1/5/2021 at 8:15 PM, tonyx86 said:

The recent website update has broken intra-site links.  Prior to the update, the links were specified as

 

Before Update: https://www.insanelymac.com/forum/topic...

 

After the update, links became

 

After update: https://www.insanelymac.com/topic...

 

'/forum' was dropped from the updated links.

 

It looks like the fix should be to restore '/forum' to the links where '/forum' is missing.  Note that this fix should only be performed for intra-site links and not for links that reference locations external to insanelymac.

I agree, still a few gremlins to be sorted and remove.

The broken links problem is still present and should be VERY EASY to fix.  Since I imagine the CMS for this site stores everything in a database (probably mySQL or similar), someone needs to write a script that looks for '/insanelymac.com/topic' and replaces it with /insanelymac.com/forum/topic'. There are many once-useful posts that are no longer helpful because their embedded links are broken.

Edited by tonyx86

Some of the download links that are embedded in posts are broken, too.  I manually fixed some of these by deleting the download link (leaving the attachment) and saving the post.  The re-created link (after saving the post) is fixed.

  • 2 weeks later...
On 1/21/2021 at 7:51 PM, Poco said:

Most links should now be fixed :)

 

Can you link an example of the attachments issue? I think I understand but want to be sure

Sorry for the late reply - I didn't realize that you had responded.  I corrected the broken download links that I found in some of my own posts.  If I stumble upon another one, I will post it in this thread as an example.  Thanks for attending to this!  Great job with the site - it is a pleasure to use now!

×
×
  • Create New...