Jump to content

OpenCore multiboot from different drive


5 posts in this topic

Recommended Posts

Hi! I'm trying to migrate from Clover to OpenCore and now stuck with main partition not showing in OpenCore.

I have non-trivial setup on my laptop with SSD and HDD on it. On SSD I have Windows EFI partition and both Windows and macOS bootable partitions. On HDD I have Clover EFI partition and other non-bootable partitions.

Such setup worked well as Clover was magically finding both Windows and macOS on SSD. But this seems to not work for OpenCore. It shows Recovery partition and some Install left-overs on SSD, but not my main system.

I tried to set OpenCore on HDD EFI and on external USB EFI - same result.

In Clover for tricky cases was an option by adding boot partition by UUID. I was thinking about adding custom Entry to the config.plist of OpenCore, but there is no .efi file on my system partition...

Any suggestion are highly appreciated!

Edited by dandepeched

SOLUTION:

I boot to installation USB drive which sees my system partition properly and then selected Startup Partition menu and choose my system drive. This added "MAC_SSD - Data via Preboot" entry to Clover and to OC! I was able to boot after this.

  • Like 1

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...