Jump to content
rajkhand

Latest kext updates Breaks Wifi - and/or Sound BT BCM4352

2 posts in this topic

Recommended Posts

I am on OC 0.6.3 and everything was working perfectly. boot args = brcmfx-driver=2 shikigva=80 alcid=7 -v

My Wifi/BT Broadcom card

Device Name : BCM4352 also known as Dell 1560

IOReg IOName : pci14e4,43b1

 

Then came updates of

AirportBrcmFixup 2.1.2

AppleALC 1.5.5

Lilu 1.5.0

VirtualSMC  1.1.9

WhateverGreen 1.4.5

 

With this the BT stopped working also it will take 7-8 minutes to boot. I tried different combination of old and new kext and now with old version of lilu and appleALC everything works.

with new Lilu and appleALC there is no sound device.

 

I tried this combination with OC 0.6.4 and it will not recognise the wifi/BT and Sound will be dead and will take again 10+ minutes to boot. If I remove AirportBrcmFixup 2.1.2 and all the BRCM BT kexts and keep above mentioned new kexts then there will be no wifi or BT but it will boot fast not sure about sound as this (OC 0.6.4) I am experimenting on the bootable Big Sur 11.0.1 USB install stick.

 

What is happening? I am afraid to experiment more as now there is no bootable clone drive possible with CCC or superduper

 

any solution???

Share this post

Take the alcid=7  out of your boot arguments and patch AppleHDA with AppleALC and the OC conifg DeviceaProperties for your sound hardware.

 

make sure layout-id is lower case.

 

If you have linux installed you can run lspci-k to see your layout.  If not you can use a live linux ISO or live linux USB.

 

Make sure lilu is loading first and that the broadcom kexts load in the proper order.

Edited by HenryV
Share this post

×