Jump to content

update to Big Sur 11.1 not available for 11.0.1 vmware workstation 16 guest?


5 posts in this topic

Recommended Posts

Hi all!

 

Since Apple released Big Sur 11.1 a few days ago, I've tried to trigger the update by opening the apple menu and therein clicking the update button.

 

But after the dialog finishes searching I get the message that I'm using the latest version available.

 

I suspect that the update mechanism somehow tries to find out which mac hardware I'm having and denies the update because it does not meet the requirements.

 

Has anyone successfully updated a wmware workstation 16 big sur 11.0.1 guest to 11.1? If yes how?

 

Thanks in advance.

 

Best regards

Me

 

Edited by level4200
  • Thanks 1

Yes, works here - in fact it even shoves unwanted, newer macOS Big Sur 11.2 Betas onto me now too. :) (somehow, this happens despite me disabling Beta updates in Software Update left hand pane)

 

Please note I had the same OR very similar issue to yours.

Originally, I got Big Sur Beta by upgrading from an older 10.13 High Sierra macOS VM of mine to Big Sur Beta -- I did not use the way of downloading a pre-prepared Big Sur Beta VMware disk file from a strange person on the Internet (which I did use sometimes in previous years with some previous macOS Betas) - and due to this did NOT originally do the VMX file changes mentioned below, because I thought I may not need them at all.

However, then at some point of my Big Sur Beta usage it stopped offering new Betas to me, saying the old version I had is latest - despite several NEW Betas having come out since.

So, then I did those VMX file edits below, and at once macOS Updates started working/showing as expected again. :) 

 

What is your Host OS, please - Windows 10/8.1/7, OR also MacOS?

 

If running Windows OS as Host OS -->

* Make sure latest/working macOS Unlocker is (re)installed. I am using the BDisp variant here.

 

* Do the VMX edits listed here -- Step 5: Edit macOS Big Sur VMX File

https://www.wikigain.com/install-macos-big-sur-on-vmware-windows-pc/

 

Then see it works. :) Please tell us how it goes. Please tell me if something is not clear.

Edited by Naki

Thank you @Naki for your help!

 

Meanwhile I've found out that I had to search Big Sur in the app store and load the update to 11.1 offered there.

 

I'm on Windows 10 Enterprise LTSC 2019 with VMware workdation 16.1.0 and unlocker installed running on an Intel 10900X CPU. Installation of Big Sur 11.0.1 worked without the need to manually modify the vmx file, just by selecting mac OSX as the operating system in the new virtual machine wizard of VMware and afterwards selection the latest OSX version 11.1.

 

But thank you fro the link. I'll try those modifications, especially hw.model and board-id to see if 11.1 would have been offered if I do so.

 

  • Like 1

I've manually modified the vmx file by adding

hw.model = "MacBookPro14,3"
board-id = "Mac-551B86E5744E2388"

and restarted the virtual machine, and yes, now I've been offered the update to Big Sur 11.1 without going into the app store!

 

So it seems that the updater checks explicitly for supported hardware, where the app store OSX updater doesn't.

 

Another test by only setting

hw.model = "MacBookPro14,3"

is not sufficient! So the board-id is what is needed. Starting over again with

board-id = "Mac-551B86E5744E2388"

led to the updater showing the 11.1 update.

 

Edited by level4200
  • Thanks 1

Great! :) Thanks for the detailed feedback. You are welcome.

I am glad the VMX edits suggested allowed your macOS VM to see/offer the latest 11.1 update. :) 

Edited by Naki
×
×
  • Create New...