Jump to content

Mac Pro 2019 with RTX 3090 sleep issues


7 posts in this topic

Recommended Posts

Hi everyone,

 

I'm running Big Sur on a Mac Pro 2019 with a W5700X and a recently added RTX 3090 to use in Windows. Big Sur apparently ignores the RTX until I try to put the Mac to sleep, which causes a crash.

 

Is there any way to disable a PCI-E slot on MacOS so that the RTX is invisible to macOS?

 

Thanks,

Alex

To my knowledge, this has been a known issue for a while, that some external GPUs will crash on sleep mode. I've seen posts say it's been a problem since 2010.

 

As an immediate workaround, I'd recommend disabling Sleep Mode in macOS and not use it whenever possible.

Open System Preferences > Energy Saver, and there, you'll find the settings to disable Sleep Mode.

 

Assuming you're using a Hackintosh and not an honest-to-goodness Mac Pro with Windows on BootCamp, I found a couple guides to disable unsupported GPUs in macOS.

The guides are rather involved, but I trust that they'll work, should you decide to use one of them.

Clover: https://www.reddit.com/r/hackintosh/comments/bu1wf8/how_to_disable_your_unsupported_gpu_for_macos/

OpenCore: https://dortania.github.io/Getting-Started-With-ACPI/Desktops/desktop-disable.html#finding-the-acpi-path-of-the-gpu

 

Until next time, stay foxy!

Yep, it's an honest-to-goodness Mac Pro :). Sometimes I wish I'd gone the hackintosh route. I use macOs 80% of the time and I use Windows when I need to do some CUDA related stuff or gaming.

 

Disabling sleep mode works, but I don't like to leave the Mac Pro on all night and I also don't like to have to do a shutdown, since it takes me a bit to get everything back to where it was (I use the Mac Pro as a development machine). Apple, being Apple, totally ignores my bug reports.

 

In that case, you *definitely* don't wanna mess with the Hackintosh guides I posted with actual Mac hardware; they'll probably brick your computer if you tried.

 

Apple basically dropped support for Nvidia GPUs within the past couple years. Nvidia GPUs still work on Macs, but nobody's making up-to-date official web drivers anymore. They also have no plans to patch any existing problems.

 

Here's another guide I found about sleep issues with genuine Macs, though a portion of it is about their laptops. It was written for Catalina, but it should work just as well in Big Sur.

https://appletoolbox.com/how-to-fix-catalina-crashing-in-sleep-mode-on-mac/

 

Since you have a Mac Pro, you should have an app called Expansion Slot Utility, which may be in Applications/Utilities. From what I've read about it, it's designed to let you allocate power to different expansion slots you're using. Perhaps there's a way to completely disable the GPU in there?

 

Another recommendation could be to reset NVRAM, which the guide linked a couple lines above should cover how to do.

 

How often do you switch between macOS and Windows? If all else fails, the only other workarounds I can think of are:
A: Keep not using Sleep Mode and only shut down the display when you're not using your Mac.

B: Downgrade back to Catalina if your sleep issues started in Big Sur
C: Physically remove the GPU before booting into macOS (which I know will be a pain)

D: Save up for a more compatible non-Nvidia GPU down the road. Based on my cursory research, the AMD RX 6800 XT seems pretty comparable to the RTX 3090. I personally have an AMD RX 5600 XT.

 

Definitely listen to an expert over me if someone else comes along in this thread, especially if they can help you without having to remove your GPU or buy a new one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...