Jump to content

Opencore 0.6.3 - 'device is write locked' after initial BigSur install


7 posts in this topic

Recommended Posts

I am trying a fresh clean USB install on a NUC5i5RYB and initial install steps go well. Installer boots and I format the SSD, files are copied and then the installer reboots as normal.

 

Open core picker shows the MacOS Installer on the SSD and I select that. After showing the apple logo it drops into verbose mode and displays the following.

 

'disk4: device is write locked.'

 

Shortly after that there is more verbose output and the installer reboots. I have attached a picture of what is displayed just before it reboots along with my EFI. 

 

Any ideas?

 

EFI.zip

IMG_4057.jpg

The relevant Error message ist this one: "IOConsoleUsers: gIOScreenLock.../gIOLockState (3..."

 

Check the OpenCore Troubleshooting guide:

https://dortania.github.io/OpenCore-Install-Guide/troubleshooting/extended/kernel-issues.html#stuck-on-or-near-ioconsoleusers-gioscreenlock-giolockstate-3

 

I see you are using a Desktop-EC.aml. But if I recall correctly NUCs should be configured following the Laptop Guide (Broadwell in your case)

The config doesn't look bad, though: https://opencore.slowgeek.com/?file=laptopbroadwell063uihVaf&rs=laptopbroadwell063

 

But for NUCs, SMBIOS iMac16,1 is suggested.

 

 

Edited by 5T33Z0
1 hour ago, 5T33Z0 said:

The relevant Error message ist this one: "IOConsoleUsers: gIOScreenLock.../gIOLockState (3..."

 

Check the OpenCore Troubleshooting guide:

https://dortania.github.io/OpenCore-Install-Guide/troubleshooting/extended/kernel-issues.html#stuck-on-or-near-ioconsoleusers-gioscreenlock-giolockstate-3

 

I see you are using a Desktop-EC.aml. But if I recall correctly NUCs should be configured following the Laptop Guide (Broadwell in your case)

The config doesn't look bad, though: https://opencore.slowgeek.com/?file=laptopbroadwell063uihVaf&rs=laptopbroadwell063

 

But for NUCs, SMBIOS iMac16,1 is suggested.

 

 

 

Thanks - I have tried the iMac16,1 SMBIOS and the laptop aml but alas the same issue persists. I will look into the gIOScreenLock.../gIOLockState as a potential source of the problem but I had gone over that once already.

 

Its interesting that I had this EFI running BS on this NUC in its current configuration. It was an SSD from another machine but I booted it on the NUC with the exact EFI I posted and it booted and ran fine. I just wanted to do a clean install on the NUC, previously the install was an upgraded beta that had been installed with the image method.

 

I will keep trying but its strange in how the EFI can boot an installed system and it can boot the installer just not the step in the middle!

 

16 hours ago, 5T33Z0 said:

@mickeyd453 The issue could be related to the Frambuffer Patch and the Memory allocated to it. I added these values to the framebuffer patch and also disabled secureboomodel for testing purposes. I've attached the edited config.

 

config.plist

 

Thanks for the tip - Before I saw your reply I decided to try something and it worked! Even thought I had repartitioned the drive and reformatted it I decided to completely destroy the drive with dd so there was nothing viable on the disk. I then re partitioned and formatted and started the install again and it worked! I didn't change the EFI config at all between the failure and the success just dd'd the disk. The drive was not locked to another Mac nor was it encrypted so I am unsure where the device locked was being generated from.

 

As another test once it was installed I ran the installer again, formatted the disk, but didn't destroy the partition table, and installed and it went through totally fine! All very odd but appreciate the help trying to debug. I put the original SSD back in that was running Catalina and did an in place upgrade all without a problem.

 

So here I am with my little NUC running BigSur and everything works, including the onboard WiFi which is a new development.

 

thanks again!

Screenshot 2020-11-19 at 13.21.12.png

Screenshot 2020-11-19 at 13.21.46.png

1 hour ago, 5T33Z0 said:

Nice that it worked. Are you using the new Kext for Intel Wifi?

 

What is DD?

 

Yes I used the itlwm kext and it seems to work well.

 

DD is a command that can copy data block by block. In my case I used it to copy blocks from /dev/random onto the disk so that I completely destroyed the partition table. I did this from the installer terminal with dd if=/dev/random of=/dev/disk0 and let it run for a few seconds then cancelled it.

 

I often used to use dd to backup my EFI partition when using Clover in legacy boot mode so that in case of emergency I could put everything back at the block level. In that case 

 

backup for me would be

 

sudo dd if=/dev/disk0s1 of=~/BACKUPS/clover-version.img

 

and if I wanted to restore that partition back I would

 

sudo dd if=~/BACKUPS/clover-version.img of=/dev/disk0s1

 

×
×
  • Create New...