Jump to content
Navaira

[FIXED] Lenovo Yoga C930 (8550u/UHD 620) Opencore No QE/CI – worked in Clover

7 posts in this topic

Recommended Posts

Hello,

 

I've spent two days on this and I'm getting desperate.

 

Specs: Yoga C930, 4k display, i7-8850u (Kaby Lake-R), UHD 620.

 

My Mojave install with Clover r5122 works very well. (I think linking to other forums is not allowed, but if you google "navaira c930" you'll find my guide...) Some functions are missing, mostly those related to Handoff/Continuity + the internal mic which will never work because thanks Lenovo, but it's been my daily driver for nearly two years now.

 

I decided to try Big Sur and upgraded Clover to r5126. Big mistake. Huge. I didn't know the changes would be so extensive. So, since I had to backtrack anyway, I decided to try Opencore. I used Dortania's guide + my own DSDT/SSDT files that I've been using in Clover. Installed Catalina first, just to make sure everything works before I move on to BS. I am 99% blown away. Everything works way better than with Clover – unlocking with Apple Watch, Continuity, bluetooth + wifi (Broadcom), trackpad (once I disabled Force Touch in System Preferences), sound... just not sleep (not a big problem) and acceleration (BIG problem).

 

The version of UHD 620 in this particular laptop is weird. In Clover I use fake-id 0x591B8086, ig-platform-id 0x591B0000, plus Inject Intel. It took me a while to figure out initially, but once I did, it worked – still does. OpenCore won't. Adding, as every guide for Kaby Lake UHD 620 recommends, device-id=16590000 stops the booting process at gIOscreenlockstate 3. I tried every combination I found online; added, then removed Framebuffer patches, then added them again with different values; using the Dortania guide I tried to "translate" Inject Intel. Right this moment I have the values in the screenshot, but they work just as well as all others, i.e. they don't. I have only managed to achieve three states: 1) it works without acceleration, 2) stops right before the login window at gIOscreenlockstate 3, 3) simply doesn't boot. 

 

Googling led me to finding a Reddit thread where the OP mentioned that CFG-Lock might be the culprit. That would be very bad, because Lenovo locked everything in the BIOS. If there is a key combo unlocking it, I failed to find it after having tried everything I found. But... how can Clover work then...? I don't have any graphics-related kexts in Clover, only Lilu + WhateverGreen (both load correctly in OC). Apart from the mentioned fake-id and ig-platform-id in Clover I only have the AAPL,GfxYTile=01000000 property, which I tried in OC as well and had as much success as usual, i.e. none. I looked up the path to the card in Windows – _SB_.PCI0.GFX0. Even copying all the graphics-related keys/values from Clover directly to OpenCore config.plist doesn't make a difference. The main thing I achieved through resetting NVRAM over and over and over in case that makes a difference was losing my Clover triple-boot every time.

 

As for the Big Sur installer, at this point it crashes before getting to verbose, so I'm focusing on getting Catalina to work first... If I can get the acceleration to work, I'll get rid of Clover completely. OpenCore is so much cleaner and, once I got through the first install, easier. Except that bit where the acceleration doesn't work.

 

Please help! I attach the OC config.plist. I'm glad to upload anything that can be of help, the Clover folder (not that it's super exciting), the OC folder, pictures of cats... 

 

Thanks so much in advance!

Screenshot 2020-11-15 at 23.19.45.png

config.plist

Edited by Navaira
Share this post

53 minutes ago, Hervé said:

If you faked IGPU id 0x591b8086 in Clover, then your OpenCore property injection for device-id should be:


device-id    1B590000    DATA

 

Thanks! Now the boot process stops with the gIOscreenlockstate 3, unfortunately.

 

What about the 8086 part?

Share this post

The 8086 part is not required in property injection, it's different from Clover's id faking.

 

Any way, you have a Kaby Lake Refresh i7-8850U with UHD 620 graphics. As such, I'm pretty certain you're using incorrect settings. I believe you should be injecting KBL layout 0x59160009 + IGPU id 0x5916 and patch your framebuffer DVMT + memory size to 19MB and 9MB respectively:

ig-platform-id 09001659
device-id 16590000
framebuffer-patch-enable 01000000 (or 1 with NUMBER)
framebuffer-stolenmem 00003001
framebuffer-fbmem 00009000

That's what I use successfully on my Dell Latitude 7490 fitted with Kaby Lake R i7-8650U CPU and Intel UHD 620 graphics.

 

You may then inject additional properties for display ports/connectors as/if required (eg: for HDMI output/audio).

Share this post

Hey Hervé,

 

I got stuck with:

 

Begin Gfx firmware load process

[...]

Hash data from ME never returned, status = 1, doing retry #

 

Can you tell me what your boot-args and SMBIOS are? I'm on MacBookPro14,1 and boot-args:

-v keepsyms=1 debug=0x100 -cdfon alcid=3

 

I saw advice to add -disablegfxfirmware to get rid of the Hash error, but the result is… see attachment. (Apparently it works for everyone else.) I think I'm disabling Intel, which leaves me with 0 GPUs. Awkward.

 

Adding -wegnoegcpu results in the second screenshot. Which looks…good? I hear the sound that normally means the charger is attached and the login window about to appear (in Mojave), but, well, it doesn't appear.

 

Would the 4K screen make a difference? I looked up your Latitude and it says it's a 1920x1080 display.

 

Thank you for helping with this.

IMG_0819.jpg

IMG_0820.jpg

Share this post

  • 1 month later...
On 11/16/2020 at 11:17 AM, Navaira said:

FIXED.

 

guide-dell-inspiron-15-7573-catalina-10-

 

I used this guy's config.plist Devices section and his boot args. The only thing I needed to do was replace 5916 with 591b in both platform-id and device-id.

 

RESUUUUUULT!!!! Thanks for taking the time, Hervé :)

Hello.

Can you please  post your EFI folder ?

Share this post

×