Jump to content

Navaira

Members
  • Content Count

    35
  • Joined

  • Last visited

About Navaira

  • Rank
    InsanelyMac Protégé
  1. Hello, I have a lovely install of macOS, Win 10, Ubuntu 18.04 all on one drive. And everything works. Almost. The presence of AptioMemoryFix.efi in drivers64UEFI breaks Ubuntu boot – it stops on purple screen and remains there ("ramdisk" error). When I remove AptioMemoryFix Ubuntu loads just as it should, but macOS doesn't. I tried all the OSXAptio* replacements, 1 and 2 cause immediate reboot, 3 causes problems – three out of four times I get the stop sign (and then on the fourth or fifth attempt it loads, which leads me to thinking the *order* of .efi files has something to do with it). Is it possible to either force Clover to NOT load AptioMemoryFix when booting Ubuntu or to load it ONLY when booting macOS? (Windows doesn't seem to care at all.) Thanks so much in advance for any response!
  2. Navaira

    AppleALC — dynamic AppleHDA patching

    Hello, may I join with a different problem or should I wait until macgeo's problem is solved? Sound card as displayed by Hackintool: Controller: Intel Sunrise Point-LP HD Audio (8086:9D71) Vendor: Realtek (0x10EC) Codec: ALC298 (0x0298) Layout ID: 29 Revisions: 0x100101, 0x100103 I am using AppleALC 1.3.4 + Lilu 1.3.1 in /L/E and AppleHDA. There are the following problems: – I had to use AppleHDA from 10.13.3 to get any sound at all – I need to do the following in order to inject the layout into AppleALC: insert (Clover/Devices/Properties) Devices: PciRoot(0x0)/Pci(0x1f,0x3) Properties: layout-id: 1D0000000 alc-layout-id: 1D000000 I know I'm not supposed to use alc-layout-id, but neither command line argument, nor Devices>Audio>Inject nor just layout-id work. Layout 29 is the one that works best. Speakers are quiet-ish, but with Boom 3D they work well enough. Headphones out is BOOMING (Boom 3D doesn't seem to have an option for disabling itself when headphones are being used). Neither internal nor external (in AKC headset that came with a Samsung S9 phone) mics work, even though they are displayed in sound properties. Other layouts that work are 3 and 66 (no microphone detected). I tried to use the Hackintool patches, both with Spoof Audio Device ID and without. No dice. Only AppleHDA from 10.13.3 and alc-layout-id give me sound. Adding or removing CodecCommander doesn't change anything. Attaching IOReg.zip. Thanks a lot for any help! ioreg_manual.zip
  3. Oh I am glad you fixed it – can you tell me what exactly you have done?
  4. Since I just had a pleasure of post-wake crash, here's the log: Anonymous UUID: Wed Sep 30 19:31:22 2015 *** Panic Report *** panic(cpu 6 caller 0xffffff801152a2be): "a freed zone element has been modified in zone kalloc.64: expected 0xffffff805198d240 but found 0xefffff805198d240, bits changed 0x1000000000000000, at offset 0 of 64 in element 0xffffff805198d3c0, cookies 0x3f0011eda1df7c78 0x535219ccbab2525"@/Library/Caches/com.apple.xbs/Sources/xnu/xnu-3247.1.106/osfmk/kern/zalloc.c:496 Backtrace (CPU 6), Frame : Return Address 0xffffff920440ba90 : 0xffffff80114e5357 0xffffff920440bb10 : 0xffffff801152a2be 0xffffff920440bb80 : 0xffffff8011529a0e 0xffffff920440bbc0 : 0xffffff8011528b82 0xffffff920440bcf0 : 0xffffff8011a3be0b 0xffffff920440bd10 : 0xffffff8011a3c8ea 0xffffff920440bd40 : 0xffffff8011a897d3 0xffffff920440bd70 : 0xffffff8011aa01ee 0xffffff920440bdc0 : 0xffffff8011aa1bfe 0xffffff920440bdf0 : 0xffffff8011a9c5e6 0xffffff920440be50 : 0xffffff8011aa9e72 0xffffff920440be90 : 0xffffff8011aa9058 0xffffff920440bec0 : 0xffffff8011a9bd4d 0xffffff920440bf00 : 0xffffff8011aa9b10 0xffffff920440bf40 : 0xffffff8011ab5091 0xffffff920440bf80 : 0xffffff8011ab5186 0xffffff920440bfb0 : 0xffffff80115d14b7 BSD process name corresponding to current thread: kernel_task Boot args: nvda_drv=1 kext-dev-mode=1 csr-active-config=0x67 darkwake=0 Mac OS version: 15A282a Kernel version: Darwin Kernel Version 15.0.0: Wed Aug 26 16:57:32 PDT 2015; root:xnu-3247.1.106~1/RELEASE_X86_64 Kernel UUID: Kernel slide: 0x0000000011200000 Kernel text base: 0xffffff8011400000 __HIB text base: 0xffffff8011300000 System model name: iMac14,1 (Mac-031B6874CF7F642A) System uptime in nanoseconds: 8269549434455 last loaded kext at 2981596278755: com.apple.filesystems.udf 2.5 (addr 0xffffff7f9428b000, size 266240) last unloaded kext at 214125657999: com.apple.driver.AppleUSBMergeNub 900.4.1 (addr 0xffffff7f92a70000, size 12288) loaded kexts: com.nvidia.CUDA 1.1.0 com.nvidia.web.GeForceWeb 10.0.7 com.nvidia.web.NVDAGK100HalWeb 10.0.7 com.nvidia.web.NVDAResmanWeb 10.0.7 com.no-one.BrcmPatchRAM2 2.0.0d1 com.wibu.codemeter.driver.CmUSBMassStorage 5.20.71 org.rehabman.driver.FakePCIID 1.2.0 org.netkas.driver.FakeSMC 1372 org.tgwbd.driver.NullCPUPowerManagement 1.0.0d2 com.apple.filesystems.udf 2.5 com.apple.filesystems.msdosfs 1.10 com.apple.driver.AppleBluetoothMultitouch 90.3 com.apple.filesystems.autofs 3.0 com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 4.4.0f4 com.apple.driver.AppleHDA 272.50 com.apple.driver.AppleUpstreamUserClient 3.6.1 com.apple.driver.AppleMCCSControl 1.2.13 com.apple.driver.pmtelemetry 1 com.apple.iokit.IOUserEthernet 1.0.1 com.apple.driver.AppleOSXWatchdog 1 com.apple.iokit.IOBluetoothSerialManager 4.4.0f4 com.apple.Dont_Steal_Mac_OS_X 7.0.0 com.apple.driver.AppleHV 1 com.apple.driver.ACPI_SMC_PlatformPlugin 1.0.0 com.apple.driver.Apple16X50ACPI 3.2 com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0 com.apple.iokit.SCSITaskUserClient 3.7.7 com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1 com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0 com.apple.BootCache 37 com.apple.iokit.IOAHCIBlockStorage 2.8.0 com.apple.driver.AirPort.Brcm4360 1000.12.1a21 com.apple.driver.AppleAHCIPort 3.1.5 com.apple.driver.usb.AppleUSBEHCIPCI 1.0.1 com.apple.driver.AppleACPIButtons 4.0 com.apple.driver.AppleRTC 2.0 com.apple.driver.AppleHPET 1.8 com.apple.driver.AppleSMBIOS 2.1 com.apple.driver.AppleAPIC 1.7 com.apple.nke.applicationfirewall 163 com.apple.security.quarantine 3 com.apple.security.TMSafetyNet 8 com.apple.driver.IOBluetoothHIDDriver 4.4.0f4 com.apple.driver.AppleMultitouchDriver 304.9 com.apple.driver.AppleHIDTransport 5 com.apple.kext.triggers 1.0 com.apple.iokit.IOBluetoothHostControllerUSBTransport 4.4.0f4 com.apple.driver.DspFuncLib 272.50 com.apple.kext.OSvKernDSPLib 525 com.apple.driver.AppleSMBusController 1.0.14d1 com.apple.iokit.IOSMBusFamily 1.1 com.apple.iokit.IOAcceleratorFamily2 203.7.1 com.apple.AppleGraphicsDeviceControl 3.11.31 com.apple.iokit.IOSurface 108.0.1 com.apple.driver.AppleHDAController 272.50 com.apple.iokit.IOHDAFamily 272.50 com.apple.iokit.IONDRVSupport 2.4.1 com.apple.iokit.IOGraphicsFamily 2.4.1 com.apple.iokit.IOBluetoothFamily 4.4.0f4 com.apple.driver.CoreCaptureResponder 1 com.apple.driver.AppleSMC 3.1.9 com.apple.driver.IOPlatformPluginLegacy 1.0.0 com.apple.driver.IOPlatformPluginFamily 6.0.0d7 com.apple.driver.Apple16X50Serial 3.2 com.apple.iokit.IOSerialFamily 11 com.apple.iokit.IOSlowAdaptiveClockingFamily 1.0.0 com.apple.iokit.IOSCSIMultimediaCommandsDevice 3.7.7 com.apple.iokit.IOBDStorageFamily 1.8 com.apple.iokit.IODVDStorageFamily 1.8 com.apple.iokit.IOCDStorageFamily 1.8 com.apple.iokit.IOSCSIBlockCommandsDevice 3.7.7 com.apple.driver.AppleUSBAudio 301.52 com.apple.iokit.IOAudioFamily 203.8 com.apple.vecLib.kext 1.2.0 com.apple.driver.usb.IOUSBHostHIDDevice 1.0.1 com.apple.iokit.IOUSBMassStorageDriver 1.0.0 com.apple.iokit.IOSCSIArchitectureModelFamily 3.7.7 com.apple.driver.usb.AppleUSBHostCompositeDevice 1.0.1 com.apple.driver.usb.AppleUSBHub 1.0.1 com.apple.iokit.IO80211Family 1100.23 com.apple.driver.mDNSOffloadUserClient 1.0.1b8 com.apple.iokit.IONetworkingFamily 3.2 com.apple.driver.corecapture 1.0.4 com.apple.iokit.IOAHCIFamily 2.8.0 com.apple.driver.usb.AppleUSBEHCI 1.0.1 com.apple.iokit.IOUSBFamily 900.4.1 com.apple.driver.usb.AppleUSBXHCIPCI 1.0.1 com.apple.driver.usb.AppleUSBXHCI 1.0.1 com.apple.iokit.IOUSBHostFamily 1.0.1 com.apple.driver.AppleUSBHostMergeProperties 1.0.1 com.apple.driver.AppleEFINVRAM 2.0 com.apple.driver.AppleEFIRuntime 2.0 com.apple.iokit.IOHIDFamily 2.0.0 com.apple.security.sandbox 300.0 com.apple.kext.AppleMatch 1.0.0d1 com.apple.driver.AppleKeyStore 2 com.apple.driver.AppleMobileFileIntegrity 1.0.5 com.apple.driver.AppleCredentialManager 1.0 com.apple.driver.DiskImages 414 com.apple.iokit.IOStorageFamily 2.1 com.apple.iokit.IOReportFamily 31 com.apple.driver.AppleFDEKeyStore 28.30 com.apple.driver.AppleACPIPlatform 4.0 com.apple.iokit.IOPCIFamily 2.9 com.apple.iokit.IOACPIFamily 1.4 com.apple.kec.Libm 1 com.apple.kec.pthread 1 com.apple.kec.corecrypto 1.0
  5. pmset -g gives me this: AC Power -1* Currently in use: hibernatemode 0 womp 0 networkoversleep 0 sleep 0 Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage disksleep 0 displaysleep 15 Meanwhile the computer survived a few sleeps, including overnight, but then rebooted upon wake #4. Judging by what I have read here and elsewhere, my memory is to blame, as it's unsupported officially by my motherboard (Crucial Ballistix Sport 16 GB DDR3 BLS2CP8G3D1609DS1S00CEU). The PJALM repo sadly doesn't have a DSDT for my mobo nothing for Z97N, only Z97X.
  6. Done Sir! So far it survived a 5-minute sleep and a 3-hour one. Curious what happens when I put it to sleep for the night. Am I right that short sleep and long sleep should be the same with darkwake=0? (As in no activity at all during sleep) Edit: The Azurewave/BCM94352 appears as a USB device indeed, it's plugged into a half mini PCI Express slot.
  7. OK this is embarrassing but I just found that "allow Bluetooth devices to wake this computer" has somehow switched itself on... disabled it and now my Hac falls asleep and stays asleep. I might be back if things start popping up again but for now (extensive testing of 1 minute) it works Sorry.
  8. Oh, interesting. I started from Yosemite 10.10.5 and went through all public betas, then at the end with GM came out I installed that on top of everything. While I was using Yosemite sleep generally worked but every few days I'd get a memory leak and restart after a few minutes from the wake. Previous Cappy betas wouldn't even give me that much, restart on wake immediately.
  9. Hello, I'm running 10.11 GM on GA-Z97N-WIFI. Everything works perfectly well except sleep. When I put the machine to sleep, it wakes up again a few seconds later. The weirdest thing: I managed to put it to sleep a few times before, once it restarted upon wake, but now it just won't sleep no matter what I do. NullCPUPowerManagement makes no difference, that's as far as I could get on my own. Here's the log: Sep 28 15:01:03 Mac-Pro kernel[0] <Notice>: Wake reason: EHC2 Sep 28 15:01:03 Mac-Pro WindowServer[186] <Warning>: CGXDisplayDidWakeNotification [108063947057]: posting kCGSDisplayDidWake Sep 28 15:01:11 Mac-Pro kernel[0] <Notice>: ARPT: 116.278124: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake Sep 28 15:01:11 Mac-Pro kernel[0] <Notice>: ARPT: 116.778173: IOPMPowerSource Information: onWake, SleepType: Normal Sleep, Sep 28 15:01:11 Mac-Pro sharingd[335] <Notice>: 15:01:11.902 : Starting AirDrop server for user 501 on wake Sep 28 15:01:12 Mac-Pro ntpd[239] <Notice>: wake time set +0.648099 s So it looks like USB is the problem (or is it my network card?). Wake on LAN is off both in BIOS and System Prefs. I looked it up and apparently I need to do an edit on my DSDT. Problem is, I don't know how to do that. I looked at repositories with patches, but none seems to cover my model. And I don't know just from looking at those millions of lines of strange code what to do. Help? I attach my DSDT.aml. Thanks in advance for any help! DSDT.aml.zip
  10. Navaira

    Broadcom Bluetooth 20702A

    Thanks Artur, removed BTFirmwareUploader. Unfortunately there's no change (other than BTFirmwareUploader no longer displaying in system.log). Bluetooth is detected, appears on the top bar and in Preferences, Bluetooth Explorer sees it, System Report sees it, basically everything is tip top except for the fact my mouse is not detected and won't pair. *sigh*
  11. Navaira

    Broadcom Bluetooth 20702A

    I'm so relieved to see I am not the only one with this problem. I was using PB6 with perfectly working bluetooth, switched it off for the night, powered up in the morning and... no bluetooth. First the device was displayed, but wouldn't connect, then after I deleted the apple.Bluetooth.plist it wouldn't appear anymore. I hoped the GM would solve the problem, but, no. I guess that somehow the driver was cached somewhere and that's why it worked until, well, it stopped. My install on the other partition stopped working too. Checked the mouse, it's fine. Azurewave AW-CE123H, vendor: 0x13D3, product: 0x3404. Updated FakePCIID and other kexts, but I still get this in console output: Sep 10 22:37:31 localhost kernel[0]: BTFirmwareUploader :: Broadcom WiFi/BT combo Bluetooth controller found Sep 10 22:37:31 localhost kernel[0]: BTFirmwareUploader :: Failed to reset the device Sep 10 22:37:31 localhost kernel[0]: BTFirmwareUploader :: Failed to initialize the device. Edit: After much editing, updating and replacing, I have arrived at: Sep 11 14:59:11 localhost kernel[0]: BTFirmwareUploader :: Broadcom WiFi/BT combo Bluetooth controller found Sep 11 14:59:11 localhost kernel[0]: BTFirmwareUploader :: ProductID 0x3404, VendorID 0x13d3 Sep 11 14:59:11 localhost kernel[0]: BTFirmwareUploader :: Failed to initialize the device. Current kexts: bcm4352 3.2.0 BrcmBluetoothInjector 1.7.4 with USBDevice replaced by USBHostDevice BTFirmwareUploader 2.8.7 plus patch in FakeSMC as per artur-pt's post Bluetooth is listed both in Bluetooth section of System Report (software c4096) and in USB Hub. I'm kinda close to giving up on this (I constantly had problems with bluetooth and Magic Mouse) and buying iogear GBU521W6 – if only I could find out whether it works completely without drivers, injectors, patches, DSDTs etc...
  12. It definitely isn't part of the package. You'd either have to use "sudo trimforce enable" or install TRIM Enabler or similar app. (Here's the article about TRIM problems: http://www.digitaltrends.com/computing/samsung-ssd-bug-wiping-data/ ) Unfortunately I don't know what else could cause your problem
  13. Do you have TRIM on? I heard TRIM doesn't work well on Samsung EVO drives...
  14. Navaira

    trimforce

    From everything I have read, Trim Enabler does exactly the same thing as trimforce – activates Apple's internal TRIM routine, just in a different way. My guess would be that Trim Enabler checks the kext to be patched, finds it unpatched and throws its toys out of the pram. If your About This Mac > System Report > SATA/SATA Express says "TRIM Support: Yes" after running sudo trimforce enable, you don't need Trim Enabler anymore.
  15. Navaira

    10.10.4 final is out!

    I had to reapply Toleda's 5 GHz patch: https://github.com/toleda/wireless_half-mini/blob/master/wireless_bcm94352-90_patch.command.zip Hopefully now my wifi will stop disconnecting every five minutes... Edit: Yeah, that helped. Happy punter, me.
×