Jump to content

Please help with OC 0.6.3 based install on Gigabyte z97x Gaming 5


5 posts in this topic

Recommended Posts

So I've been using hackintoshes as my daily drivers for a long time now, first with chameleon then clover and now with OC, and this is the first time I've been really totally stumped. For example I'm posting this on my x570+3600 based ryzentosh, which seems very stable, and I maintain another half a dozen or so mostly Haswell era based hacks for friends and family. IOW not a newbie, but no pretensions to being any kind of expert!

 

System: Mojave 10.14.6 with OC 0.6.3 on a 4770K+ Gigabyte z97x Gaming 5 + 16GB /32GB Corsair Vengeance 1600MHz + RX580 4GB + Noctua air cooler + Fenvi t919

 

SSDT's from Dortania as pre-builts (may try to do it manually - though not been necessary previously)

Kexts loaded are Lilu, Whatevergreen, Atheros E2200 Ethernet, VirtualSMC (I did have other VirtualSMC kexts initially but removed them as part of troubleshooting)

 

With this Gaming 5 build I have actually managed to get through the install process and have - through multiple reboots - created a user account, the machine is still crashing within two minutes of logging in, often not getting even that far. Too short a time anyway to copy over the EFI to the boot volume, though I'm not sure I'd want to do that until it's far more stable. The problem is that this is happening after the verbose stage so I've very little to go on except the crash report, which again after multiple reboots I eventually managed to make a copy of. I will post this below, but I have searched for most of the terms in the report and most of the results reference real Apple machines crashing. NMI-ing reports various CPU's from 0 to 7 and other than searching enough to discover that this is very similar to panic reports from real Macs, I'm clueless to interpret anything else from the report.

 

 

Spoiler

*** Panic Report ***
Machine-check capabilities: 0x0000000000000c09
 family: 6 model: 60 stepping: 3 microcode: 39
 signature: 0x306c3
 Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz
 9 error-reporting banks
Processor 0: IA32_MCG_STATUS: 0x0000000000000005
 IA32_MC4_STATUS(0x411): 0xba00000052000402
 IA32_MC4_MISC(0x413):   0x0000000000000000
Processor 1: IA32_MCG_STATUS: 0x0000000000000005
 IA32_MC4_STATUS(0x411): 0xba00000052000402
 IA32_MC4_MISC(0x413):   0x0000000000000000
mp_kdp_enter() timed-out on cpu 0, NMI-ing
mp_kdp_enter() NMI pending on cpus: 0 1 2 3 4 5 6 7
mp_kdp_enter() timed-out during locked wait after NMI;expected 8 acks but received 1 after 33736957 loops in 1749996517 ticks
panic(cpu 0 caller 0xffffff80030dc51a): "Machine Check at 0x00007fff622324c3, registers:\n" "CR0: 0x0000000080010033, CR2: 0x00007fa247063a08, CR3: 0x00000007440330f7, CR4: 0x00000000001626e0\n" "RAX: 0x00007fa256510b70, RBX: 0x00007fff92d93198, RCX: 0x00007fff92d05df8, RDX: 0x00007fa25655a9a0\n" "RSP: 0x00007ffedfbfd870, RBP: 0x00007ffedfbfd890, RSI: 0x0000000000000000, RDI: 0x00007fff92d93198\n" "R8:  0x0000000000000000, R9:  0x0000000000000001, R10: 0x00007fff92d931c0, R11: 0x00007fa256421e00\n" "R12: 0x00007fff92d05df8, R13: 0x00007fa25655a9a0, R14: 0x0000000080080000, R15: 0x00007ffffffffff8\n" "RFL: 0x0000000000000202, RIP: 0x00007fff622324c3, CS:  0x000000000000002b, SS:  0x0000000000000023\n" "Error code: 0x0000000000000000\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-4903.271.2/osfmk/i386/trap_native.c:168
Backtrace (CPU 0), Frame : Return Address
0xffffff83b9583c00 : 0xffffff8002fae6ed mach_kernel : _handle_debugger_trap + 0x47d
0xffffff83b9583c50 : 0xffffff80030ea185 mach_kernel : _kdp_i386_trap + 0x155
0xffffff83b9583c90 : 0xffffff80030db8ba mach_kernel : _kernel_trap + 0x50a
0xffffff83b9583d00 : 0xffffff8002f5bb40 mach_kernel : _return_from_trap + 0xe0
0xffffff83b9583d20 : 0xffffff8002fae107 mach_kernel : _panic_trap_to_debugger + 0x197
0xffffff83b9583e40 : 0xffffff8002fadf53 mach_kernel : _panic + 0x63
0xffffff83b9583eb0 : 0xffffff80030dc51a mach_kernel : _panic_64 + 0xda
0xffffff83b9583fa0 : 0xffffff8002f5c39f mach_kernel : _hndl_machine_check + 0xf

BSD process name corresponding to current thread: com.apple.WebKit
Boot args: -v debug=0x100 keepsyms=1 alcid=1

 

 

The config plist I've created scores all green on Sanity Checker, though I've also checked manually at least a dozen times by now.

 

On the Dortania site the closest troubleshooting I can find relates to the https://dortania.github.io/OpenCore-Install-Guide/troubleshooting/extended/kernel-issues.html#macos-frozen-right-before-login

 

which relates to CpuTscSync, but I've tried adding this kext without any change i.e. nothing better, nothing worse. That's also after resetting NVRAM and of course doing new snapshots in ProperTree.

 

During the install phase the freeze would even so happen just as the progress bar ended, or when the welcome screen came up for country selection as per the photos. It maybe that the fix, which discusses Skylake, just isn't appropriate for Haswell era CPU's ?

 

Things I've tried: Tested the hardware very thoroughly on Windows and Linux, running games and stress tests - no problems whatsoever. I've also swapped around the RAM, varying slots and which of the four identical sticks I'm using (Corsair Vengeance 1600Mhz)

 

I had an older Mojave USB installer based on OC 0.5.8 - this gets the same result. I've taken another boot volume from another haswell build and this also crashes

 

Of concern is that there is no option to change CFG-Lock in the BIOS-UEFI, so I have changed the config.plist accordingly, ditto for VT-d. I've also tried with hyperthreading enabled and not. The BIOS is updated to F8a following a post I read warning of RAM related bugs in the original F7 BIOS that they didn't fix until after z97x had been replaced. Again I've not noticed any imporvement or worsening post BIOS update - though I was hoping for a CFG-Lock option to appear - which it didn't.

 

My best guess at first was the hardware since both motherboard and CPU were bought secondhand from a friend upgrading their gaming PC. But as stated in Windows it plays games as well as can be expected and gets comparable scores in Geekbench to other 4770K's - Other than XMP profile 1 there's no overclocking applied (yet) - and no, turning off XMP doesn't change anything either.

 

My next step is just to start from scratch with everything new, recreating the installer and formatting the drive, but I thought it best to ask here first to see if there's anything I'm missing? If I can supply anymore info just let me know? I've thankfully rarely had problems so I'm not very experienced at asking for help!

 

Lastly, though I've stuck with Mojave mostly because I occasionally use 32bit audio plugins, it struck me that most testing and development for Opencore is likely to be happening on at least Catalina, so I'd be interested if anyone thinks just switching to a newer OS that OC might be better optimised for is worth a shot? But that's really clutching at straws as I know I must have done something dumb but I'm just not seeing it!

 

cheers and thanks in advance

Thanks limurphy - had a look at the config and it's going to need a fair amount of tweaking but it's worth a shot even just to compare with a fresh vanilla install. It's worth just trying it to see what happens I guess :)

I'd really like to understand what I've been doing wrong though :)

So I took the EFI folder from amogh-w and changed the boot arguments because it's for an Nvidia GFX card and then added generated serials UUID etc. and it just freezes at exactly the same place :(

 

Apart from the nvidia boot argument it only has alcid=1 while I added debug=0x100 and keepsyms=1 with -v of course - maybe its worth trying without these arguments though he was booting High Sierra not Mojave.

 

There's also a few things that are "wrong" according to the Dortania guide such as AppleCpuPmCfgLock being set to True when that's not supposed to be needed post 10.10 - but I didn't muck about with it since it was worth a punt as is before trying to compare differencec between 0.5.9 and 0.6.3

 

Is there a way of rolling back the Dortania guide to read it as if for earlier versions?

 

Looks like I'm just going to have to start over from scratch.

 

Any ideas greatly appreciated.

looks like I messed about with this board's BIOS too much and it's bricked. I managed to get it into flashing its back up BIOS by shorting pins 1 and 6 after standard methods did nothing, but though the progress bar shows that something is happening the resulting restart just ends in a black screen with upper left white flashing underscore.

 

No idea what to try next :(

×
×
  • Create New...