Jump to content
Followers 0
silencer51

Kaby Lake R - UHD 620 & 4k laptop panel with modded BIOS

1 post in this topic

Recommended Posts

I have a modded Thinkpad T480 with the i7 8550u (Kaby Lake Refresh) with UHD 620. This laptop originally shipped with 1080p and 1440p panels, which work out of the box with MacOS provided one uses a proper platform and device id.

 

However, the bios settings for DVMT are locked at 32mb. Installing a 4k panel works fine with Windows & Linux, but not macOS.

 

I had to modify my bios using a CH341a SPI programmer to enable advanced settings and set DVMT to 64mb. That way, I can now boot macOS with acceleration at 4k HiDPI (looks like 1920x1080) but - at 40 or 48hz, depending on the custom EDID I inject.

 

I haven't managed to get 4k60hz working on the internal panel of this laptop. Even forcing the refresh rate via a custom EDID results in macOS loading, but the internal screen just shows the apple logo and loading bar, stuck on the screen from when acceleration kicks in during the second part of the OS loading process.

 

I keep wondering why that is - does it have to do with DVMT being still low for 4k60? I sadly cannot set it to 128mb in bios, even with mod. The similar hardware-wise T580 did originally ship with a 4k panel but it also only has a maximum DVMT value of 64 in the bios. From what I understand, 4k60 does work with macOS on the T580. So I'm trying to pinpoint the difference.

 

I've tried quite a few combinations of platform and device IDs, even set framebuffer-unifiedmem to 3GB, tried changing other graphics related bios settings (such as aperture size etc), but they made no difference. Is there something I'm missing?

Share this post

×