Jump to content
About Just Joined group Read more... ×

MSI X299 SLI Plus + BigSur Beta 6 + OC 0.6.1

4 posts in this topic

Recommended Posts

Hi everyone:


This is to report a success (!) in installing macOS Big Sur Beta 6 (version 20A5364e) on my system MSI X299 SLI Plus with Intel i9 9940X using OpenCore 0.6.1. I followed the main OpenCore guide here:


Make sure you look for the Skylake-X or HEDT sections.

The SMBIOS is for the iMacPro1,1.


There were two main issues that had to be taken care of:


* I needed the kernel argument 


otherwise USB would not work.


* I had to replace the precompiled SSDT-AWAC with my own RTC SSDT, as explained here:

The problem is that my SSDT does not have any AWAC to be patched. A sign that I needed this was that booting into the installer hanged around loading Lilu or some of the SMC extras.


The path to replace in the provided SSDT-RTC0 is:

** PCI0 -> PC00

** LPCB -> LPC0

This is probably specific to my motherboard. Instead of using the SSDT-AWAC, I use my own RTC0 like this:

DefinitionBlock ("", "SSDT", 2, "ACDT", "RTC0", 0x00000000)
    External (_SB_.PC00.LPC0, DeviceObj)    // (from opcode)

    Scope (_SB.PC00.LPC0)
        Device (RTC0)
            Name (_HID, EisaId ("PNP0B00"))  // _HID: Hardware ID
            Name (_CRS, ResourceTemplate ()  // _CRS: Current Resource Settings
                IO (Decode16,
                    0x0070,             // Range Minimum
                    0x0070,             // Range Maximum
                    0x01,               // Alignment
                    0x08,               // Length
                IRQNoFlags ()
            Method (_STA, 0, NotSerialized)  // _STA: Status
                If (_OSI ("Darwin"))
                    Return (0x0F)
                    Return (Zero)

Only the lines:

    External (_SB_.PC00.LPC0, DeviceObj)    // (from opcode)
    Scope (_SB.PC00.LPC0)

are different from the original SSDT-RTC0 here:


By following the guide above and implementing these two differences, I was able to install macOS Big Sur beta 6.


Big thanks to the amazing OpenCore team for allowing this. Not only the complete tools, files, binaries, are fantastic, but the manual is amazing!


Edited by slurpi
extra info on the need for RTC

Share this post

Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
      -USB Port Mapping TUTORIAL-
        1 -Create a USB bootable
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
      Big Sur
      Credits: crazybirdy
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
      Big Sur
      If you want check one step by step, check here
      -Opencore Vanilla Tutorial
      2- EFI folder USB installation
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      3- EFI folder SSD
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      4- Start Fine Tune
      Run this app and post full dump here for full ACPI solution
      If you like a SSDT way, here we go
      5- USB Solution
      USB INTEL SERIE 400.zip
      Use these kexts, enable XHCI port limit patch and follow this tutorial for remap USB ports
      --DSDT PATCHES--

      -If you want to buy me a beer - Donations with PayPal
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By miliuco
      Hi everyone. Big Sur beta 10 boots up and works fine on my system. But booting from the installation USB, even erasing NVRAM before choosing the installation program, I have the problem that, after language selection dialog, which apparently arrives well and quickly, the screen goes gray and does not reach the macOS Recovery message or the window with the installation options.
      Can anyone guide me on the cause and solution of this problem? I have tried some modifications, without success.
      I attach config.plist. IGPU is disabled in BIOS. Only RX 580 dGPU is active.
      Thank you.
    • By amirali mahmoudi
      i have a problem since updated my opencore to 0.6.2
      My audio output is set to headphones, and every time i turn on the pc , i need set this on internal speakers
      and the other problem is that sometimes my hackintosh wake up from sleep after 2 second and sometimes its work fine
      i've checked my config.plist in sanity checker and dortania and its all good but these problems still exist 
      Can you help me out please ?
      asus z390 p 
      i7 9700k
      rx 590 8gb
      wifi/bt/handoff works fine
      catalina 10.15.7
      opencore 0.6.2
    • By VortexisTV
      Hi, I made sure I got the right kexts and bios settings for my system, and followed every step I could take on Dortania's opencore github guide but I was met with kernel panic. I sanity checked my config.plist and made sure I had the exact settings for my Whiskey Lake laptop. I've dumped my DDST and generated SSDTs using the SSDTTime method, except XOSI (I tried manually recompiling the GPIO SSDT but I also got the same kernel error). I made sure I deleted unnecessary kexts and ACPIs. I'm thinking that my Zenbook laptop has a specific way of handling Hackintosh. If anyone could take a look into my EFI folder and find what's causing them It would be greatly appreciated.
      EFI and kernel panic picture is attached below
      ASUS Zenbook UX331FN
      Intel UHD Graphics 620
      8GB of SDDR4
      Opencore 0.6.2

    • By dadamaja
      Hi all!!
      After using my old Dell Clover convert for a few years, I recently built a new Catalina box using OpenCore.  Everything works perfectly and has been very stable.  The only thing that is not working is unlocking with my Apple Watch.  The screen says "Unlocking with Apple Watch" with the spinning graphic and then just prompts for my password.  It does not shake or anything as if the password is incorrect.  My 2014 MBP unlocks without issue and they both use the same iCloud account.  I purchased the Fenvi FV-T919 pci-e adapter and BT, WIFI, Handoff, and Airdrop are all working without issue.  I confirmed in system preferences that unlock is supported and made sure that automatic login is disabled in my profile.  I have cleared keys out of the keystore, restarted a number of times, logged out and back into iCloud all to no avail.  Anyone else having this issue?  Thanks in advance!!
      More info my build:
      Asus PRIME z370-A II
      Core i7 9700K
      32 GB PC3200 Crucial Ballistix RAM
      Sapphire Pulse RX380 
      Samsung 970 Evo Plus
      Fenvi FV-T919
      2x Seagate Barracuda 4TB
      CoolerMaster MasterLiquid ML240L V2