Jump to content

Unlocker for VMware Workstation 16


11 posts in this topic

Recommended Posts

  • 1 month later...
On 9/24/2020 at 11:29 PM, BAONX said:

https://github.com/BDisp/unlocker

Work for VMware Workstation 16

Doesn't work for me. I just tried the master branch against version VMWare 16.0.0 build-16894299 and I still get an error on OSX boot.

 

UPDATE: This seems to be CPU-specific. I just upgraded my CPU to AMD and I'm running into this problem: 

 

Edited by cowwoc

Intel CPU is your friend - use Intel. :) And throw this AMD thing away -- also, older Intel CPUs are better with Mac VMs than "latest & greatest", which have issues with this.

 

I can report ONE bug here -- with VMware Workstation 15.x (older version) when I have latest VMware Tools in my macOS VMs (running LOTS of VMs here, from 10.8 Mountain Lion to Mojave, Catalina and multiple Big Sure Betas), VMware Workstation correctly says "Reinstall VMware Tools" in the menus i.e. it detects I have latest Tools already - on ALL my many VMs.

Unfortunately, on latest VMware Workstation 16.0 the macOS Unlocker mostly works but this part does not work anymore.

It now wrongly says "Update VMware Tools" on ALL my VMs, despite having latest Tools already on them all.

 

The guys maintaining the macOS Unlocker project, can you fix this, please? 

I mean this is most likely a bug in the macOS Unlocker here, and not anything else wrong on my side, correct? :|

Edited by Naki
grammar/clarity

One more issue I have, ONLY on my macOS VM with macOS Big Sur 11.0.1 RC2 OS -- trying to minimize any window in the VM will freeze the VM -- it stops responding to anything -- with my Intel Core i5 CPU heavily loaded for close to 5-6 minutes. Then the VM "unfreezes" and CPU load goes down to normal levels. :|

 

On my 2nd computer also with VMware Workstation 16.0 on it -- a HP workstation laptop with a slightly more powerful Intel Core i7 CPU - I also get a similar freeze on minimizing any windows in macOS Big Sur VM, but on the laptop this is just 5-10 seconds long, so much more bearable.

Laptop has 4 cores/8 threads, but the other PC has only 4 cores/4 threads (being an old Intel Ivy Bridge Core i5 model).

Both computers run Windows 10 OS, Pro, 64-bit, version 20H2. (i.e. latest non-Preview) available) 

 

Please note I have LOTS of other, older macOS VMs here ranging from 10.8 Mountain Lion up to 10.14 Mojave and Catalina too and they do not suffer from same issues - minimizing windows in them will do the minimize at once, and not after 4-7 secs or 5+ minutes. So, something is wrong only on macOS Big Sur RC (previously on the Betas too) somehow.

 

Anyone know how to fix this slowness, or at least lower the 5+ minutes to something like 1, 2 minutes max? :worried_anim:

Edited by Naki

@Naki Your comments are not helpful. Over a quarter of the market is using AMD nowadays with more joining every day. If you don't know how to get OpenCore installed under VMware that's fine. Just please don't disparage others for trying.

 

@BAONX I got past the OS installer but now I am unable to get the system to boot on its own. The system boots fine using the USB EFI but the hard drive EFI dies with the VMWare error mentioned in the above discussion thread. How did you get past this point?

  • 5 weeks later...
On 12/13/2020 at 12:44 AM, KellyK said:

PSA stop using the older versions of VMWare just to get your virtual mac to boot. They have proven security vulnerabilities that'll make it easy for hackers to get into your machines.

 

Also, Intel chips suck 

Only new Intel CPUs suck! :)

Intel Haswell & Ivy Bridge CPUs still rock. ;) 

×
×
  • Create New...