Jump to content
macattackjack

SATA Weirdness with Non UEFI X58 Rampage II Gene

4 posts in this topic

Recommended Posts

SETUP 1

MSI X58M mATX MB, i7-950 Intel, 8 MB RAM GT710 GPU, Blaze 60 GB SSD.

SETUP 2

 

Asus Rampage II Gene X58 mATX MB, i7-950 Intel, 8 MB RAM GT710 GPU, Blaze 60 GB SSD.

Background. I used both these motherboards with 10.9.5 with clover, and both used the EXACT same files kexts, etc. It was a thing of beauty to go back and forth so easily.

NOW

After a little effort, using a z68 motherboard, getting this to work on an X58 was easy. I just dropped the DSDT needed for the Z68 and the same EFI worked perfectly. Or so I thought.

On the ASUS, If I boot with the SSD connected to a USB port with a SATA to USB3 cable, it works.
But If I connect the SSD to the SATA on the Asus motherboard, it freezes on boot. If I connect the exact same SSD on the MSI X58M, it works.

Solutions I've tried that don't work:
In the config.plist, turning on FixSATA in the Fixes 

Adding this to Patches Doesn't work

                 <dict>
                    <key>Comment</key>
                    <string>change SAT0 to SATA</string>
                    <key>Disabled</key>
                    <false/>
                    <key>Find</key>
                    <data>
                    U0FUMA==
                    </data>
                    <key>Replace</key>
                    <data>
                    U0FUQQ==
                    </data>
                </dict>

Nothing I change in the bios makes any difference.

I know it's not a motherboard problem. I have an install of 10.13.6 that works with the Asus. There's something about Catalina the Asus doesn't like.

I'd like to get both working with Catalina.

Any suggestions?

Thanks in advance.

 

Config Original working X58m.plist

 

About.png.001df638062741a7776feb6be5fc12c2.png

 

361626051_X58MCloverFolder.thumb.png.7fbf7fca06493f07567d5a7aeded16a9.png

Share this post

Ummm.... never mind

I don't know what possessed me, but I thought to reset the NVRAM, and that solved the problem.

I was using Clover 5108 and was having an issue where the motherboard BIOS would be reset every time the system was restarted, on both the MSI and the Asus X58 motherboards, After some research, I found this had been a issue with Mojave and earlier OS versions, all of which was solved by using r5114. I switched to 5121, and it solved the reset problem.

For some reason the reset NVRAM option on clover 5108 hasn't been working. I tried it now with 5121, and it worked, and the system booted fine.

If anyone is interested I can upload the EFI

 

Share this post

I take it back. Whatever I did to get it to work, when I tried adding a boot argument for sound, alcid=1, it stopped booting from the SATA. I'm now back booting with the SSD connected via the SATA to USB adaptor. None of the original steps I took with setting the NVRAM worked after multiple tries.

Still looking for suggestions. I don't know if it's the applealc.kext, the NVRAM issue, or what. I'm going to see if I can get sound to work booting from USB and also taking the applealc.kext out and turning off the sound in the bios.

Share this post

×