Jump to content
Followers 0
steve3d

is there a better way of disable UAR1 on my system?

1 post in this topic

Recommended Posts

I'm using gigabyte z390 aorus master, with it's latest bios f11c, there is no option to turn off the serial port option, and another strange thing is there is no physical serial port on this board.

 

and I'm using a usb dac as sound card, with this UAR1 device exists, there will be many stops when I use my usb dac to output any sound.

 

currently I'm using a very bad way to disable the UAR1 device by patch dsdt, 

 

			<dict>
				<key>Comment</key>
				<string>Rename UAR1 to XAR1 (Disable Serial Port)</string>
				<key>Enabled</key>
				<false/>
				<key>Find</key>
				<data>CF9ISUQMQdAFAQ==</data>
				<key>Replace</key>
				<data>o6Ojo6Ojo6Ojow==</data>
				<key>TableSignature</key>
				<data>RFNEVA==</data>
			</dict>

as you all can see the problem here, with this patch, I can not boot windows with opencore, always reboot.

 

So I'm wondering if there are any other way of disable UAR1 on my board, and I'm attached with a ioreg dump file. please someone help me to disable this ANNOYING Serial port. Thanks

iMac.ioreg

Share this post

×