Jump to content

steve3d

Members
  • Content Count

    18
  • Joined

  • Last visited

About steve3d

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

590 profile views
  1. steve3d

    AppleALC — dynamic AppleHDA patching

    @MacPeet, so this page means if I want to have 192k output, the only way is to switch to those smbios model, right?
  2. steve3d

    AppleALC — dynamic AppleHDA patching

    hi, @MacPeet please see the attached midi setup and sound property from windows. my board support 192k output, but under mac, the max rate is 96k.
  3. steve3d

    AppleALC — dynamic AppleHDA patching

    of course I tried with midi setup, the max output rates displayed is 96k, I'll post a screenshot when I get home. I get it, but so far macpeet's layout is almost perfect for my board, his layout can automatically switch from speaker to headphone when I plug a headphone on front jack of my case. and switch back to speaker when I pull out the headphone from front jack
  4. steve3d

    AppleALC — dynamic AppleHDA patching

    and so far, @MacPeet 's layout 16 works best. except his layout 16 can not have 192k output on my board.
  5. steve3d

    AppleALC — dynamic AppleHDA patching

    @insanelyDeepak thank you for the layout, I've tested all 1,2,5,7,11, and seems layout 1 has the right the jack number. but all of these layout are marked my speaker as headphone. layout 2 missing line in, layout 5,7,11 no sound. and 5,7,11 says I have a internal microphone. that's not possible for a desktop computer. Anyway, thanks!~
  6. steve3d

    AptioMemoryFix

    just tested with my new version of bios, it didn't help, same halt/pause at shutdown/reboot.
  7. steve3d

    AppleALC — dynamic AppleHDA patching

    @insanelyDeepak, any luck with my 1220 layout?
  8. steve3d

    AptioMemoryFix

    I have another old computer which has z97 board and old xeon v3 cpu. I've tried with the same driver64uefi rig, this computer don't have the panic problem. is it any possible of the uefi bios? I see gagabyte released a new bios a few days ago, I will try it and report back. and if this happens again, how can I get this panic log in text? I only posted about half of the panic log. another half can not be seen clearly with my iphone's normal video recording. use a slow montion video recording?
  9. steve3d

    AptioMemoryFix

    Peripherals → USB Configuration → XHCI Hand-off : Enabled Peripherals → USB Configuration → Legacy USB Support : Auto and another strange thing is, almost every guide says I need this XHCI hand-off set to enable. but, now I'm using the setting disabled. and this legacy usb support, I also set it to disabled. nothing happens. and yesterday, I found no matter what I set these two bios setting, EVERYTHING USB port works. in case you might be intreseted, I'm attaching my config.plist and bootlog.txt here. I don't have any ssdt/dsdt patch, because I don't know how and what to patch. bootlog.txt config.plist
  10. steve3d

    AptioMemoryFix

    well, unfortunately, I've read about this guide somewhere, and my first config is almost 90% similar to this. but my situation is a little different here, because this board only have one hdmi 1.4 output, so my 4k monitor is useless with igpu, I have to use my old nv 970 card as dgpu, so that's why I'm still stuck with 10.13.6. and with these setting, the AptioFix2-free2000 driver also gives me a allocation error, and can not boot at all. but all the config.plist so far about this ga-z390 aorus master as one common big mistake, which is that this board comes with a CNVi wifi/bluetooth. the bluetooth works only if you boot into windows first, then back to mac, then you will find out that the bluetooth works. of course without instant hotspot and continuexxx(I have chinese version, so I forgot how to spell this correctly). so this cnvi bluetooth problem is that when cold boot into mac, there is no way to upload the firmware. so this random hangup only happens when I use AptioMemoryFix, with or without nvramemu, it always hangs when reboot/shutdown. the core cause this TLB error is totally random. anyway, thank you Matgen84 and apianti. I can use this bluetooth to pair with headphone, iphone, android. So I'm very positive about this bluetooth works. why need a 3rd 4.2/4.1/4.0 bluetooth while you can have a bluetooth 5.0?
  11. steve3d

    AptioMemoryFix

    well, with my board, it's not possible to use AptioFix2/3, they always failed to start, but with AptioMemoryFix, I only got this panic when I try to reboot/shutdown mac. but it boots fine. so, is there possible solution that I can help test?
  12. steve3d

    AptioMemoryFix

    Hi, I want to use AptioMemoryFix with native nvram on my GA-Z390 Aorus Master/i9-9900k, but I found a strange problem, once I install this driver into clover/drivers64UEFI and remove any aptiofix*/emunvram driver, my mac will halt about 30-60 seconds on every reboot/shutdown, so I start in verbose mode, and when reboot, I got this "TLB invalidation IPI timeout" panic no matter what smc I'm using(fakesmc/virtualsmc), no matter how I change the clover dsdt patches, it always give this panic on every reboot/shutdown. when I switch to OsxAptioFixDrv-64.efi, this panic is gone. so what's wrong?
  13. steve3d

    AppleALC — dynamic AppleHDA patching

    thanks, I'm using latest 10.13.6
  14. steve3d

    AppleALC — dynamic AppleHDA patching

    hi, insainlyDeepak, I'm using your layout 16 on gigabyte z390 aorus master, Now I can finally see my audio devices, but none of the output has a audio output, and I think this z390 aorus master has a different config than other normal z390 board, can you make a new layout for this? I have card codec dump from linux. would you please help me check if this is a different layout? Sorry, My bad, the internal speaker DID work after a cold boot. but output shows me two line out? that is not possible, right? and this board's audio is able to output 32bit/192000 hz, but in midi setup, I only have 32bit/96khz Thanks! card0.txt
  15. and another note: I found these in dmesg: 000000.621651 XHC@14000000: AppleUSBXHCIPCI::createPorts: ports limit reached. Not creating the remaining 6 ports 000001.701624 IOUSBHostHIDDevice@: IOUSBHostHIDDevice::handleStart: unable to open interface 000001.701878 IOUSBHostHIDDevice@: IOUSBHostHIDDevice::start: unable to start IOHIDDevice Apple16X50UARTSync1: Detected 16550AF/C/CF FIFO=16 MaxBaud=115200 000001.705527 IOUSBHostHIDDevice@: IOUSBHostHIDDevice::handleStart: unable to open interface 000001.705546 IOUSBHostHIDDevice@: IOUSBHostHIDDevice::start: unable to start IOHIDDevice 000001.705572 IOUSBHostHIDDevice@: IOUSBHostHIDDevice::handleStart: unable to open interface 000001.705582 IOUSBHostHIDDevice@: IOUSBHostHIDDevice::start: unable to start IOHIDDevice
×