Jump to content
macattackjack

Asus Prime X299-A Success with Big Sur Beta 5 OC

2 posts in this topic

Recommended Posts

Asus Prime X299-A, i7-9800X, EVGA GT710 2G Metal, Patriot XMP 3200  64GB RAM

First Credit where credit is due.

Mald0n for his Big Sur Beta 5 install the easy way. This is the only way I was able to get the system to work. The link to his image is here

And d5aqoep for his work on his MSI X299 Tomahawk motherboard. He managed to tweak the ACPI to get it to work with his motherboard. Luckily it worked with my Asus with only a few modifications.

I must point out at this point that this motherboard is a pain in the neck. I also have a EVGA X299 Micro which I tried with the same i7-9800X, and porting my 10.15.5 from my X79 Rampage IV Gene to The EVGA required only adding slide=0 to the boot 
arguments to get it to boot. Tweaking took a little more work, but there were no freezes like when trying to get the Asus to work.

I took d5aqoep EFI and tried it, but it didn't work at first. what I found was VooDooTSCSync was set to 10 cores. When I set it to my 8 core i7-9800X and it worked sort of, but it was not shutting down properly and sometimes would restart on its own. I used this EFI to do an install from Mald0n's flash image but it would hang on the second restart and get stuck, and trash the NVRAM as well. When He told me to try the Easy way (it's an image of the installed OS) which successfully installed the OS onto the drive, and I then replaced the OC EFI with the one from d5aqoep. During one boot,  I noticed it was hanging on the audio kext. So I removed the alcid=1 boot argument, and it worked.  No more hangs on shut down. But no audio. Further investigation at GitHub here and I found it needed to be set to alcid=2. Audio was back.

All USB ports work and show the proper Icon, however there's one USB 3.1 connector that if a USB HD is used, it shows up as an internal drive. I can live with it.

Sleep and shut down work as well.

I've enclosed the EFI here. A few notes about it.

First, I replaced all the kexts with current versions. The VooDooTSCSync now automatically sets the thread count. I replaced the current IntelMausiEthernet02.5.1d1 to version 2.5.0 for a program that I know works with version 2.5.0. But both work properly.

Bios settings are standard with the only changes outlined here.

What I don't know, is how to get OC to skip the HD boot list and go directly to booting, as I'm really kind of a novice with OC.

But for now, it works.

 

I'm not able to upload the entire EFI, as it's over 10GB, so it's missing the Apple folder.

 

Config.plist

 

OC.zip

 

BOOT.zip

 

411194625_BigSurAsusPrimeX299-A.thumb.png.c726a8694b1bd61d94617e6ad47ee70e.png

 

 

Edited by macattackjack
Share this post

  • 1 month later...

I'm glad you got this working. I just answered to another older post from you in another thread. This was before I saw this here, so ignore my answer there.

 

I have a MSI X299 SLI Plus. It is not the same as yours, but I am wondering about you using VooDooTSCSync. I used to have the VooDooTSCSync, but it stopped working properly when I updated my CPU from 7820 to 9940. I was getting kernel panics at boot and also during normal operation. This was still in 10.15 with Clover. When I changed to TSCAdjustReset, all the issues were solved. So perhaps that was your original problem, using  VooDooTSCSync instead of TSCAdjustReset?

 

I am a beginner with OC, but I have a few years of tweaking in Clover. My systems suffers a lot under the AptioFix issue. I have now found a way to make it work (OsxAptioFixDrv + Test2-2016) but it is a random combination that seems to fail each time I update my Clover installation. OC worked at the first try, which is a big improvement for me. My daily system is still Clover+10.15, but I have OC+11 in a test partition that I have been booting once in a while and testing. Sleeping and audio and USB work, I have not tested it thoroughly though...

 

Good luck, do update this thread as you discover new issues. I am now running OC 0.6.1 and 11beta8. Booting is fine and I worked in the system for a few hours (browsing and listening to music, a few terminal commands) with no issues so far.

 

My installation thread is here BTW:

 

Share this post

×