Jump to content

PLEASE HELP IMEI AND HD620 KABY LAKE ON OPENCORE! HP 840-G4


1 post in this topic

Recommended Posts

So i managed to install latest Catalina with opencore 0.59 and latest acidanthera's work on my HP 840-g4. But i have just one annoying problem: IMEI.

 

The issue is exactly the same as described here:

 

 

and in other thread at the commercial hack site with big eyes.

 

Most of the applications not responding after wake from sleep. crashed quicklookup, quicktime player, youtube, hackintool, etc, etc. (spinning color wheel).

 

So surfing deeply on the forums, i noticed that the problem is related of lack of IMEI injection. So i tried manual HECI to IMEI patch, knowing that WhateverGreen do that work. No results.

 

The only way that i can get IMEI on ioReg is changing the address from 16 to 0, through a ACPI patch:

 

dict>
				<key>Comment</key>
				<string>HECI ADDRESS</string>
				<key>Count</key>
				<integer>0</integer>
				<key>Enabled</key>
				<true/>
				<key>Find</key>
				<data>SEVDSQhfQURSDAAAFgA=</data>
				<key>Limit</key>
				<integer>0</integer>
				<key>Mask</key>
				<data></data>
				<key>OemTableId</key>
				<data></data>
				<key>Replace</key>
				<data>SEVDSQhfQURSDAAAAAA=</data>
				<key>ReplaceMask</key>
				<data></data>
				<key>Skip</key>
				<integer>0</integer>
				<key>TableLength</key>
				<integer>0</integer>
				<key>TableSignature</key>
				<data></data>
			</dict>

 

So with this i can get IMEI on IoReg

 

113798791_CapturadePantalla2020-06-24ala(s)16_32_05.thumb.jpg.2e2c847885c02c8fed8c50b4aaa769a8.jpg

 

1910677583_CapturadePantalla2020-06-24ala(s)16_32_00.thumb.jpg.8529580dce6e5e3a58a8a678187fab8a.jpg

 

 

But i think that is a problem! Because the KBL FrameBuffer can't initialize the MEI Service, even with the IMEI at ioreg, this is from boot syslog:

 

2020-06-24 16:38:29.075004-0400  localhost kernel[0]: (AppleIntelKBLGraphicsFramebuffer) <AppleIntelKBLGraphicsFramebuffer`AppleIntelFramebufferController::createMEIDriver()> [IGFB][ERROR  ] Failed to start MEI service!
2020-06-24 16:38:29.075014-0400  localhost kernel[0]: (AppleIntelKBLGraphicsFramebuffer) <AppleIntelKBLGraphicsFramebuffer`AppleIntelFramebufferController::createMEIDriver()> [IGFB][ERROR  ] Failed to create MEI service

 

 

Soooo, the question is:

 

How can i solve this?!!

 

I also tried:

 

1. SSDT-IGPU from Rehabman

2. SSDT-IMEI

3. Rename HECI to IMEI ACPI patch

All these with no luck.

 

PD: I have to say that not SDcard mount after wake from sleep and this are the only two thing left to solve in order to get full working hackintosh laptop.!

 

 

Thanks in advance

 

EFI.zip

ioreg_imei0.ioreg.zip

syslog.txt

×
×
  • Create New...