Jump to content

Z390 Designare iGPU black screen after gIOScreenLockState (OpenCore)

4 posts in this topic

Recommended Posts

In OpenCore's config.plist, set the following values within DeviceProperties/PciRoot(0x0)/Pci(0x2,0x0)



Hi everyone


I am pulling my hair out a bit having spent two days working on this and feeling like I am no further forward. I initially used the beast tools / Clover to install Catalina on my new build but had to use FakeID 0x12345678 on every boot and the GPU was not running correctly. I was recommended on r/hackintosh to start from scratch and use OpenCore instead. I followed the OpenCore Desktop guide from here:




The problem

Having built the EFI etc and attempting to boot, I got a back screen and then no signal on monitor after gIOScreenLockState.


What I have tried

  • I have been advised that this is likely due to issues in the GPU patching. I have Whatevergreen and Lilu in my plist and kexts folder along with all the other required kexts and what I believe to be the correct ACPI files and entries
  • I have just flashed the beta F9g firmware and set the BIOS settings according to the dortania guide, including disabling CFG Lock (actually after flashing the beta it was showing as already disabled) 
  • Completed the section in the guide on iGPU BusID Patching, trying different bus IDs by trial and error. I have just gone through every single one:
    • 010x0900 00080000 C7030000 (x = 1 to 6)
    • 020x0A00 00080000 C7030000 (x = 1 to 6)
    • 030x0800 00080000 C7030000 (x = 1 to 6)

      For each one I set the bus ID of the other two outputs to 00 and the connector type to 00004000 as per the guide. None of them worked, exactly the same problem every single time.



  • I am at a loss now. I built this machine to spec because the components were among the most compatible, but nothing I have tried seems to work. I would really appreciate some further guidance on this
  • Is there anything I am missing to get the iGPU working? I can post my OpenCore config.plist and my EFI folder structure if it would help
  • If I give up on the iGPPU, disable it in the BIOS, and install a natively compatible dedicated graphics card, will this effectively solve the problem of not being able to boot? Eventually I will be installing a dedicated card anyway, so if it will solve the problem then I may as well just do it now


Thanks so much for any help, I will really appreciate it.



  • Gigabyte Z390 Designare motherboard
  • Intel Core i9-9900K 3.6 GHz CPU

  • Kingston HyperX Predator 32GB DDR400 RAM

  • Samsung 970 EVO Plus 500GB NVME

Edited by Bjørn Felle
Link to comment
Share on other sites

Well sadly after reaching my limit of frustration with this I just gave up and ordered a Sapphire Radeon RX 580 8 GB PULSE. If this gives me as much of a (literal) headache then I'm just going to use Windows, unless there is any other way, as I simply do not understand what I am doing wrong and although I appreciate the information being put together by the community I just can't make sense of any of it :/

Link to comment
Share on other sites

  • 10 months later...

  • Create New...