Jump to content
Y50-70 LAPTOP

install windows it's better

21 posts in this topic

Recommended Posts

Advertisement

Hello,

 

So, if this is what you're currently using, it seems a lot more than mentioned here.

SSDT-HPET.aml
SSDT-dGPU-Off.aml
SSDT-EC.aml
SSDT-PLUG.aml
battery-num.aml
SSDT-EHCx_OFF.aml
SSDT-PNLF.aml

 

I only see:

SSDT-PLUG
SSDT-EC
SSDT-GPIO
SSDT-PNLF

 

So let's try first the official way. And you mentioned something about HDMI. Not sure what that was, so maybe you can offer a bit more details? This is a laptop. Are you connecting it via HDMI to an external monitor or something?

 

By the way, full disclaimer, I never tried to hackintosh a laptop. My only laptop is an actual MacBook Pro. So...I don't have much experience with this. But seeing that you're struggling with this issue, I decided to at least try to help as much as I can.

 

Share this post


Link to post
Share on other sites
Posted (edited)
13 minutes ago, Y50-70 LAPTOP said:

now I am using the laptop display (HDMI is plug is not connected)

you mentioned: 

SSDT-PLUG
SSDT-EC
SSDT-GPIO
SSDT-PNLF

 

What I use


SSDT-HPET.aml - https://github.com/corpnewt/FixHPET
SSDT-dGPU-Off.aml - found on internet to disable dGPU for not draw power (at least miminal) bios is 
battery-num.aml - from rehabman to display percentage
SSDT-EHCx_OFF.aml -  Disable EHC1 and EHC2 ports (https://github.com/acidanthera/OpenCorePkg/blob/master/Docs/AcpiSamples/SSDT-EHCx_OFF.dsl)

 

 

 

SSDT-HPET -  do you need it? Cause I don't. In fact, even with Clover, messing with that would cause issues.

SSDT-dGPU-OFF - isn't Lilu + WEG + boot-args "-wegnoegpu" good enough for this? Or it doesn't work for this case? What if you try without it?

battery-num... ok, but right now we have a different issue. So...I'd try without it, for now.

SSDT-EHCx_Off - I mean...I don't see how that would affect anything, but again, what I would recommend is trying the exact procedure in the guide. And only AFTER we manage to see what's wrong with your sleep/wake issue, add the rest of the stuff. This way, if one of them is causing this issue, we can reduce the amount of variables to a minimum.

Also, that's a sample. Don't you need to change it according to your needs? Again, I don't use it, and at least for now, I would highly recommend sticking to that guide.

Edited by arsradu

Share this post


Link to post
Share on other sites
2 minutes ago, Y50-70 LAPTOP said:

i tried it but it crashed again

 

Alright, could you please, remove your smbios info from config and upload your entire EFI folder? So we can discuss it later on.

Share this post


Link to post
Share on other sites
Posted (edited)
10 minutes ago, Y50-70 LAPTOP said:

posted here.

EFI.zip

 

All your SSDTs (included the ones we agreed to disable/remove) are still present in ACPI and config.

 

Edited by arsradu

Share this post


Link to post
Share on other sites
Posted (edited)
30 minutes ago, Y50-70 LAPTOP said:

@arsradudo you know how to fix it please?

 

I don't know exactly how to fix it. I told you, I don't have a hackintosh laptop. BUT I'm still trying to help you. But if you refuse to follow the guide I mentioned above, how can I really help you? Also, I asked you to remove/disable those SSDTs and you just re-enabled them... We can't work like this. I'm trying to go with you step by step so we can get to the source of the problem. If you keep reverting things, I cannot do it. Some things need to remain fixed into position, while we change others. We can't just change everything chaotically, hoping that maybe something will work.

 

You know what I did for the past hour or so? Going through that guide for you. So you can try this EFI and hope that it fixes your issue.

 

So, first of all, please, use this on a USB drive!! Do not just replace the EFI folder inside your main system, unless you already have a USB drive to boot from!

 

So, always have a backup! Either replace the EFI on your main system and have a spare USB drive that you know you can boot from. Oooor...use that USB drive for testing this EFI and boot from your main EFI in case you can't boot from your USB. As you wish, but please, just make sure you always have a backup!

 

So, obviously you will need to rename EFI-Y50 to EFI. And if you want, you can do a smart thing and just rename your current EFI (wherever it is) to EFI-backup or something similar so you can use it later on.

 

Also, I do not appreciate being pushed. At all. Please, be patient, or fix this yourself.

Edited by arsradu

Share this post


Link to post
Share on other sites
Posted (edited)

 

What about the part above that? Not sure what could cause this.

 

update: try this config instead please.

Edited by arsradu

Share this post


Link to post
Share on other sites
Posted (edited)

I wouldn't waste my time @arsradu, as you've noticed yourself, the man is very pushy to say the least; I tried to help myself in a very recent past only to be insulted by PM because he considered that the stuff I posted was useless since he did not understand any of it. Then, he PM'ed me for help (yup!) so I told him where to go in my own special way... A more recent attempt to help resulted in same sort of behaviour.

 

We've just banned him from OSXL because, yesterday, after seeing this (from 2013!) he posted this (since deleted):

koder.jpg.aae383482d8811f3d9cbe4385e82e5ad.jpg

and ended up with this about EMlyDinesh's ELAN/FocalTech/Synaptics kext development work:

koder_onedaypls_Y50-70.png.68dcde6ef66800e13d46ad67b559f571.png

 

Then, he calls people troll... :whistle:

 

 

Edited by Hervé

Share this post


Link to post
Share on other sites

Yeah.... ok. That's not good.

 

I wanted to see the whole screen. :) Also, I don't wanna get into a fight with anyone here, or on any other forum for that matter. :)) I think that's stupid. :)) Also, I have a deep appreciation for some of the people here so...yeah.

 

I'm sorry, I don't think I can help you. Not because of what Herve said. But because I honestly don't know how to fix it. As I said from the very beginning, I do not have a hackintosh laptop. And they are notoriously harder to patch than desktops. So...I'm really sorry. I wish I could help more. I tried. And I still think that the best way to get this fixed is starting fresh, and using the guides provided on Dortania. For me at least they were really useful. :) 

 

You can of course still use some of the things I put in that EFI if you think any of that helps. 

Share this post


Link to post
Share on other sites
Just now, Y50-70 LAPTOP said:

I think it's lost case, I tried lot of googling talking with people but no one know how to fix this issue.

 

The image above I tried to disassemble the swd process but can't find information regarding sleep.

For dylib I was trying to load symbols but I am not sure how to and if that was possible.

 

 

 

You know, I was wondering what's with that...

 

I wouldn't call it a lost cause yet.... But yeah, it's not really easy to debug. At least for me. Maybe other people have more experience with laptops and all that. I was lucky enough to buy hardware that gave me very few headaches over time...

 

Question: have you considered reinstalling the OS? Maybe create a separate partition and installing it there, just for testing? :) I don't know... I'm just saying... Maybe what your system needs is a clean install.

Share this post


Link to post
Share on other sites
Posted (edited)
7 minutes ago, Y50-70 LAPTOP said:

Yes I was thinking about that before, I was trying it many times but that didn't help.

I see.... Well, to me at least, that iGPU patching (for a laptop) looks ok. So...it might not be that. But if your system can go to sleep just fine, but when it wakes up, it panics and restarts instead (if I understood your issue correctly), that...in my experience is related to the iGPU. 

 

By the way, one other thing I would try...is checking BIOS settings related to the iGPU. You should have iGPU enabled, obviously. I know laptop BIOSes offer a lot less customisations than Desktop ones. But I'm just saying... Maybe something in there is not properly configured.

 

What kinda bothers me is that we have the same iGPU model. And I have no issues with sleep/wake... But then again, I'm using a Desktop, you're using a laptop.

Edited by arsradu

Share this post


Link to post
Share on other sites
Posted (edited)
8 minutes ago, Y50-70 LAPTOP said:

Yes you explained it correctly after clicking sleep a couple moments then power button is turned off then it restarts.

 

On BIOS I selected UMA Graphics instead of Switchable Graphics.

 

 

Hmm... ok. One other thing that came to my mind. But I don't think you will have that option onto a Laptop BIOS..... But you can try.

 

Do you have any options for SuperIO? This might be stupid. But...I know I had some sleep/wake issues before because of that. Granted it was in Mojave, if I'm not mistaken... But maybe still applies to Catalina. I know I always set that to disable, just in case.

 

So, in BIOS, I have something that's called Super IO Configuration.

And under that, I've got Serial(COM) Port 0 Configuration. 

 

That, for me was default set to Enabled. So I had to Disable it in order to fix that issue.

 

See if you have something similar on your end. Something related to Serial ports or something.

Edited by arsradu

Share this post


Link to post
Share on other sites

Well that sucks...

 

Then I don't know... One thing you can probably do is disable Sleep altogether. From Energy Saver. At least until you can find an actual fix to this.

Share this post


Link to post
Share on other sites

@Y50-70 LAPTOP Quick question: is your iGPU properly recognised in MacOS? For example in About This Mac -> System Report... -> Graphics/Displays? With the correct amount of VRAM and all that?

 

I'm thinking...if AAPL,ig-platform-id 0600260A doesn't work for you, maybe some of the other ones could...? At least some of the ones marked as "Mobile"? Have you already tried that?

Share this post


Link to post
Share on other sites
Posted (edited)
34 minutes ago, Y50-70 LAPTOP said:

Yes, yes and yes

It's not marked as mobile but settings of display looking right.

 

Hmmm... ok.

 

Can you try something else, please?

 

It might be stupid, but some people say it could fix this... 

 

So, in Device Properties, for your AUDIO device (yes, not the iGPU), try to change as follows:

 

PCI Address: PciRoot(0x0)/Pci(0x1b,0x0)

Key: replace "alc-layout-id" with "layout-id" 

Value: 0F000000

Type: DATA

 

Add new key (for the same device): "No-hda-gfx"

Value: 00000000

Type: DATA

Edited by arsradu

Share this post


Link to post
Share on other sites
2 minutes ago, Y50-70 LAPTOP said:

alc-layout-id is recommend when using AppleALC

I just tried that but it still crash.

 

I mean...it could be. But...according to OC's Configuration PDF, it should be "layout-id". In fact, I don't remember seeing it as "alc-layout-id" except for the other forum of which we don't speak here. :))

 

 54895821_Screenshot2020-05-24at17_16_36.thumb.png.4702e4c924f889ebd5acd27600907c76.png

 

Anyway, if adding No-hda-gfx doesn't work, I'm out of ideas right now. I'll try to search some more online and let you know if I find anything else.

Share this post


Link to post
Share on other sites
2 minutes ago, Y50-70 LAPTOP said:

 

I changed it to "layout-id" and also added no-hda-gfx before but it still crash, here is proof

thanks for your help. someone has more ideas?

 

Uhm... it might sound stupid, but can you try adding "No-hda-gfx" with a capital N?

This is what it should look like in ioreg.

1607921199_Screenshot2020-05-24at17_56_29.png.f170c066ddfe5b4d56a9bdfb3208105b.png

Share this post


Link to post
Share on other sites
Posted (edited)
5 minutes ago, Y50-70 LAPTOP said:

I only tried  installing Catalina .

 

note: "no-hda-gfx" disables audio and doesn't fix sleep issue.

 

No-hda-gfx should only disable HDMI audio, not analog audio, for as far as I could read. But...if it doesn't fix sleep, that's a bummer.

 

Also, if you have some spare space on your HDD/SSD, you could try installing Mojave, just for testing. :) 

Edited by arsradu

Share this post


Link to post
Share on other sites
Posted (edited)
13 minutes ago, Y50-70 LAPTOP said:

by accident I typo "layout-id2" which disabled audio.. But, I restarted and fixed that and tried again but it still crash with same error.. And, that error is useless only if apple had stop codes like microsoft ...

 

Yes I can try. Can I install it alongside Catalina?

 

Yes, you can. You will only have one APFS partition, as opposed to Catalina which creates a system partition and a "-data" partition. But yes, you can have both on the same disk.

 

For Mojave, you might need to change the date on your computer to get it installed. But we'll see more about that when we get there, or if necessary.

 

Also, I'm guessing you also fixed your capital N in "No-hda-gfx"? And no changes on the sleep issue even after that? Sometimes, those little details make the biggest differences. :) That's why I'm insisting with all these details. I just wanna make sure everything is done correctly so we don't run in circles.

Edited by arsradu

Share this post


Link to post
Share on other sites

@Y50-70 LAPTOP Found this online. Might help. There's a mention below for sleep issues. From what I could understand, you might need to patch your SSDT-dGPU-Off.aml and change the address from PEG0 to...probably something else.

 

I'll let you read more on that. The patch doesn't seem that complicated (as opposed to other SSDT/DSDT related stuff) but...since I don't have access to a similar laptop, there is of course no guarantee that any of this will work. Also, I'm a complete noob when it comes to patching SSDT/DSDT). As usual, I would recommend doing this on a spare USB drive or something, the idea is to always have a working backup, in case you can't boot anymore after that.

 

Hope it helps.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×