Jump to content
Sign in to follow this  
Followers 0
Tristana

[SOLVED] HDR Disabled not reported to LG 27GN850-B monitor

5 posts in this topic

Recommended Posts

Posted (edited)

Hello- I'm having an issue where toggling HDR on/off in Catalina isn't being reported to my new LG 27GN850-B monitor. This is a problem as with HDR enabled in the monitor, I can only adjust brightness/sharpness & I can't seem to use the sRGB profile built into the monitor. There seems to be no way to manually disable HDR on the monitor.

Toggling HDR on/off in Catalina *does* affect the image; it's washed out with HDR on, but hyper-saturated with it off. The monitor, however, thinks it's getting an HDR signal either way.

I am connected via a DisplayPort & my RX580. Any ideas? Thanks!
 

System:

Quote

macOS 10.15.4 High Sierra
core i5 7600k Kaby-lake @ stock 3.8ghz
ASRock Z270M Pro4
16 GB DDR4 2400mhz (Mushkin 2x8gbs)
Sapphire Radeon Pulse RX 580 8GB GDDR5
be quiet! 500w PSU

MOTU Ultralite mk4 USB audio interface

 


Kexts:

Quote

Kexts:
AppleALC.kext
FakePCIID_Intel_HD_Graphics.kext
FakePCIID.kext
FakeSMC.kext
IntelMausiEthernet.kext
Lilu.kext
USBInjectAll.kext
WhateverGreen.kext

XHCI-unsupported.kext

Edited by Tristana

Share this post


Link to post
Share on other sites
Advertisement

alright, the system is trolling me. I toggled it on/off a few more times and the monitor realized that it wasn't getting an HDR signal eventually.

Any ideas on a more permanent fix? I'm actually fine never using HDR with this monitor, but it'd be nice to have it so that toggling it... works as expected.

Share this post


Link to post
Share on other sites

In waking the monitor from display sleep, it thinks it's HDR again. :-/ 

Share this post


Link to post
Share on other sites
4 hours ago, enlaid said:

It's Catalina 10.15.4 bug not related to hackintosh:

https://discussions.apple.com/thread/251218978

https://discussions.apple.com/thread/251213356

 

Generate display override file using Hackintool or use script: https://gist.github.com/adaugherity/7435890


Awesome, thank you! I somehow didn't find this in my searching (though perhaps because I was using the 'Hackintosh' keyword when it's a general macOS problem).

The kext made by hackintool seems to be working.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      macOS Installation
      See macOS installation steps here See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the SSDT-UIAC.aml here) Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers AptioMemoryFix Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here  
      Current Versions
      Catalina 10.15.5.02 Clover (UEFI) r5119 Lilu.kext 1.4.5 WhateverGreen.kext 1.4.0 AppleALC.kext 1.5.0 IntelMausi 1.0.3 (Not IntelMausiEthernet)  
      Credits To be provided
       
       







      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk800 G4 Mini - Rev 0.91.zip
    • By verrwirung
      Hi!
      Just finished installing hackintosh Catalina on my Razer Edge Pro tablet.
      I need help making the touchscreen work.
      I've tried installing VoodooI2C kexts (I2cHID, I2CELAN, etc) but still not working.
      can someone help me on this project? it would be really really be much appreciated 
       
      Thanks!
       



    • By UsamaShahid036
      I was previously using clover with Catalina and on that everything worked very good, now i shifted to Opencore everything is working on laptop except trackpad, from windows is searched that my trackpad is "Microsoft HID" and i have tried all the VoodoI2 kexts, seperately like VoodoI2CHID, VoodoI2CELAN, VoodoI2CSynaptics but trackpad won't work. Previously i was using VoodoI2CHID on clover and trackpad was working very fine.
      Kindly help me in that, a little help would be appreciated.
       I have attached my OpenCore EFI Folder
       
      OC EFI.zip
    • By ltooz_audis
      So, I cheap out and got a $20 dw1820a for my laptop hackintosh - EliteBook 820 G3 macOS Catalina 15.5. Clover wouldn't boot or work properly, OpenCore works perfectly with some adjustment.
      https://www.youtube.com/watch?v=46hanWDwZLA
      Cheers,
      Louis
    • By oetzi
      Hi, I got an old but well-working El Capitan on my Hackintosh, with Maldon patched Clover folder and DSDT.
       
      I had to update my Mobo BIOS from f( to F10 and now... my Hackintosh doesn't work anymore.
       
      I can only boot with -x -s flags, with no graphics (you can see the card in my signature).
       
      Without using these flags I can see the black screen with mouse pointer disappearing and some flashings (maybe the progress bar).
       
      I'm using Nvidia Web Drivers. I'm quite sure it's a "graphic card issue" but I can't manage how to get the system working again.
       
      Can somebody help to solve this issue?
       
      Thanks!
×