Jump to content
ClementDel

Failed to install macOS - memory panic stackshot succeeded

2 posts in this topic

Recommended Posts

Posted (edited)

Hello,

I'm new on this forum, I appologize if I make a mistake :)...

 

I tried to install Niresh Catalina on my laptop, but I can't finish the installation properly.

I have a "Memory panic stackshot succeeded" error.

I seems to be an error due to "ACPI", with error "AE_ALREADY_EXISTS".

 

This is a link of a video of my screen in slow motion https://photos.app.goo.gl/BHkou4WEg33DA9ib7 (I can do another if logs are not visible enough)

 

This error appears after the 10-15min loading of the installation, after a reboot.

 

This is my laptop https://www.ldlc.com/fiche/PB00167274.html.

 

If someone can help me, I will apreciate a lot!

Thank you

Edited by ClementDel

Share this post


Link to post
Share on other sites
Advertisement

Sorry but due to forum rules you will not find help on here concerning OSx86 distros such as Niresh. I suggest you post in their forums.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By blackosx
      Do you want to quickly find your boot log, or ever wanted to know which version of bootloader is installed on your disk(s), had the need to dump your BIOS from OS X, just curious about your own system setup or been asked to provide your setup information to others when asking for assistance?
       
      DarwinDumper is a useful collection of readily available tools, and scripts wrapped in an application framework giving you a convenient method to quickly gather a system overview of your hack or Mac. And rest assured that enabling the privacy option will mask sensitive data like the IOPlatformSerialNumber, IOPlatformUUID, IOMACAddress(s), USB Serial Number(s), SystemSerialNumber, serial-number, fmm-mobileme-token-FMM, MLB and ROM efi vars and CustomUUID in the dumped files and report.

      Current Release Version: 3.1.1



      The system dumps are saved to a folder or your choice, but defaulting to the same directory as the main application. You can choose to setup a symlink to make it simple to run DarwinDumper from the Terminal.
       
      There is an option to create an html report showing a complete overview of the dumps. This report will mostly just contain the text dumps as you'll find in the main dump directory, but for some dumps there is extra processing to try to present the information in a better way. For example, the Disk Partitions and Unique ID's dump will show a visual map of the disk layout, and the DMI Tables (SMBIOS) dump will show the data split by table type.
       

       
      Note: The html report does not contain all files from a complete dump so if seeking assistance for a problem and you wish to send someone a DarwinDump then you will want to send the complete dump directory and not just the .html report file.
       
      The following can be read and dumped by DarwinDumper:
      - ACPI tables.
      - Audio codec and further info.
      - Boot loaders and configuration files.
      - CPU info.
      - Device-properties.
      - Disk partition structure / info.
      - Disk sectors (hex).
      - DMI (SMBIOS).
      - EDID.
      - I/O Kit Registry.
      - EFI Memory Map.
      - EFI vars (some).
      - Kernel information
      - Kexts - (list of currently loaded kexts).
      - Memory.
      - NVRAM (both Apple specific and UEFI firmware variables).
      - SMC Keys.
      - LSPCI (PCI vendor & device codes) dumps.
      - Power (Sleep/Hibernate) settings.
      - RTC.
      - System Profiler.
      - System BIOS.
      - System Log(s).
      - Video BIOS.
       
      License:
      DarwinDumper is licensed under GNU General Public License, version 3.0 (GPLv3).
       
      Tools included:
      AnalyseVBIOS
      Copyright: Not Known. License: Not known Source: http://www.insanelymac.com/forum/topic/211294-information-on-vesa-modes-in-atinvidia-bios/ Alt Link: https://www.dropbox.com/s/dnp903x2z9pqf8k/AnalyseVBIOS.zip?dl=0   AppleIntelInfo Copyright: © 2012-2017 Pike R. Alpha. All rights reserved. License: Creative Commons Attribution-NonCommercial Source: https://github.com/Piker-Alpha/AppleIntelInfo   atomdis Copyright: Michael Larabel @ Phoronix.com License: GPL Version 2 Source: http://www.phoronix.com/scan.php?page=article&item=amd_atombios_dumper   bgrep Copyright 2009 Felix Domke <tmbinc@elitedvb.net>. All rights reserved.   Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:      1. Redistributions of source code must retain the above copyright notice, this list of       conditions and the following disclaimer.      2. Redistributions in binary form must reproduce the above copyright notice, this list       of conditions and the following disclaimer in the documentation and/or other materials       provided with the distribution.   THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL <COPYRIGHT HOLDER> OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   The views and conclusions contained in the software and documentation are those of the authors and should not be interpreted as representing official policies, either expressed or implied, of the copyright holder.   Source: https://github.com/tmbinc/bgrep   bdmesg Copyright 2010 by Islam M. Ahmed Zaid. All rights reserved. License: GPL Version 2 Source: http://forge.voodooprojects.org/p/chameleon/source/tree/HEAD/trunk/i386/util/bdmesg.c Alt Link: https://sourceforge.net/p/cloverefiboot/code/1905/tree/CloverPackage/utils/bdmesg/bdmesg.c   cmosDumperForOsx Created by rafirafi, revised extensively by STLVNUB License: Information not available Source: https://www.dropbox.com/s/bg1q0yho6g7u3xn/cmosDumperForOsxV0.1.zip?dl=0   csrstat Created by Piker-Alpha Copyright: © 2015-2017) by Pike R. Alpha License: Information not available Source: https://github.com/Piker-Alpha/csrstat   dmidecode Original nongnu.org
      License: GPL Version 2
      Now updated and hosted by acidanthera Source: https://github.com/acidanthera/dmidecode   dumpACPI Created by blackosx. Idea taken from PHPdev32's MacIASL. Source: https://bitbucket.org/blackosx/dumpacpi   edid-decode Created by Adam Jackson, revised by Andy Vandijck License: Information not available Original Source: http://cgit.freedesktop.org/xorg/app/edid-decode Revised Source: https://www.dropbox.com/s/l0htffnqzs9e1vg/edid-decode.zip?dl=0   fdisk440 Apple Computer, Inc. License: APSL v2.0 Original Source: http://www.opensource.apple.com/source/diskdev_cmds/diskdev_cmds-491/fdisk.tproj/mbr.h Modified by Zef Source: http://forge.voodooprojects.org/p/chameleonApplications/source/tree/HEAD/trunk/fdisk.tproj Alternate Link: https://www.dropbox.com/s/odl9kp38j3flla5/fdisk440.zip?dl=0   FirmwareMemoryMap script Amit Singh (showbootermemorymap) Further development by bcc9 and dmazar License: Information not available   flashrom http://flashrom.org/Flashrom License: GPL Version 2 Source: https://www.dropbox.com/s/gfmqx2t7lvofs1v/flashrom.zip?dl=0   getcodecid Copyright © 2012 AnV Software. All rights reserved. License: Information not available Source: https://github.com/Gengik84/getcodecid   getdump Created by fassl?, modifications by Slice and AutumnRain? License: Information not available Source: https://sourceforge.net/projects/voodoohda/files/   gfxutil Copyright 2008 mcmatrix. All rights reserved. License: Information not available Historic detail can be found at forum.netkas.org Source: https://github.com/acidanthera/gfxutil   iasl Copyright © 2000 – 2014 Intel Corporation. License: Information not available Source for v20200110: https://www.acpica.org/node/176   ioregwv Apple Computer, Inc. License: APSL v2.0 Original Source: https://opensource.apple.com/source/IOKitTools/IOKitTools-86/ Modified by blackosx Source: https://bitbucket.org/blackosx/ioregwv   lzma Copyright © 2013 Igor Pavlov. License: GNU Lesser General Public License Source: http://www.7-zip.org/sdk.html This build by Slice at insanelymac.com: https://www.insanelymac.com/forum/topic/311786-updated-lzma-utility-v1514/   lzvn Copyright: © 2014 Apple Computer, Inc. All rights reserved. License: APSL Credit: Piker-Alpha, Andy Vandijck, MinusZwei. https://github.com/Piker-Alpha/LZVN   MacGap2 Created by Tim Debo. All rights reserved. License: MIT Source: https://github.com/MacGapProject/MacGap2   Macpmem driver (Macpmem.kext) Copyright © 2007-2011 Volatile Systems. Copyright 2013-2014 Google Inc. All Rights Reserved. License: GPL Version 2 Source Code: https://github.com/google/rekall/tree/master/tools/osx/MacPmem]https://github.com/google/rekall/tree/master/tools/osx/MacPmem   nvram Apple Computer, Inc. License: APSL v2.0 Modified by blackosx Source: https://bitbucket.org/blackosx/nvram   oclinfo Copyright © 2009 cmf License: GPL Version 2 Source: http://www.insanelymac.com/forum/topic/170796-opencl-info/   pciutils driver (DirectHW.kext) DirectHW is Copyright © 2008-2010 coresystems GmbH License: GPL Version 2 Source: https://github.com/CloverHackyColor/directhw Kext: Pre-built (Signed) Kext   pciutils lspci Copyright © 1997--2008 Martin Mares License: GPL Version 2 Source Code: https://git.kernel.org/pub/scm/utils/pciutils/pciutils.git
      RadeonDump Created by Dong Luo. Copyright 2008. All rights reserved. Modified by Andy Vandijck License: Information not available Source: http://www.insanelymac.com/forum/topic/282794-darwindumper/page__st__120?do=findComment&comment=1920068 Alt Link: https://www.dropbox.com/s/5drpckxlmaot732/RadeonPCI.zip?dl=0   radeon_bios_decode Created by Dong Luo. Copyright 2008. All rights reserved. License: Information not available Source: http://www.insanelymac.com/forum/topic/282794-darwindumper/page__st__120?do=findComment&comment=1920068   SMC_util_FansOnly Copyright © 2006 devnull  License: GPL Version 2 Source: https://www.dropbox.com/s/ra9h6gbjj6yhgol/SMC_util_FansOnly.zip?dl=0   smcutil Copyright © 2006 devnull  License: GPL Version 2 Source: https://www.dropbox.com/s/0dgvexijx4oewfr/smcutil.zip?dl=0   VoodooHDA.kext Created by fassl?, modifications by Slice and AutumnRain? License: https://sourceforge.net/p/voodoohda/code/HEAD/tree/tranc/License.h]https://sourceforge.net/p/voodoohda/code/HEAD/tree/tranc/License.h Source: https://sourceforge.net/p/voodoohda/code/HEAD/tree/]https://sourceforge.net/p/voodoohda/code/HEAD/tree/   x86info Written to succeed CPUID by Phil Karn (KA9Q). Contributed to by various people. OS X compatability by Slice License: GPL Version 2 Original Source: https://github.com/kernelslacker/x86info Revised Source: https://github.com/CloverHackyColor/x86info  
       
      Running DarwinDumper from the command line:
      From Terminal, you can initiate DarwinDumper by running the following script directly.
      /DarwinDumper.app/Contents/Resources/public/bash/script.sh To help with this, the UI has a Symlink option which you can click to create a symbolic link which points to the above script. DarwinDumper can then be subsequently run from the command-line by loading a new Terminal window and typing darwindumper followed by return.
      $ darwindumper usage: [-a zip,lzma,none] [-d acpi,appleintelinfo,audio,biosSystem,biosVideo,codecid,cpuinfo,devprop,diskLoaderConfigs,bootLoaderBootSectors,diskPartitionInfo,dmi,edid,bootlogF,bootlogK,firmmemmap,memory,ioreg,kernelinfo,kexts,lspci,rcscripts,nvram,opencl,power,rtc,sip,smc,sysprof] [-h] [-l] [-o html,private] [-p 1,2,3,4,5,6,7,8] [-v] Example:
      $ darwindumper -l Will re-run the last dump used options.

      Credits (in alphabetical order):
      acidanthera team, Adam Jackson, Amit Singh, Andy Vandijck, Apple Inc., arsradu, bcc9, blackosx, cmf, DieBuche, dmazar, Dong Luo, droplets, ErmaC, Felix Domke, Google Inc., Intel Corporation, InsanelyDeepak, JrCs, Kabyl, Kynnder, Martin Mareš, mcmatrix, Michael Larabel, Mickey1979, phcoder, Phil Karn, Piker-Alpha, rafirafi, гык-sse2, Slice ,sonotone, STLVNUB, THe KiNG, Trauma, Volatile Systems, xsmile, !Xabbu.
       
      DarwinDumper was originally inspired as an open project by Trauma, it has remained an open project and please keep it an open project, so if you make any changes or additions to it then please share your work here.
       
      Please report any feedback, requests or bugs.
       
      Known issues: v3.1.0
      1 - When SIP File Protection is enabled, dumping disk partition info of non-APFS containers and disks which are not APFS physical stores may fail when running from DarwinDumper via the graphical interface. However, it's been known to succeed when using DarwinDumper from the command line. Something to do with osascript.
      2 - lzma archive option has been known to fail on macOS 10.15 when running dumps requiring root privileges.
       
      macOS Version support:
      - v2.9.9.2 is for older macOS versions
      - v3.0.4 requires OS X 10.9 and newer to run in the Finder, though it should work from the command line okay on older OS versions.
      - v3.1.0 was updated for newer macOS versions and has been tested on 10.13 and 10.15.

      DarwinDumper Download
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      https://tinyurl.com/rkqmpd9
       
      --OpenCore Folder--
      https://tinyurl.com/y75hqg7z
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By chatelp
      Hi all !
       
      I'm migrating from Clover to OpenCore and stuck on an ACPI error at boot:
      ACPI Error [_STA] Namespace lookup failure, AE_ALREADY_EXISTS This comes from trying to load my custom SSDT-EC tables.
       
      From what I gather, the preferred method of dealing with EC0 for Desktops with OC is to add an _STA method to EC0 to change return code to 0, and then to add a new fake EC device. Both done via SSDT-EC.
       
      Problem is, my EC0 defined in the system DSDT already has an _STA method. And it looks like it can't be overridden through SSDT redefinition at boot. Is this excepted ACPI behavior? Is it not possible to override/redefine methods like _STA? If so, what other option do I have?
       
      Here is the original EC0 device in DSDT
      Device (EC0) { Name (_HID, EisaId ("PNP0C09")) // _HID: Hardware ID Name (_UID, One) // _UID: Unique ID Name (_GPE, 0x6E) // _GPE: General Purpose Events Method (_STA, 0, NotSerialized) // _STA: Status { Return (0x0F) } ....  
      Here is my very standard SSTD-EC for Skylake:
       
      /* * AppleUsbPower compatibility table for Skylake+. * * Be warned that power supply values can be different * for different systems. Depending on the configuration * these values must match injected IOKitPersonalities * for com.apple.driver.AppleUSBMergeNub. iPad remains * being the most reliable device for testing USB port * charging support. * * Try NOT to rename EC0, H_EC, etc. to EC. * These devices are incompatible with macOS and may break * at any time. AppleACPIEC kext must NOT load. * See the disable code below. * * Reference USB: https://applelife.ru/posts/550233 * Reference EC: https://applelife.ru/posts/807985 */ DefinitionBlock ("", "SSDT", 2, "ACDT", "SsdtEC", 0x00001000) { External (_SB_.PCI0.LPCB, DeviceObj) /* * Uncomment replacing EC0 with your own value in case your * motherboard has an existing embedded controller of PNP0C09 type. * * While renaming EC0 to EC might potentially work initially, * it connects an incompatible driver (AppleACPIEC) to your hardware. * This can make your system unbootable at any time or hide bugs that * could trigger randomly. */ External (_SB_.PCI0.LPCB.EC0, DeviceObj) Scope (\_SB.PCI0.LPCB.EC0) { Method (_STA, 0, NotSerialized) // _STA: Status { If (_OSI ("Darwin")) { Return (0) } Else { Return (0x0F) } } } Scope (\_SB) { Device (USBX) { Name (_ADR, Zero) // _ADR: Address Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { If ((Arg2 == Zero)) { Return (Buffer (One) { 0x03 // . }) } Return (Package (0x08) { "kUSBSleepPowerSupply", 0x13EC, "kUSBSleepPortCurrentLimit", 0x0834, "kUSBWakePowerSupply", 0x13EC, "kUSBWakePortCurrentLimit", 0x0834 }) } } Scope (\_SB.PCI0.LPCB) { Device (EC) { Name (_HID, "ACID0001") // _HID: Hardware ID Method (_STA, 0, NotSerialized) // _STA: Status { If (_OSI ("Darwin")) { Return (0x0F) } Else { Return (Zero) } } } } } }  
      I saw this other similar post but can't find a working solution in it: https://www.insanelymac.com/forum/topic/341585-hpet/?_fromLogin=1
       
       
    • By MacKonsti
      Hello everyone, I hope you are well and safe. Long time Hackintosh user, didn't post new topics really as most solutions are here, just need some good digging around.
       
      However, there has been no talk about renaming "bare" PCI devices shown in IORegistryExplorer such as e.g. pci8086,1911@8 or pci8086,9def@14,2 to something more meaningful such as ACPI Devices like (SPI1) or (PGMM) or (SHRM) etc. etc.
       
      I have been experimenting a lot with different SSDT ways of making code and injecting the compiled AML via Clover, in preparation for OpenCore, but I cannot succeed for this one.
       
      Why is this needed? For starters, I have two good reasons.
       
      a) My device pci8086,3ed0@0 is MCHC per lspci and despite Clover being able to inject the parameter AddMCHC, I cannot achieve the same result via SSDT injection instead, meaning OpenCore would not do it either (well, for now).
       
      b) Moreover, I discovered by accident from another config.plist in some Github repository, that my device pci8086,9df9@12 that is listed in lspci as Coffee Lake Thermal Controller [8086:9df9] can be set to being compatible with Apple's accepted and combatible device-id of pci8086,9d21 via Clover injection in Devices -> Properties section or via SSDT, but I cannot make it get a human-friendly ACPI name at all so it get to work and load kext com.apple.driver.AppleIntelPCHPMC.
       
      Believe me, I have a few structures of code... Here is my code (compiles 100%) as an example and below, a blocking issue as well.
       
      /* * Intel ACPI Name Space Architecture for NUC8i7BEH2 device * * NOTES: * Assigned PCI device generic (PGMM) and working (PMCR) to undefined devices in IODeviceTree. * Added new (SBUS) sub-system (BUS0) and (DVL0) devices for improved vanilla detection. * Added new (LPCB) sub-system (EC) device for improved Catalina detection. */ DefinitionBlock ("SSDT-OTHER.aml", "SSDT", 2, "Clover", "OTHER", 0x00000000) { External (_SB_.PCI0, DeviceObj) External (_SB_.PCI0.LPCB, DeviceObj) External (_SB_.PCI0.LPCB.H_EC, DeviceObj) External (_SB_.PCI0.SBUS, DeviceObj) Scope (\_SB.PCI0) { // Device (MCHC) // Intel Corporation Host Bridge/DRAM Registers [8086:3ed0] // { // Name (_ADR, 0x00000000) // } // Device (PGMM) // Intel Corporation Core Processor Gaussian Mixture Model [8086:1911] // { // Name (_ADR, 0x00080000) // } Device (PMCR) // Intel Corporation Coffee Lake Thermal Controller [8086:9df9] { Name (_ADR, 0x00120000) } // Device (SRAM) // Intel Corporation Coffee Lake Shared SRAM [8086:9def] // { // Name (_ADR, 0x00142000) // } // Device (SPI1) // Intel Corporation Coffee Lake Serial Bus SPI Controller [8086:9da4] // { // Name (_ADR, 0x001F5000) // } } Scope (\_SB.PCI0.LPCB) // Intel Corporation Coffee Lake LPC Controller [8086:9d84] { Device (EC) { Name (_HID, "ACID0001") Method (_STA, 0, NotSerialized) { If (_OSI ("Darwin")) { Return (0x0F) } Else { Return (Zero) } } } } // Do not rename EC0, H_EC, etc. to EC as these devices are incompatible with macOS // and may break at any time; AppleACPIEC kext must NOT load. If your motherboard // has an existing Embedded Controller of PNP0C09 type, use the code below to disable. Scope (\_SB.PCI0.LPCB.H_EC) { Method (_STA, 0, NotSerialized) { If (_OSI ("Darwin")) { Return (Zero) } Else { Return (0x0F) } } } Scope (\_SB.PCI0.SBUS) // Intel Corporation Coffee Lake SMBus Controller [8086:9da3] { Device (BUS0) { Name (_ADR, Zero) Name (_CID, "smbus") Device (DVL0) { Name (_ADR, 0x57) Name (_CID, "diagsvault") Method (_DSM, 4, NotSerialized) { If (LEqual (Arg2, Zero)) { Return (Buffer (One) {0x57}) } Return (Package (0x02) {"address", 0x57}) } } } } } So if I use External (_SB_.PCI0, DeviceObj) reference on top, then a Scope (\_SB.PCI0) under it, I found out after many tests and reboots that device with 0x00120000 address is somehow allowed to be assigned a "name" in IODeviceTree but not any others! If I enable the other ones, nothing gets injected in this SSDT as a result !
       
      00:00.0 Host bridge [0600]: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers [8086:3ed0] (rev 08) 00:08.0 System peripheral [0880]: Intel Corporation Core Processor Gaussian Mixture Model [8086:1911] 00:12.0 Signal processing controller [1180]: Intel Corporation Coffee Lake Thermal Controller [8086:9df9] (rev 30) 00:14.2 RAM memory [0500]: Intel Corporation Coffee Lake Shared SRAM [8086:9def] (rev 30) 00:1f.5 Serial bus controller [0c80]: Intel Corporation Coffee Lake SPI Controller [8086:9da4] (rev 30) I guess this is likely due to the way my Intel NUC8i7BEH's BIOS and ACPI code is written ?
       
      What's amazing is that if we use Clover's AddMCHC option, in MacIASL I see inside the main DSDT a new code portion added in the _SB.PCI0 very very end at the bottom:
       

       
      But if I uncomment the code for adding Device (MCHC) in my SSDT code above, the device will not get injected ! This is nuts.
       
      @MaLd0n I have been following most of your work for many years and know that you have better knowledge of ACPI code than me, can you possibly advise how we can rename these "naked" PCI devices in IORegistry Explorer to something meaningful like Device (XYZ) ? Is this possible via SSDT code injection?
       
      Anyone else you have in mind, that could help? @Hervé peut-être, maybe you?
       
      The idea is that, except device at 0x00120000 address being accepted (by chance!) and renamed as Device (PMCR) that helps enable the native power-management by injecting later in Clover's configuration a <key>compatible</key> ID, all others including MCHC cannot be assigned a name.
       
      Your help is appreciated... I tried ways to define Devices with root " \ " reference as in External (\_SB_.PCI0, DeviceObj) and Scope (\_SB.PCI0) and without this, for the love of me I cannot understand how to do it.
       
      Moreover, having disassembled all AML files obtained at Clover Boot time, there is no reference to a device with addresses Name (_ADR, 0x00000000), Name (_ADR, 0x00080000), Name (_ADR, 0x00120000) or Name (_ADR, 0x001F5000) anywhere...
       
      Could it be that they do not belong to Scope (\_SB.PCI0) at all ? But Hackintool does report them as being under PciRoot(0x0) ! Could it be differently under some other device instead? ACPIPlane in IORegistryExplorer doesn't show anything
       
      IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/MCHC@0 --> PciRoot(0x0)/Pci(0x0,0x0) IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PMCR@12 --> PciRoot(0x0)/Pci(0x12,0x0) IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/pci8086,9def@14,2 --> PciRoot(0x0)/Pci(0x14,0x2) IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/pci8086,9da4@1F,5 --> PciRoot(0x0)/Pci(0x1F,0x5)  
      Thanks... hope I can resolve this before spending time migrating to OpenCore...!
       
      Here's a screenshot of the "bare" pci8086,xxxx devices without injection of my code at all, except Clover's AddMCHC option.

    • By sierra2600
      The laptop in question: Acer TravelMate 8472 TM8472 (Model: ZQ3) (refer to the "Spoiler" at the end if you want the machine specs)
       
      "So what are you bugging us for?" Good question, because I am usually an introvert and usually just keep looking for answers but I could not find some. Jumping to it...
      What does not work and I would like thoughts on:
      Bluetooth does not register, used to on previous installs (sorry, I did not pay attention to see if this was caused by me updating to 10.8.5 but that was necessary for the below functions) (It does not work in Debian either - Ignore) LAN and WLAN  - I have found Kexts (somewhere, I think I just lost them... dang it...) for the WLAN but I have yet to try them, nothing for the LAN I know this is cheating but I read that The NDISulator for FreeBSD (HINT HINT) is a port of NDISwrapper for Linux that runs Windows XP network drivers in Linux or BSD Brightness controls work from the middle down on the "Sun" brightness overlay, I got this far from following this: https://www.insanelymac.com/forum/topic/287133-guide-backlight-brightness-for-intel-80860046-1st-gen-hd-gma-5700mhd/ but I am kind of thinking of trying: https://www.insanelymac.com/forum/topic/287133-guide-backlight-brightness-for-intel-80860046-1st-gen-hd-gma-5700mhd/?do=findComment&comment=2214344 . My "magic number" is: 0xF        I used DSDTEditor in Windows, since I figured all the drivers are loaded, to extract the DSDT and compile something that somewhat works... Wake from sleep issue - I tried the above guide for that but I get a no backlit display and I can see that the cursor in the password field is not flashing when I use an external light source, but it will reboot when I press Ctrl + Alt + Power "button" (it is actually a slider) and then also clear my freaking CMOS right down to the clock... yeah I have the ACPI fix implmented and it usually works... DVD Player.app reports that no viable video device was found (personally I don't care about the DVD Player.app problem, just wanted to put that out there for the heck of it) The microphone port always sounds like it is going through a [dirty] guitar effects petal no matter what sliders are adjusted  
      Likely causes of:
      Bluetooth (BCM92046), WIFI (BCM943225HM) - So, I USED TO be able to turn on the WIFI from within Windows then reboot into Mac OS and have it work but I noticed recently that the indicator light for them turns off BEFORE it reboots now. When Windows or Android load, it lights up- "No... really, captain obvious?!"... anyways... working "No really Sherlock!" so OBVIOUSLY, the OS has to activate them... and preferably ignore the wireless switching button For the WIFI module, if you omit the 9 and HM in a search, results appear! Brightness - Will get reset to full "Bright light! Bright light!" when a "Load System Defaults" is applied from within the BIOS settings but like the WIFI and Bluetooth the OS will forcefully take control of it Microphone In sounding dirty - me being lazy with the audio drivers LAN (BCM57760) - I dunno...  when I search it, nothing comes up...  
      "How did you get this far?"
      Update the BIOS, this is oh so very important (refer to the battery section of the "Spoiler" for the reson) PLEASE BACKUP YOUR BIOS FIRST! PLUG THE MACHINE INTO THE AC ADAPTER/CHARGER! DO NOT FORCE THE COMPUTER TO SHUTDOWN NOR REMOVE THE BATTERY NOR UNPLUG IT FROM THE AC ADAPTER/CHARGER WHILE IT IS UPDATING! I WILL NOT BE HELD LIABLE FOR BRICKED MACHINES! So it will boot off of the (Niresh) Mac OS X 10.8 with no changes to anything "Awesome" but you may still need at least a USB mouse "Aww" If you have the option to remove the display drivers/kexts otherwise it will not to boot or not display If you forgot this, breathe "You think that's air your breathing?"... anyways... during the bootloader, go into single user mode [ -s ] and follow the on screen instructions to allow for modifying the files. You will want to PREFERABLY create a folder where Mac OS cannot read them and move the IntelHDGraphics Kexts into it You are likely going to need an external USB keyboard as well now that it is installed Now install the described Kexts in the "Spoiler" associated with the hardware to get more functionality and loose the USB HICs  
      Any help pertaining to the Bluetooth, WIFI, LAN, bizarre brightness and wake after sleep backlit display issue would be wonderful... Thank you for your time and I hope that I helped anyone else out with some of their own issues pertaining to the Acer TravelMate 8472 TM8472 ZQ3 no nVidia with i5 laptop...
      (Attached are non-modified extracted DSDT DSL and AML files "with errors according to DSDTEditor" for reference of the machine with a Phoenix BIOS version of 1.28 (07/20/2011))
      dsdt.aml
      dsdt.dsl
       
       
×