Jump to content
Followers 0
SenorHayes

Any Help On An OpenCore Install?

4 posts in this topic

Recommended Posts

First off, I just wanted to start by saying I tried really hard to troubleshoot my issue before posting. I'm having issues getting macOS to boot (looks like a cpu kernel panic). I'm using Opencore 0.5.8 (the debug version currently). I read the instructions at least x5 times (this one https://dortania.github.io/OpenCore-Desktop-Guide/). My config.plist list looks good according to sanity checker (https://opencore.slowgeek.com/) Also I went over it multiple times trying different options to hopefully get it to boot, or at least get a bit further in the booting process, still nothing.

 

I've tried making my own SSDT using SSDTTime and using the per-configured ones on github. No changes. I've tried using older versions of kext files. I'm at a loss here.

 

I'm running a Core i7 8086k (Coffee Lake), on a Gigabyte z370HD3 (all settings changed to the correct specs except CFG Lock, I can't seem to find the option), and using a GTX 1080, hence High Sierra.imageproxy.php?img=&key=c17464ef1b1b51c7

 

The last listed item in the opencore log is "12:171 00:022 OCSMC: SmcReadValue Key 4D534163 Size 2"

 

The boot screen seems normal until the line:

"panic (cpu 0 caller 0xffffff801d98776f): Kernel trap at 0xffffff7f9e939216, type 14=fault, registers:"

 

I've been googling the issue for days, most of the issues that came up from my researching have been from Clover uses (I understand why), any help for someone running Opencore would be great!

 

opencore-2020-05-14-161537.txt

image0.jpeg

Edited by SenorHayes
Removed file
Share this post

This should work out of the box, so you might re-check your .config settings

I got the same cpu/chipset combo - so try my config if it works for you.
---

I don't know what LAN card you have, if you got a Realtek RTL8168/8169/8111

series you don't need to do anything. If you have something else, you need

to add it to the config and remove settings I left in that config.

---

IMPORTANT: if you can boot, try to re-enable HPET/IRQ patches and

see if you get any funky output during boot.

 

You should re-configure SMBios entries accordingly. I assume you know how to edit your

config.plist file?

 

To enable HPET/IRQ patches (SSDT-HPET.aml), edit the part below in config.plist,

simply change <false/> to <true/>

<dict>
        <key>Comment</key>
        <string>HPET _CRS (Needs _CRS to XCRS Rename)</string>
        <key>Enabled</key>
        <false/>
        <key>Path</key>
    <string>SSDT-HPET.aml</string>
</dict>

If you can't boot, make a picture as you did above and post here.

 

efi_oc.7z

6 hours ago, SenorHayes said:

I'm running a Core i7 8086k (Coffee Lake)

I wanted to buy this funky-named CPU badly, but intel pissed me off with the pricing and I got the 8700K (which exactly the same, the only difference being 5Ghz boost in 8086, but the names cooler ;))

Edited by Synapsis
Share this post

Yeah, I bought my 8086k off a guy on craigslist, lol. Still sealed and everything. He said won into in a contest (intel gamer days or something) and didn't want to upgrade his motherboard. I bought it slightly cheaper than the 8700k at the time. It's been a good processor over the past year! I haven't upgraded since the very first i7 ten years ago so I'm happy, haha

 

Thank you for the help, I am grateful! Unfortunately, I was unable to get your config file to display the Install option. I added it to my EFI, changed some of the .plist settings to match my system. No luck. I tried running your whole EFI folder. Still no luck.

 

My LAN is Intel based. So I made those changes.

image0(1).jpeg

Share this post

I did it! I was using an Intel Optane cache drive which I guess was causing the problem. I needed to switch from RST to AHCI in my BIOS. Also needed to disable my NVMe drive even just having it installed caused issues. I added nvme=-1 to the boot-args and now we're booting!

Share this post

×