Jump to content

3 posts in this topic

Recommended Posts

Posted (edited)

So I'm new to OpenCore, I've been a Clover user for too long but it's finally totally failed me after a motherboard upgrade, I couldn't boot to Mac OS.

 

So I gave OpenCore a go using the basic config and boom, booted first time! I'm an instant convert!

 

The main problem I have is that I have a triple boot machine with Windows 10, Ubuntu and Mac OS on three separate drives. With OpenCore I can ONLY boot Mac OS. It gives me an option of "BOOTCAMP Windows" but if I select it it boots to the Ubuntu GRUB menu (??) and then won't load the linux kernel! There is no option that tries to boot Windows.

 

It looks like multi-OS support is not a priority right now, is this correct? Is there anything I can do to help test/code/progress this aspect of the project?

Edited by kevpatts

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)
6 hours ago, kevpatts said:

So I'm new to OpenCore, I've been a Clover user for too long but it's finally totally failed me after a motherboard upgrade, I couldn't boot to Mac OS.

 

So I gave OpenCore a go using the basic config and boom, booted first time! I'm an instant convert!

 

The main problem I have is that I have a triple boot machine with Windows 10, Ubuntu and Mac OS on three separate drives. With OpenCore I can ONLY boot Mac OS. It gives me an option of "BOOTCAMP Windows" but if I select it it boots to the Ubuntu GRUB menu (??) and then won't load the linux kernel! There is no option that tries to boot Windows.

 

It looks like multi-OS support is not a priority right now, is this correct? Is there anything I can do to help test/code/progress this aspect of the project?

Look for the n.d.k version of OpenCore. Running quadruple boot ( Catalina, Mojave, Windows & Linux ) on 4 different drives for each os, without any issues. 

Edited by Ellybz

Share this post


Link to post
Share on other sites
11 hours ago, Ellybz said:

Look for the n.d.k version of OpenCore. Running quadruple boot ( Catalina, Mojave, Windows & Linux ) on 4 different drives for each os, without any issues. 

Hey, so I downloaded, compiled and configured a NDK OpenCore config. I based it on the sample but migrated all my working settings over. I ensure the ScanPolicy is set to 0.

 

I now have a nice graphical EFI menu, but the same problem in that "BOOTCAMP Windows" starts Ubuntu GRUB which then can't boot Ubuntu. The additional problem I have now though is that Mac OS won't boot either (see attached).

 

Is there any chance you could share your config.plist with me for comparison? Did you have to install Windows through boot camp to get this to work? The NDK OpenCore documentation suggests this.

IMG_5468.jpeg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Myfz
      Hi all,

      I recently build my hackintosh, I got Win10 on my 1st disk and MacOS Catalina on the 2nd disk.
       
      Unfortunately my Win10 disk was defective and I will need to change it.
       
      I was thinking to :
       
      - Remove my Win10 disk and replace by my new one
      - Temporarily remove my MacOS Disk (Clover)
      - Reinstall Win10 on my new disk
      - Put back my MacOS Disk

      I believe clover will still start, and I will still be able to boot on the new Win10 disk, what do you think ?

      Thank in advance for your help,
      regards
    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      Catalina 10.15.4 - Windows 10
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound (all ports) USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) No problem so far ASUS HyperKit with a KINGSTON NVMe SSD - 250 GB Hardware decoding/encoding on both HD 530 and RX 5700 iGPU QuickSync is used in the default config.plist To use dGPU for hw decode/encode you need to disable iGPU in BIOS and boot with "config_dgpu_enc_dec.plist" (this will use iMacPro1,1 SMBIOS, so you may need to resign in to use your iCloud) System Integrity Protection is Enabled by default. If you need to boot with SIP disabled you may use "config_debug.plist" or disable it manually in Clover settings. If you want Enabled SIP but with allowing unsigned kexts you may boot with "CsrActiveConfig = 0x01"  
      What is not working:
      -  
       
      Not tested:
      Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: (This is for HD 530 in headless) Primary Display: Auto (to use dGPU only this must be PEG) iGPU Multi-monitor: Enabled (to use dGPU only this must be Disabled) RC6(Render Standby): Enabled (to use dGPU only this must be Disabled) DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: Intel SpeedStep: Enabled CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5112): Click here -> ASUS-Z170-Deluxe_Cata.zip  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia, gibMacOS - Windows: Transmac, Vmware, Win32diskimager, gibMacOS) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:
       

       




       
       
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Useful Applications for Mac:
      EFI Mountain Show -> To easily mount your EFI Clover Configurator -> To easily manage your config.plist https://mackie100projects.altervista.org/download-clover-configurator/ PlistEditPro -> Advanced plist editor https://www.fatcatsoftware.com/plisteditpro/ iStat Menus -> To monitoring your devices https://bjango.com/mac/istatmenus/ Boom 3D -> To significantly increase your audio quality https://www.globaldelight.com/boom/ TextMate -> a basic code editor just like Notepad++ on Windows https://macromates.com Modified Wineskin to run basic Windows 32-bit or 64-bit (or DX9 games) applications on Catalina -> https://www.reddit.com/r/MacOS/comments/fobx5t/i_didnt_want_to_boot_windows_every_time_when_i/ MaciASL -> View/Edit your .aml, .dsl files https://bitbucket.org/RehabMan/os-x-maciasl-patchmatic/downloads/ Hackintool -> All useful info, tools in one place https://github.com/headkaze/Hackintool IORegistryExplorer V2.1 -> To view your IO tables https://github.com/vulgo/IORegistryExplorer/releases/tag/v2.1 App Cleaner -> To delete your apps with caches https://freemacsoft.net/appcleaner/ Intel Power Gadget -> To see your frequencies https://software.intel.com/en-us/articles/intel-power-gadget Carbon Copy Cloner -> Advanced macOS drive backup utility https://bombich.com Commander One ->A Total Commander alternative for macOS https://mac.eltima.com/file-manager.html  
      Useful Applications for Windows:
      Total Commander -> To easily manage EFI https://www.ghisler.com gibMacOS -> A python script for downloading/creating macOS Internet Recovery USB from Windows (working internet is needed when installing) https://github.com/corpnewt/gibMacOS mountvol b: /s -> To mount your system drive EFI
      EasyUEFI -> To manage boot orders and any bootloaders with ease https://www.easyuefi.com/index.html
      MiniTool Partition Wizard -> To mount your USB EFI, and manage other drives https://www.minitool.com/partition-manager/
      Notepad++ -> Basic code editor for all type of files https://notepad-plus-plus.org
       
      Notes:
       
      2020.04.23: Corrected layout-id to use all audio ports, updated bootpack
      2020.04.22: Deleted unnecessary boot-args, can boot without any custom boot-args (except agdpmod=pikera for RX 5700), updated bootpack
      2020.04.20: Deleted unnecessary lines from config.plist, updated bootpack
      2020.04.17: Replaced FakeSMC with VirtualSMC because FakeSMC is outdated (to see your frequencies use Intel Power Gadget) -> Removed unnecessary kexts, Updated all necessary kexts, updated Clover to v5112, updated bootpack, enabled SIP, deleted bootcamp theme
      2020.03.26: Updated to 10.15.4 -> Updated WhateverGreen, Lilu -> Updated Clover to v5107
      2020.03.23: Removed "EmuVariableUefi.efi" -> deleted, caused false nvram map, now it's native, updated Clover to v5106
      2020.02.11: Updated to 10.15.3 -> No problem when/after installing
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
    • By Jancey
      I used this command: diskutil info disk0s2 | grep -i "Partition UUID" | rev | cut -d' ' -f 1 | rev

      But I accidentally removed the wrong disk and now my main windows drive is not appearing in the bootloader. I can't figure out how to get it back. I tried resetting my windows drive, but I kept getting an error. I also reset my mac and reinstalled Catalina.
    • By tlac
      Simple steps to create macOS Installer for Vmware on Linux or Windows
       
      This guide describes how you can create a Vmware image (vmdk) for installing macOS in Vmware. Most tutorials about this topic require an ISO installer file that was typically created in macOS or you have to download some preinstalled image file from unknown source. None of them are ideal. But if you follow the steps below, you will not need to access macOS and will use official and trusted sources.
       
      First of all download gibMacOS from here and set up
      https://github.com/corpnewt/gibMacOS
        Run the script to download the full macOS installer:
      on Linux: gibMacOS.command on Windows: gibMacOS.bat  
      Install qemu-img converter

      on Linux (Debian or Ubuntu):
      install qemu-tools package

      on Windows use this installer:
      https://qemu.weilnetz.de/w64/
      when you run the installer, it is enough to select the "tools" and "dll library".
       
      Convert the downloaded BaseSystem.dmg to Vmware image
      run the following commmand in that directory where BaseSystem.dmg was downloaded (somewhere here: gibMacOS-master/macOS Downloads/publicrelease/061-44387 - 10.15.3 macOS Catalina)
      on Linux:
      qemu-img convert -O vmdk -o compat6 BaseSystem.dmg recovery.vmdk on Windows:
      c:\"Program Files"\qemu\qemu-img convert -O vmdk -o compat6 BaseSystem.dmg recovery.vmdk  
      Use the previously created image to install macOS in Vmware
       
      I assume you have a patched and working Vmware already. If not, find another guide but in nutshell:
      - confirm the VT-x is supported on your Intel machine (if you are on AMD you may not able to virtualize macOS or you need to do more work)
      - install VMware Workstation or VMware Workstation Player (free for non-commercial use)
      - use an unlocker to patch the Vmware to support macOS guest
       currently this works well: https://github.com/BDisp/unlocker/
       
      So when you are here you have a patched Vmware and a Vmware image (recovery.vmdk).
      Run Vmware and create a new virtual machine by choosing macOS guest. But add another hard disk as well with selecting to use an existing virtual disk. Browse the recovery.vmdk. You will get a warning about the image is not in the latest format but choose to keep the existing format.
      After you installed the macOS, install the vmware tools as well.
       
      Tested on Windows 10 with macOS Catalina 10.15.3 in Vmware 15.5 Player
       
      Comments are welcome.
       
    • By johnny28
      Ho una tastiera wireless Apple Magic Keyboard con tastierino numerico (layout italiano), con Catalina OK, ma quando la uso con Windows 10, ho un piccolo problema i tasti "<" e "\" sono scambiati, nel senso che quando pigio sul tasto "\" ottengo invece "<" e viceversa. C'è modo di correggere il problema, senza dover ricorrere ad un software a pagamento come "Magic Keyboard Utlities" ?
×