Jump to content
neoskateur

RX580 MSI Armor Only Displayport working - HDMI Black Screen High Sierra

4 posts in this topic

Recommended Posts

Hello team!

I have a small issue wiith my RX580 MSI on High Sierra, only one DP is working, no hdmi... Any clue?

Supermicro X8DTL-6F
2 x Xeon X5650
RX580 MSI

Share this post


Link to post
Share on other sites
On 2/2/2020 at 1:17 AM, neoskateur said:

Hello team!

I have a small issue wiith my RX580 MSI on High Sierra, only one DP is working, no hdmi... Any clue?

Supermicro X8DTL-6F
2 x Xeon X5650
RX580 MSI

work - 2 HDMI 2 DP. DVI nothing to check but ioreg 5 ports shows. MSI RX580 Armor OC 8G /10.14.6

Снимок экрана 2020-02-03 в 14.27.32.png

Edited by Nuacho

Share this post


Link to post
Share on other sites
On 2/1/2020 at 5:17 PM, neoskateur said:

Hello team!

I have a small issue wiith my RX580 MSI on High Sierra, only one DP is working, no hdmi... Any clue?

Supermicro X8DTL-6F
2 x Xeon X5650
RX580 MSI

 

I have Catalina running on my own Nehalem-based system.  If you want to run Mojave as @Slice suggested, your system will run perfectly as MacPro5,1.  If you want to run Catalina, it will still run perfectly with Clover bootflag -no_compat_check.

My RX580 is working with the following configuration items:

  •  Configure CLOVER config.plist with the following options
    1. Fixes: FixDisplay
    2. Boot Arg: -no_compat_check (for Catalina)
    3. Graphics: Vendor ID: 0x1002, Product ID: 0x67DF, FB Name: Orinoco, Inject ATI, RadeonDeInit
  • Lilu.kext and WhateverGreen.kext

  • Add Fake EC if your DSDT doesn't have one (I think this was required for Catalina - not sure)

Edited by tonyx86

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By blazinsmokey
      I've written some detailed guide in my time but I'm going to keep this one shorter. I want to accomplish 2 things with this write up.
      1. Address the native nvram problem, this is huge for people with similar hardware moving forward with Big Sur.
      2. Help others get installed and booted with a very clean setup.

      Hardware and Overview
      ASUS Maximus VII Hero Z97, 4790K, Sapphire Nitro+ RX 580 8GB, HDMI to 43" 4K screen.
       
      Modifying the BIOS to get native nvram fix for Big Sur is also confirmed working for these boards
      ASUS Z97 ROG Maximus VII Hero ASUS Z97-A, requires manual modifying of BIOS file ASUS Z97-P ASUS Z97 ROG Maximus VII Gene ASUS Z97 ROG Maximus VII Ranger ASUS Z97 ROG Maximus VII Impact ASUS Z97 ROG Maximus VII Formula  
      This included setup was used to upgrade directly to from Catalina to Big Sur but installation should be fine as well.

      Using OpenCore 0.6.3 and latest kexts. Using SMBIOS iMacPro1,1 even tho it may be frowned upon but it worked for DRM at least in Catalina, not willing to change it now. You can however do as you please.

      Everything pretty much works. FaceTime, Messages, AppStore etc. Waking the computer from sleep though requires pressing the PWR button.

      There is no options in OpenCore or Clover, drivers or magic to get native nvram working. You have to modify the BIOS or flash an old one that doesn't have the white list as discussed below. So if you can't go through with fixing the NVRAM, you will have to use the transplant method.

      NVRAM Problem
      Big Sur installer fails after about 20% progress in the Apple logo, fails shortly after disk#: device is write locked ending with apfs_vfsop_unmount. Verbose output below just before restart. I imagine a new install the same problem occurs because after the first state information on the drive and whatever is stored in the native nvram and the installer can't access something that is not there because it wasn't saved in the first place.


      Background
      Reddit post here starts to question it as Haswell in general but seemed more an issue with ASUS Z97 boards. A comment in that thread led me to Vit9696 saying fix your NVRAM. All other paths led to devs are aware and it's an macOS bug or giving up and transplanting the installation by using another machine. Well I ain't having none of that, Vit9696 said fix nvram, so I fixed it.

      Why
      Vit9696 actually solved this for us years ago here. The key take away is the whitelist part and replacing NvramSmi driver.
      Fix
      As stated above we can extract the NvramSmi driver from an older BIOS and the replace it in the latest one. I believe most our boards from this era are no longer being supported but the latest firmwares do have microcode to patch vulnerabilities like Spectre, meltdown, etc. It would be ideal to go this route and it's not that hard and working nvram is great!

      I'm guessing another way would be to flash back to old BIOS where native nvram is working and upgrade/install Big Sur and then flash the latest after. You could save your BIOS profile if available that way you won't have to set everything back up. If this is also the case for incremental updates, sounds like a nightmare.

      How (I chose to fix)

      Replacing the NvramSmi driver made the most sense and it was relatively easy. I am no expert and you know the responsibility I take in anyone trying this **** and failing, ZERO.

      To find a BIOS version before the whitelist was added to the NvramSmi driver I used the dates from the link in Vit9696's quotes. User 314TeR said his ASUS Maximus VII Impact nvram broke after 0412 which was released 2014/10/17 and worked with 0217 released 2017/07/28. To me anything after 2014/10/17 will have added the whitelist.

      So with my board I downloaded version 1104.

      Download UEFITool 0.26.0 as the latest versions won't let you rebuild/replace.

      Download latest BIOS and one without whitelist.

      Load older BIOS in UEFI tool, my case 1104. Search with text nvramsmi and extract as is, the file section. Like below. Save the ffs, name it whatever and close out we are done here.



      Load the latest BIOS now, 3503 in my case and search nvramsmi again. This time replace as is and select the ffs you just named and saved.


      You can't flash the modified BIOS as usual, they are capsules with write security. I just used my board's USB Flashback Utility. Named the modified BIOS to M7H.CAP, each board will have it's on naming method. Copied to a fat32 usb, stuck it in the correct USB port in the back and pressed the button for 3 seconds. 2 minutes later and I was booting my modified BIOS and restarted the upgrade process again from within macOS.

      If you don't have USB Flashback Utility, take a look here for alternative ways.

      After BIOS modified flash test your nvram, mine worked right away. Then I tried the upgrade and that worked fine. I believe it was 4 phases total and 3 reboots. Took about 25 minutes on SSD.

      My modified BIOS 3503 is attached, don't be stupid with it and try to install on a different board. Rename it accordingly if you want to use it.

      Some BIOS Settings
      AHCI - Enabled
      VTD - Disabled
      Primary Display - Auto
      CPU Graphics Multi Monitor - Disabled
      Legacy USB - Enabled
      xHCI - Enabled
      EHCI handoff - Enabled
      Fast Boot - Disabled
      Secure Boot - Other OS
      CSM - Disabled

      OpenCore Configuration Basic Understanding
      ACPI SSDT-EC.aml - fix for EC on Catalina and above SSDT-GPRW.aml - fixes immediate wake from sleep, paired with rename patch in plist SSDT-LPCB.aml - allows AppleLPC to be loaded, helps with power management SSDT-PLUG.aml - necessary for CPU identification and power management SSDT-SBUS-MCHC.aml - allows AppleSMBusPCI/Family/Controller SSDT-USBX.aml - USB power config Drivers AudioDxe.efi - boot chime HfsPlus.efi - reading Hfs partitions OpenCanopy.efi - GUI boot picker OpenRuntime.efi - NVRAM, memory management, etc Kexts AppleALC.kext - audio IntelMausiEthernet.kext - nic Lilu - various fixes and system enhancements USBPorts.kext - USB Mapping (you can edit this details in USB section) VirtuaSMC.kext - Apple SMC emulator WhateverGreen.kext - various fixes for graphics and system devices Resources download from binary resources, removed all audio except boot chime Tools OpenShell.efi - shell cli config.plist Highly suggest looking at the Dortania Guide Haswell section if you are want to know why x is set the way it is, I don't have time for that and that information is readily available USB Ports
      If all accessible ports are enabled in our system it is going to break the 15 port limit so a single sacrifice needs to be made. Instead of wiping out a whole port, I personally removed USB 2.0 ability on one of the USB 3 ports.

      The included USBPorts.kext includes all 16 ports, so the last USB 3.0 port SSP6 port(furthest from ethernet) will not function at 3.0 speeds if you use this kext as is. Customizing is simple with the kext. Open the plist inside the kext and you can remove the one port/functionality you don't need. Included are pictures labeling what is what HSXX and SSPX. There's also a SSDT included to help identify.

      Shout out to @YoshiMac for posting images of the USB ports mapped out. I included some of his work so you have quick access when deciding but his post is great as well. Hopefully I can return the favor a bit with this guide.

      OpenCore Config Customize
      While I added a SMBIOS just to get you going, you need to get your own SMBIOS - > https://dortania.github.io/OpenCore-Install-Guide/config.plist/haswell.html#platforminfo I'm using UIScale 2 for HiDPI, where as you may need to change to 1 Boot args currently uses verbose, you can remove that if all is well after I'm sure I'm forgetting to mention stuff, just let me know if I should warn about some other stuff here. Files Attached
      The included EFI is OpenCore 0.6.3 with updated kexts as of 11/18/2020

      USB Folder includes pics of the mapping and original USBPorts.kext with 16 ports for back up. There is also .dsl file which maps the ports if you need some clarification textually, do not use it.

      Modified 3503 bios for Maximus VII Hero with replaced NvramSmi from 1104.

      Well that wraps it up I think. If you need any extra advice or questions shoot away.
       
      Asus Maximus VII Hero OC 0.6.3 Share.zip
       
      BIOS in next post due to size limit
       
      Modified 3503 bios for Maximus VII Hero with replaced NvramSmi from 1104.
      3503modifiedM7H.CAP
    • By kokozaurs
      Hi all,
       
      I'm using ESXI 7.0b (did use 6.7 to try but with no difference).
       
      Right now on Catalina but I can't seem to try to get GPU (RX580) working properly.
       
      I pass it through to the VM(tried with windows before with no problems) and it appeared just as pci-device with no name.
       
      After that, I've applied whatevergreen + lilu kexts and it does properly recognize it under system report however that's all there is. It's listed at GFX0. See attached images.
       
      No hardware acceleration. Monitor also not turning on using either DP/HDMI. 
       
      Since it is being passed through to the VM, it seems that the problem is not on ESXi side but on macOS side. 
       
      Has anyone has been able to pass through an AMD GPU to ESXI VM? Can anyone suggest some pointers as to where I could find some solutions to this problem?
       
      Thanks! 
       
       



    • By b2550
      Currently my install is 100% working except that so far I have only been able to get one of my 1080p monitors working with a MiniDP to HDMI cable. I currently am getting a second MiniDP to HDMI cable but for now I am stuck with a DVI to HDMI cable.

      The monitor that is working is plugged in via the MiniDP to HDMI. The monitor that isn't working is using the DVI cable. However I also tried switching it to HDMI to HDMI which had the same result. The monitor wakes up but it's black. However for whatever reason, both monitors are still recognized in system preferences and hackintool.

      I know all my cables are good and work because I updated from an install of El Capitan (which I still have on it's original SSD just in case this install fails) as well as a Windows install. Both monitors worked fine on El Capitan for literally years. El Capitan is just too old now and I need to update to keep up with software updates.

      Problem reporting files should provide needed info about how I've configured this install. Build is in my signature.
      debug_22725.zip
    • By autantpourmoi
      I'm an happy user of a x99 built hackintosch since 6/7 years using it mainly for photoshop and fcpx ... Using new camera with better resolution and video in ProResRaw , my built start to struggle a bit 
      I'm thinking of making a new built and seeking for advices for this new built that I want evolutive and last at least as long as my previous built 
      I'll use a SSD M2 forth Generation so I need at least 2 to 3 SSD M2 PCI x4 slots
      then which proc to use , I was thinking about the AMD Ryzen 9 3900xt or the Intel I9 10900k ( don't have the money for AMD threadripper ) if you have better idea I'm really open to it as long as you explain it to me 
      then which chipset should I use:
      for Intel  , should I go to Z490 or X299 or W480
      For AMD , I think I have only the choice of X570
      I always used Gigabyte motherboard so it will be naturally my first choice but again I'm open to any suggestion
      I need at least usb 3,1 Gen 2 and TB3 is not necessary but an option and can be add later on with a PCI Card I think
      So I'll be pleased o read your opinion and the choices that you'll do for the purpose of this built 
      thanks in advance 
       
       
    • By asheenlevrai
      Hi
       
      I recently built my 1st ryzentosh.
      I also used Opencore (0.6.1) for the 1st time and followed the install guides on Dortania.
       
      Now I need to map my USB ports and apparently it's not achieved the same way on AMD platforms compared to what I was "used to" on Intel platforms.
       
      The guide on Dortania is a bit confusing to me since there is information that is not clearly labelled as "for Intel" or "for AMD" and I thus don't understand very well what I should and shouldn't do.
       
      Can anyone give me advice or point towards as comprehensive tutorial intended for AMD-based builds.
       
      Thank you very much in advance for your help.
       
      Best,
      -a-
×