Jump to content
About Just Joined group Read more... ×

2 posts in this topic

Recommended Posts

Hi, I've upgraded from Mojave to Catalina and now my WiFi card didn't recognized in system. I upgraded clover and kexts to latest versions, but Wifi didn't appears.

In "about this Mac" I see:

  • CoreWLAN: 13.0 ((null))

  • CoreWLANKit: 13.0 ((null))

  • Menu Extra: 13.0 ((null))

  • System Information: 12.0 (1355)

  • IO80211 Family: 12.0 (1200.12.2b1

  • Diagnostics: 1.0 (910)

  • AirPort Utility: Not Installed

 

My kexts is:

Spoiler

 

AirportBrcmFixup

FakePCIID

FakePCIID_Broadcom_WiFi

BrcmFirmwareRepo.kext

BrcmFirmwareData.kext

BrcmPatchRAM3.kext

 

 

I checked forum and table of supported Wifi cards - and everything should work (a lot of people has this card working on Catalina). When I was on Mojave my wifi was ok.

As I can see in terminal output ( after command "kextstat") - kext for wifi not loaded, but I'm not sure because I haven't got a lot of experience of this

*my english isn't good enough, sorry for that*

 

Any help appreciated and thanks

loaded-kexts

Снимок экрана 2020-02-02 в 10.48.31.png

Edited by The Krya

Share this post


Link to post
Share on other sites
Advertisement

UPD: I have changed DeviceID in Clover FakeID to 0x43ab OR 0x43b1 - for me they both works.

Edited by The Krya
Problem solved; answer added

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By dadamaja
      Hi all!!
       
      After using my old Dell Clover convert for a few years, I recently built a new Catalina box using OpenCore.  Everything works perfectly and has been very stable.  The only thing that is not working is unlocking with my Apple Watch.  The screen says "Unlocking with Apple Watch" with the spinning graphic and then just prompts for my password.  It does not shake or anything as if the password is incorrect.  My 2014 MBP unlocks without issue and they both use the same iCloud account.  I purchased the Fenvi FV-T919 pci-e adapter and BT, WIFI, Handoff, and Airdrop are all working without issue.  I confirmed in system preferences that unlock is supported and made sure that automatic login is disabled in my profile.  I have cleared keys out of the keystore, restarted a number of times, logged out and back into iCloud all to no avail.  Anyone else having this issue?  Thanks in advance!!
       
      More info my build:
      Asus PRIME z370-A II
      Core i7 9700K
      32 GB PC3200 Crucial Ballistix RAM
      Sapphire Pulse RX380 
      Samsung 970 Evo Plus
      Fenvi FV-T919
      2x Seagate Barracuda 4TB
      CoolerMaster MasterLiquid ML240L V2
       
    • By rajkhand
      It works perfectly till ver. 2.0.7 
       
      I have updated the below mentioned kexts to the latest versions but when I put the latest version (2.0.8/2.0.9) of AirportBrcmFixup no Wifi but if I put AirportBrcmFixup 2.0.7 it works
      BrcmBluetoothInjector
      BrcmFirmwareData
      BrcmPatchRAM3
      BT4LEContinuityFixup
      Lilu & WhateverGreen
       
      I am now on OC 0.6.1 my Wifi/BT card details (also known as Dell DW1560)
      Vendor ID : 0x14E4
      Device : 0x43B1
      Sub Vendor : 0x106B
      Sub Device : 0x0019
      Vendor Name : Broadcom Inc. and subsidiaries
      Device Name : BCM4352 802.11ac Wireless Network Adapter
      Class :  Network controller
      Sub Class : Network controlle
      IOReg Path : IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/RP07@1C,6/IOPP/ARPT@0
      IOReg IOName : pci14e4,43b1
      Device Path : PciRoot(0x0)/Pci(0x1C,0x6)/Pci(0x0,0x0)
       
      OSX 10.15.6 want to update to 10.15.7
       
      Any work around?
       
    • By ALGhackintosh
      Hi @chris1111 i have a tenda w311ma usb wireless adapter , i wanted to make it work with my catalina hackintosh so i installed the driver from the official site , the Rt2870driver.kext file and your wireless panel utility but i have a problem : The software dosent always connect to the acess points and when it does , and everything seems to be ok (even in network section of the system preferences ) when i go to safari for example it tells me that im not connected . I tried to connect the pc to my phone using hotspot , same problem in the pc it shows connected to network but in the phone the pc doesnt appear in the list of the connected devices . What to do ? Please help me !
       
    • By MrPaulfpv
      Hi Im am a complety noob on this of the hackintosh world, and with all im from spain so its difficult.
      I have installed HIgh SIerra woth Aorus Z390 pro wifi, 16GBRam, 8700K, GTX 1060
      I have succesfully follow the guide from Dortania.
      But i`ve figured out i need a patch for mi SSDT-PLUG acpi to work well on mi mobo,. i will link it.
      Then hardware aceleration doest work, ive iltalled nvidia web drivers and lilu and watervergreen are wonking properly, tested witrh comands on Dortania GUide NVRAM works too.
      and for the best part im having freezes that are sooo anoying. Ya i need so much help im asking for a lot but.
      The help will be so much appreciate it.
      good night guys. Have a nice year.
      SSDT-PLUG.aml


×