Jump to content

Can someone help me with MacOS Catalina (10.15.2)?


2 posts in this topic

Recommended Posts

I'm currently running MacOS Catalina 10.15.2

 

Here's what i need help with: 

 

1. Wifi (which previously worked on Mojave)  

2. iMessage 

3. FaceTime 

4. AirDrop 

 

Note: I can't do DSDT patching, tried it many times, and i failed. That's just beyond my capabilities. 

I really hope someone can help me, i've been busting my head for days. :( 

 

If possible, i would like to avoid bricking my os, because i need it for my job on the day after tomorrow. 

 

My RunMe app file: https://mega.nz/#!yxlgiIwR!-XZsreXxNjxjQemXiQia2vcSfITWwr_AVciV2Kdb-ps  

My specs: https://drive.google.com/file/d/1d47b7YXOAitKSYvA9Z6Ojv57ThqXzZxJ/view

 

 

Edited by Shogun212

Clearly, all those apps require running wireless & Bluetooth and I'm failing to see the relevance of the point you were trying to make about DSDT patching.

 

Your laptop appears to be fitted with an Atheros AR9565 card (0168:0036). That was only ever supported in OS X/macOS (and somehow poorly or with limitations) with a specifically re-written Atheros40 driver. Now, surely you cannot ignore that Apple dropped all support for Atheros cards when Mojave was introduced. Afaik, there's been no update to that aforementioned Atheros40 driver since High Sierra (I could be wrong of course), so if the kext you used under Mojave no longer supports your AR9565 card under Catalina, consider it a dead-end.

 

It's a big IF, of course, because, since it's not present in your Clover kext folder, one would assume you did try that kext either in /S/L/E or in /L/E under Catalina. However, I doubt it since the IOReg extract you provided shows no such kext loaded. Unfortunately, the .spx SysInfo/SysProfiler file you provided does not help us on that point because it does not list any kexts at all. Given that the various kext logs you provided do not list anything related to any Atheros driver either, the conclusion seems quite evident. But, by all means, do clarify the situation to enlighten us... Rest assured that no wireless driver means no wireless at all.

 

On the other hand, Bluetooth certainly looks active and properly registered in IOReg (since the necessary kexts are visibly present and loaded). 

 

Maybe you should consider swapping to a properly/fully supported M.2 card like the DW1560 which, in fact, really is the de-facto standard given the extremely limited choice on the matter.

Edited by Hervé
×
×
  • Create New...