Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×
Sign in to follow this  
Followers 0
v7kF4U2HTd

cpu power management primer

3 posts in this topic

Recommended Posts

for a while now i've been pulling my hair out trying to get cpu power management working. i followed a lot of tutorials, tried all clover ssdt option combinations i could think of, used ssdtPRGen with and without freqVectorsEdit, tried different smbios versions, booted with and without the -xcpm kernel option, tried a lot of bios settings ... you get the idea. but unfortunately nothing worked. intel power gadget's freq graph never moved an inch up or down. always perfectly straight.

 

i'm using an asus z10pa-u8 with the latest bios and a xeon e5-2690 v4. my bios settings are as follows:

 

Advanced Power Management Configuration

  • Power Technology: CUSTOM
  • Config TDP: NO
  • P State: turbo and eist YES
  • C State: non retention C6, C3 OFF and C6 ON
  • HWPM native and autonomous C state ON
  • T State: YES

Energy Perf BIAS

  • Energy Performance Tuning ON
  • everything else default

 

with windows these settings work fine. in the task manager i can see the freqs moving between minimum and turbo as needed. so at least nothing is broken. which i started to consider after so many different tries had no effect at all.

 

i've read all kinds of related stuff i could find but there're still gaps because most guides were either very specific to one cpu and osx version and/or lacked important info. so here're a couple of things i would very much welcome an answer to:

  • does the osx version i run have to support my cpu? e.g. would it be possible to get speedstep working with let's say 10.8.5 which had no broadwell support by default?
  • if yes, i assume i have to copy a few files from a later osx which does support my cpu model natively. e.g. a couple of plists for X86PlatformPlugin.kext. so which files would i have to drag over?
  • ideally i'd even like to have speedstep with 10.6.8. is that even possible with my gear?

 

as to clover, to some things i couldn't find a proper answer either:

  • if i do use an aml file, which clover options MUST be off?
  • and is it enough to have them not in the config file or do they have to be set to false explicitly?
  • what's the defaut behavior of settings which are not in the config file? is it the same as setting them to false or is there a difference?
     

i'm using 4798 btw.
 

anyhow i'm using a bunch of osx versions for different tasks so for now getting that to work with just one of them would be great already. i'm using 10.6.8, 10.8.5, 10.9.5 and 10.12.6.


i'm really out of ideas so help in whichever way would be outstanding!
 

Edited by v7kF4U2HTd

Share this post


Link to post
Share on other sites

actually, it seems that only 10.12 had these issues. i found older versions of intel's power gadget and according to these, the older osx versions do cpupm pretty much without any extra work. no turbo though so i'm not sure about the whys and hows.
anyway that's pretty neat already :)

Edited by v7kF4U2HTd

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×