Jump to content

dell m6700 usb 3.0 intel seen as 2.0


9 posts in this topic

Recommended Posts

Hi everyone, I have a problem with the intel USB 3.0 ports of my Dell Mobile Workstation M6700:


5 usb ports in total:
2 usb 2.0 ports (work perfectly)
1 usb / eSata combo port (works perfectly)
2 usb 3.0 intel ports (seen as 2.0 and slow as such)

I tried usbinjectall.kext with the patch limit port for sierra in clover (renamed ehci1 to eh01 .....), nothing.
I applied the patch (to the dsdt.amd) 7-series / 8-series usb of rehabman, nothing. (this method worked on another dell and on a toshiba)
I tried GenericUSBXHCI.kext and fakepciid.kext + fakepciid_xhcimux.kext, nothing.
The system always reads them as 2.0. In the profiler you can see 2 usb 2.0 controllers and no xhci controllers.


I hope you can help me because I'm really freaking out: cry :: cry:


Fyi some files.









Edited by itpwd
Link to comment
Share on other sites

4 hours ago, Hervé said:

You could either apply ACPI fix "FixDarwin7" in your Clover config (use Clover Configurator app to that effect) which sets Darwin for Windows 2009 (i.e. OSYS gets set for Win7) or patch your DSDT


Hi Hervé,

Thank you for providing two professional methods.

Maybe my luck is not good.


Method 1: Fix "FixDarwin7"

Restart cannot be loaded/entered into the OS after fix "FixDarwin7".

Fyi -v screenshot.



Method2: Patch DSDT

I am not familiar with patch dsdt, there are two syntax errors here, but I don't know how to fix it.

Fyi the dsdt.dsl.




Hope to receive your reply/help. And I hope you have a great time every day. ^_^

Edited by itpwd
Link to comment
Share on other sites

9 hours ago, Hervé said:

It's just the well-known and documented ACPI/iASL bug that messes up the section of code for PM6H and PM0H.

In fact, I found that the syntax here is not normal, but because I am not familiar with dsdt…

Thank you for your information, I have learned the knowledge of dsdt.


9 hours ago, Hervé said:

Anyway, here's your patched DSDT and source code with bug fix:



Please note that, since we're dealing with an iASL bug, the issue will return if you open up the compiled DSDT.aml file I just posted and recompile it. That's why I've also attached the source code .dsl file that includes the fixed piece of ACPI code. Ideally, apply any subsequent patch to the .dsl file before recompiling the DSDT. If you simply re-open the .aml file for modification (which you're perfectly allowed to do), you'll have to also re-apply the above fix.

Got your information.

But the patched file you provided cannot be loaded into the system after being placed in ACPI/patched.

I tried to replace FakeSMC/VirtualSMC or remove FakePCIID/FakePCIID_XHCIMux in the kext directory, but it didn't work very well.
To do this, I generated the debug file(not included dsdt.aml) and asked for your help again.


Hope all is well and fine.



Link to comment
Share on other sites

Hi Hervé,

Good news.

Works good after apply USB fix "Repair ownership"(I am not sure if this translation is in English.) in Clover config.


Thanks for your professional information.


Link to comment
Share on other sites

3 hours ago, Hervé said:

So I guess both OSYS adjustment methods should work with this additional fix in place.

Hi Hervé,

You are right. I tested two methods.

Both of these methods can achieve the display USB3.0 (1e31), then what is the difference between them?



Link to comment
Share on other sites

44 minutes ago, Hervé said:

In a nutshell, Clover's method basically defines the OS to Win7 in DSDT through a fancy patch whilst the other method simply injects Darwin OS alongside Win Vista (or Win7) in a much shorter single-line mod.


Both methods basically achieve the same result but Clover's patch is an on-the-fly direct modification of the DSDT table loading from BIOS ROM whilst the other method I described consists of a patched DSDT table saved in a file that Clover loads at system startup to replace the default BIOS table.

Hi Hervé,

Thanks for your quickly reply.

I am afraid this requires more knowledge to understand what you mean.

There should be some guidelines for the fix in this area, but I can't search for it.

It should be said that I don't know how to search for keywords. I don’t seem to be able to search for related cases in the Chinese community.

Can you provide some typical examples /link to study? If possible, I will share your professional information to some Chinese communities to help more people search for this information.


BTW, in the advice of novices, which method do you think is better?



Link to comment
Share on other sites

  • 2 months later...

  • Create New...