Jump to content

[SOLVED] Realtek RTL8153 USB


4 posts in this topic

Recommended Posts

Someone is using this usb lan adaptor after the upgrade to Catalina (was working good OOB in Mojave)

 

I can see it under USB devices in system report but the LAN is not showing in System preferences-> Network ...

 

Is something wrong on my Hack or is just not compatible with Catalina ?

 

Thanks

Mattia

 

 

EDIT : Solved after the upgrade to 10.15.1 beta 2

Edited by tmbt

Hi,I'm in the exact same situation than you,  I just installed macOS 10.15.1 on my laptop, but the update did nothing :/ My adapter is a AUKEY Gbe USB-C ethernet dongle using the same RTL8153 chipset.

 

Edit : Problem solved, it was due to kext conflicts.

Edited by Gabigeek
  • 3 weeks later...

@Gabigeek what kexts were conflicting? I can't get my adapter to work and I struggled half day with this already

 

EDIT: For other users that might have this problem, give this a try:

Following @Gabigeek comment I searched for conflicting drivers and found something.

// Un-plug your adapter

// Backup and remove Apple's driver
rsync -avzh /System/Library/Extensions/AppleUSBRealtek8153Patcher.kext ~/Desktop/ 
sudo rm -rf /System/Library/Extensions/AppleUSBRealtek8153Patcher.kext
// Install driver from Realtek
// Refresh kextcache (I used an app called "Hackintool" which has an option on "Tools" tab)

// Reboot

 

I tried like 10 hours a lot of methods and only last night I realised that driver might conflict with the ones from Realtek and probably that's the case. For now my network survived restarts and looks/sleeps and look stable.

 

I hope this is the fix and I hope it will help others.

 

Edited by doruchiulan
  • 10 months later...
×
×
  • Create New...