Jump to content
deanza

Hackintosh 10.14.5 GIGABYTE Z390 I AORUS PRO WiFi i9-9900K RX 580 - Stable

2 posts in this topic

Recommended Posts

Posted (edited)

This is not intended to be a complete and comprehensive installation guide. Rather, this is supplemental information specific to the hardware listed below. I hope you find this information useful, it took me a while to get to a stable state.

 

Resources I found helpful:
https://github.com/cmer/gigabyte-z390-aorus-master-hackintosh/blob/master/STEP_BY_STEP.md
Why InsanelyMac does not support tonymacx86

 

System Hardware

  • GIGABYTE Z390 I AORUS PRO WiFi (Intel LGA1151/Z390/Mini-ITX/M.2/Realtek ALC1220-VB/Intel GbE LAN/HDMI/Motherboards)
  • Intel Core i9-9900K Desktop Processor 8 Cores up to 5.0 GHz Turbo unlocked LGA1151 300 Series 95W
  • Noctua NH-L12S 70mm Low-Profile CPU Cooler with Quiet 120mm PWM Fan
  • 2 of Patriot Viper Elite Series DDR4 16GB PC4-21300 2666 MHz Memory Module (Black/Grey)
  • Samsung 970 EVO 1TB - NVMe PCIe M.2 2280 SSD (MZ-V7E1T0BW)
  • Sabrent 2TB Rocket NVMe PCIe M.2 2280 Internal SSD High Performance Solid State Drive (SB-ROCKET-2TB)
  • Seagate Exos X12 12TB SATA 6Gb/s 256MB Cache Enterprise Hard Drive 3.5" (ST12000NM0007)
  • Sapphire 11265-05-20G Radeon Pulse RX 580 8GB GDDR5 Dual HDMI/ DVI-D/ Dual DP OC with Backplate (UEFI) PCI-E Graphics Card Graphic Cards
  • CORSAIR SF Series, SF750, 750 Watt, SFX, 80+ Platinum Certified, Fully Modular Power Supply
  • USB Adapter Bluetooth 4.0 Dongle for PC & Mac, Special Accessory for Systems That Work with Multifunctional Device Hideez Key, Support All Windows & Mac OS - Matte Black
  • Inamax USB WiFi Adapter 1200Mbps, USB 3.0 Wireless Network WiFi Dongle with 5dBi Antenna for PC/Desktop/Laptop/Mac, Dual Band 2.4G/5G 802.11ac,Support Windows 10/8/8.1/7/Vista/XP, Mac10.5-10.14
  • SilverStone Technology Mini-ITX Slim Small Form Factor Computer Case with Handle (SST-ML08B-H-USA)

 

Bios Configuration, what's important:
Bios Version -> F5
M.I.T -> Extreme Memory Profile(X.M.P.) -> Disabled
Bios -> Windows 8/10 Features -> Other OS
Peripherals -> USB Configuration -> XHCI Hand-off: Enabled
Chipset -> VT-d -> Disabled
Chipset -> Internal Graphics -> Enabled
Chipset -> Audio Controller -> Enabled
Chipset ->  Above 4G Decoding -> Enabled
Power -> CEC 2019 Ready -> Enabled


M.I.T -> Advanced Frequency Settings:
You can leave this alone, or play around a bit. I have my settings set to 5.0Ghz on all cores with 250 watts maximum.  I haven’t notice any issues other than thermal limitations.  Just makes sure you leave:
M.I.T -> Advanced Frequency Settings -> Advanced CPU Core Settings -> TjMAX Temperature -> Auto

 

Clover Configuration
Current clover version is 4945. OSX = 10.14.5, utilizing 18.1 apple model (18.3 had issues with the bluetooth adapter). The USBMap.kext is specific to this mainboard. The two USB ports above the Ethernet port are 2.0 all other ports are 3.1.  The iGPU settings in the config file are specific to the i9-9900K. It works in headless mode with the RX 580 (and did so for the other graphic cards I tried).  I used Hackintool, to identify the iGPU settings for the config file, and to install the Kexts to the OS.  Note, I did not do a fresh installation, I used a clone of an existing OSX system and copied it over.

 

Custom files attached: config.plist | USBMap.Kext

 

EFI -> CLOVER -> drivers64UEFI

  • SMCHelper-64.efi
  • ApfsDriverLoader-64.efi
  • AudioDxe-64.efi
  • DataHubDxe-64.efi
  • EmuVariableUefi-64.efi (Need this for proper shutdown and restart)
  • FSInject-64.efi
  • HFSPlus.efi
  • NvmExpressDxe-64.efi
  • OsxAptioFix2Drv-free2000.efi (replace with AptioMemoryFix-64.efi if you have booting issues with a graphic card, see note below).
  • PartitionDxe-64.efi

 

EFI -> CLOVER -> kexts -> Other

  • WhateverGreen.kext
  • VirtualSMC.kext
  • USBMap.kext
  • SMCSuperIO.kext
  • SMCProcessor.kext
  • SMCLightSensor.kext
  • SMCBatteryManager.kext
  • Lilu.kext
  • IntelMausiEthernet.kext
  • AppleALC.kext


CPU Thermal restriction
The i9-990k is unable to run at 5.0Ghz for any sustained amount of time (all cores running at 100% beyond a few moments) in my setup.  When running a full load (all cores @ 100% @ 5Ghz) the frequency lowers to about 4.3 - 4.5 Ghz.  It appears the CPU is drawing 100 - 110 watts at that state. I am content with the performance and works well for my needs. 

 

I originally started with this cooler: Noctua NH-L9x65, 65mm Premium Low-Profile CPU Cooler (Brown). Then tried: Noctua NH-L12S 70mm Low-Profile CPU Cooler with Quiet 120mm PWM Fan.


I think I get a little bit more out of the CPU with the NH-L12S, however I had to use the smaller fan from the NH-L9 to fit in the computer case. If you use the NH-L12S, you may need to bend the pipes slightly (kind or squish it in) to get it to all fit. In the end, not sure the NH-L12S is worth the trouble. However, it is what is on my system.  I also have 2 of Noctua NF-A4x20 PWM, Premium Quiet Fan, 4-Pin (40x20mm, Brown).  I placed them in a way to blow onto the base of the CPU in an attempt to cool things down even further.  I didn't notice any performance increase from doing so.  But I left them there.

 

GPU
In the end, I assume that each of the graphics cards would have worked without issue if I had keep the memory at the base clock speed in Bios (i.e. not using 'profile 1').  This is one thing I wish I had tried early on, as it would have saved me a great deal of time.

 

Originally I setup the system without a dedicated graphics card.  I found that utilizing the GPU on the i9-9900K allowed me to implement less than appropriate settings, while utilizing the system without significant issue. (The settings in the EFI I have shared are now correct). I encountered problems when attempting to add an external graphics card. 

 

In order, these are the graphics cards I attempted to use (all on 10.14.5).

  1. Gigabyte Radeon Computer Graphics Cards (GV-RXVEGA64GAMING OC-8GD)
  2. PowerColor Radeon VII 16GB HBM2 PCI-E DP/HDMI Vega 7nm Video Graphics Card
  3. Sapphire 11276-02-40G Radeon Pulse RX Vega 56 8GB HBM2 Dual HDMI/DP (UEFI) PCI-E Graphics Card
  4. Sapphire 11265-05-20G Radeon Pulse RX 580 8GB GDDR5 Dual HDMI/ DVI-D/ Dual DP OC with Backplate (UEFI) PCI-E Graphics Card Graphic Cards

 

Noted behavior:  Each graphics card, upon the first boot was able to boot fully into the OS.  On or after 1 - 3 reboots, the system no longer loaded. The solution was to replace AptioMemoryFix-64.efi with OsxAptioFix2Drv-free2000.efi.  I also found that disabling the internal GPU was also a viable solution in-order to boot into the OS, but of course the iGPU will not be headless.

 

On 10.14.5 I was able to boot utilizing all four (4) graphics cards.  Most everything seemed to run fine, video playback and brief video encoding.  Note that the GPU fans turned off when booting into the OS.  I initial thought this was a problem, but now believe this may be normal behavior for 10.14.5.  The fans on the RX 580 seem to engage under heavy load, my assumption is that I never placed the other GPU's under heavy load and took note of the fan at the same time.

 

Under intensive encoding tasks lasting longer than 10 minutes and up to 3 hours (almost all CPU based, not GPU), the system would become unresponsive. A hard reboot was the only resolution. I tried all sorts of solutions over the course of a few months, and tried all four (4) graphics cards.  All experiencing the same behavior.  The final solution was simple. Disable overclocking of the memory in the bios, specially turning off 'profile 1'.

All four cards experience the same issue under the same conditions.  Therefore, I feel fairly confident that any of the four cards would have work just fine, with the correct memory setting.  I'm staying with the GPU I have now, RX 580.  It is just able to handle the 4K video editing of time lapse stills I use the system for. I like the idea of having the Vega 7, and there is a bit better performance in premier and in encoding video files.  However it is much more power than I technically need at the moment, and in my application (non-gaming) it is mostly unused potential.

config.plist

USBMap.kext.zip

Edited by fantomas1

Share this post


Link to post
Share on other sites
Advertisement

Hi! i have this setup and i want to try it!

Why should i leave internal graphics enabled if i want to use my radeon¿

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×