Jump to content

Clover unable to load any kext on mojave


5 posts in this topic

Recommended Posts

The picture was taken on the very early stage of clover booting output. FakeSMC, Lilu and any other kexts were not able to load, saying "not entitled to link kext".


Checked the permission of kext binaries are all 777.
Tried with different versions of clover - all same.

 

RTVariables are also set:

Quote

    <dict>
         <key>BooterConfig</key>
         <string>0x28</string>
         <key>CsrActiveConfig</key>
         <string>0x67</string>
         <key>ROM</key>
         <string>UseMacAddr0</string>
     </dict>



Hardware: Xeon E5 2648/Supermicro C612 Motherboard/RX580, almost copied everything from KGP's guide.

Anyone has any idea?
Thanks

IMG_0959.jpg

Edited by geeti

Where are your kexts? Are you injecting them from Clover's E/C/k/O or did you install them in /S/L/E or /L/E to cache them? Which version of Clover are you using?

 

Kexts permissions should be 755, not 777 and ownership should be root:wheel.

 

Please post a zipped copy of your Clover EFI folder (remove the Themes subfolder).

Edited by Hervé
  • 1 month later...

OMG this is exactly what has been happening to me since I tried to update to Mojave. The laptop worked perfectly fine under HS. I have attached my EFI. This is for the Dell Inspiron listed in my signature.

 

988080046_ScreenShot2019-07-19at12_14_33PM.thumb.jpg.93ce60a817ac3b84f122ffada5f37bb5.jpg

 

I pulled the hard drive out of the laptop and ran the below on Clover>Kexts>Other

sudo chmod -Rf 755 
sudo chown -Rf 0:0 

Still no luck. I am pulling my hair out over this one.

EFI.zip

 

EDIT:

Well. Hmpf. After reading some other posts elsewhere, I decided to update Clover to the latest (5018) from RehabMan's 4700. And voila, my laptop booted with no issue. I was always led to believe that I shouldn't; update from RehabMan's version since some of the fixes were tied to it, but I guess since he is MIA that no longer holds true.

Edited by pkdesign
FIX
×
×
  • Create New...