Jump to content
blxkspell

HDD keeps spinning up

10 posts in this topic

Recommended Posts

Is there any possibility to monitor the apps which access my external HDD as I enabled standby for hard drives in the energy saving settings BUT they keep spinning up randomly (every 5-10 min).

This is very annoying because of the noise and it certainly cant be to good for a HDD to spin up/ down - up/ down ... all the time.

I have even set them to be unmounted with Paragon actually as I don't need them in macOS (they are Windows NTFS drives).

Hope there is a possibility to completely turn them off.

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)

My opinion is the best way is create a LaunchAgents with a simple app create with an Applescript

On that way the Volumes will be Unmount at each Login

Your only have to edit the name of the volume in the Applescript then Save

144497905_Capturedcranle2019-05-2307_35_23.png.d9db0a1b2a3555666519661604ec6e0e.png

2012443442_Capturedcranle2019-05-2307_38_59.png.2727268ac0c68b49d087820b885cfb14.png

 

Now put this app on your Applications

 

Put the com.Unmount.plist on Root volume ➣ /Library/LaunchAgents

Double click to Executable Agents (You can see the contant of the script, by opening with textedit)

                                                                  ⬇︎

#!/bin/bash
# This is useful for loading launch daemons and agents.

cd /Library/LaunchAgents 
sudo chown root:wheel com.Unmount.plist
sudo chmod 644 com.Unmount.plist
sudo launchctl load /Library/LaunchAgents/com.Unmount.plist


exit 0

 

Attaching here the necessary files

I just test right now and it work :wink_anim:

com.Unmount.plist.zip

Executable Agents.zip

Unmount.zip

Edited by chris1111

Share this post


Link to post
Share on other sites
Posted (edited)

Another easy way is to create a LoginHook

Put the attaching script in Home 

1720485523_Capturedcranle2019-05-2313_10_51.png.19876c1f66bd4490084733eb7ee38b98.png

Edit the script with the name of Windows volumes

 

#!/bin/bash
diskutil Unmount  /Volumes/"Windows-10"

Loupe.png.8cc21082c49cc231788aabdddc988757.png

 

Open the Terminal.app and Type this

chmod +x ~/LoginHook.sh

 

sudo mv ~/LoginHook.sh /usr/local/bin/LoginHook.sh

 

sudo defaults write com.apple.loginwindow LoginHook /usr/local/bin/LoginHook.sh

 

 

Reboot :D

LoginHook.sh.zip

Edited by chris1111

Share this post


Link to post
Share on other sites

Thanks for the detailed explanation but this unfortunately doesnt help me out... The paragon software already unmounts my drives after login.

In fact some random apps still try to access them randomly even they are unmounted and dont show up in finder.

Bildschirmfoto 2019-05-23 um 22.03.49.png

Share this post


Link to post
Share on other sites
3 minutes ago, blxkspell said:

Thanks for the detailed explanation but this unfortunately doesnt help me out... The paragon software already unmounts my drives after login.

In fact some random apps still try to access them randomly even they are unmounted and dont show up in finder.

Bildschirmfoto 2019-05-23 um 22.03.49.png

delete the app use this 

LoginHook

 

Share this post


Link to post
Share on other sites

Ok thank you again for your help. But as I said, they are ALREADY unmounted. No need to unmount them twice. My problem is that:

 

15 minutes ago, blxkspell said:

 

In fact some random apps still try to access them randomly even they are unmounted and dont show up in finder.

 

 

So what I need is to restrict the OS or any stupid apps to randomly access my HDDs 

 

 

 

Share this post


Link to post
Share on other sites
3 minutes ago, blxkspell said:

Ok thank you again for your help. But as I said, they are ALREADY unmounted. No need to unmount them twice. My problem is that:

 

 

So what I need is to restrict the OS or any stupid apps to randomly access my HDDs 

 

 

 

Your are using Paragon to Unmount

this is the problem because the Drive is use by paragon and all Sh...it stuff....

Dont use paragon to unmount the drive

Share this post


Link to post
Share on other sites

well it doesnt make any difference. I disabled paragon and still the drive spins up every 5-10 min being unmounted

Share this post


Link to post
Share on other sites

I have found out what spins up my HDD all the time!

It seems to be the HWMonitor app which is running all the time!

1842990870_Bildschirmfoto2019-05-26um12_33_48.thumb.png.e6d11bd0d0c947949b875d938d0b1490.png

 

The SMART check thing causes my problem as it was set to 10min. The max time is 30min which is quite better but still annoying. Is there a way to completely disable it?

Share this post


Link to post
Share on other sites

Are you sure you have not enable the SMART in BIOS ?

I have always this setup disable

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×