Jump to content

iTunes Crashing: Mojave (macOS 10.14.5), iTunes v12.9.5


11 posts in this topic

Recommended Posts

I have a fairly new system and was trying to get things migrated over, and iTunes is crashing about 7-8 seconds after opening.  Audio does work (through QuickLook, VLC), and so far this is the only issue I've noticed (except hot plugging of USB devices seems to cause a kernel panic ... that's a separate issue?).  I did a fair amount of internet searching on this issue and can't find anyone having it in Mojave, 10.14.x, so that's why I'm posting a new thread.


The big issue that seems to have fixed the problem for people in the past is to use a kernel extension named "Shiki," but that is now part of WhateverGreen.  I do have the latest version of WhateverGreen (April 9, 2019 - v1.2.8 - as of this post), so that doesn't seem to be a fix.


When I say this is a "fairly new system," from an iTunes standpoint it's a completely new system.  Nothing in the library, and I made doubley sure and deleted everything in my ~/ directory and sub-directories that had iTunes in it to make sure that wasn't the issue.  I also tried to limit any internet activity to it by blocking all connections in Little Snitch, then just pulling the ethernet plug, but it still crashed.  Another person's fix of trying to play something in it on startup, and another's of trying to close the main window on the application's startup also did not fix the crash issue.  And trying to add the shikivga=1 flag at startup also didn't fix things (if it would do anything anyway since it's part of WhateverGreen?).  I tried putting the AppleALC.efi in my drivers, still crashed.


Here's the dump of the Report that it would send to Apple, up to where it starts listing thread-by-thread what was going on:


Process:               iTunes [10373]

Path:                  /Applications/iTunes.app/Contents/MacOS/iTunes

Identifier:            com.apple.iTunes

Version:               12.9.5 (12.9.5)

Build Info:            iTunes-1200012009005005~7

Code Type:             X86-64 (Native)

Parent Process:        ??? [1]

Responsible:           iTunes [10373]

User ID:               501


Date/Time:             2019-05-15 22:17:36.258 -0600

OS Version:            Mac OS X 10.14.5 (18F132)

Report Version:        12

Anonymous UUID:        0933F537-03A5-85E1-B758-E7C6536848AD



Time Awake Since Boot: 8000 seconds


System Integrity Protection: disabled


Crashed Thread:        2  Dispatch queue: com.apple.FigASMF.InstanceManagement


Exception Type:        EXC_BAD_ACCESS (SIGSEGV)

Exception Codes:       KERN_INVALID_ADDRESS at 0x000000000000044c

Exception Note:        EXC_CORPSE_NOTIFY


Termination Signal:    Segmentation fault: 11

Termination Reason:    Namespace SIGNAL, Code 0xb

Terminating Process:   exc handler [10373]


VM Regions Near 0x44c:


    __TEXT                 000000010d553000-000000010f27e000 [ 29.2M] r-x/rwx SM=COW  /Applications/iTunes.app/Contents/MacOS/iTunes


Application Specific Information:

dyld3 mode


Suggestions?  I'm hesitant now to update my old Hackintosh from 10.11.4 to 10.13.6 (NVIDIA GPU) if I can't get iTunes working on this computer.

Link to comment
Share on other sites

Same problem here. I was reading some others that had the same issue on another forum were able to solve it by changing the SMBios, I'm hoping there's another solution because last time I did that I had to re-register a bunch of my software and my rig is working fine otherwise on 10.14.4. I assume it has something to do with the hardware decoding changes made to AMD cards. If I find a solution I'll report back here.

Link to comment
Share on other sites

On another forum, it looks like everyone affected by this is using the MacPro6,1 SMBios.  Are you using that one, too?  I selected it because that's what worked to solve the QuickLook / Preview viewing problem with .JPG files.

Link to comment
Share on other sites

1 minute ago, astroguy said:

On another forum, it looks like everyone affected by this is using the MacPro6,1 SMBios.  Are you using that one, too?  I selected it because that's what worked to solve the QuickLook / Preview viewing problem with .JPG files.

Yes, I'm using MacPro6,1

Link to comment
Share on other sites

I think I figured it out, no iTunes crashes so far. Basically instead of changing the SMBios, we just need to tell AppleGVA.framework to use the configuration for a different board-id (in this case the iMacPro1,1).
Use the following boot flags: shikigva=32 shiki-id=Mac-7BA5B2D9E42DDD94
You need WhateverGreen for them to work.
You may need to use shikigva=40 instead if you have an iGPU. 


Here's why/how this works..

According to the crash report, it's pretty clear that AppleGVA is the culprit if I scroll down to the actual crash:

Thread 16 Crashed:: Dispatch queue: com.apple.FigASMF.InstanceManagement
0   com.apple.AppleGVAFramework       0x00007fff62ac2be3 0x7fff62a9f000 + 146403
1   com.apple.AppleGVAFramework       0x00007fff62abb318 0x7fff62a9f000 + 115480
2   com.apple.AppleGVAFramework       0x00007fff62af0a18 0x7fff62a9f000 + 334360
3   com.apple.AppleGVAFramework       0x00007fff62abad88 0x7fff62a9f000 + 114056
4   com.apple.MediaToolbox            0x00007fff572b1aaf 0x7fff56e0d000 + 4868783
5   libdispatch.dylib                 0x00007fff7e82763d _dispatch_client_callout + 8
6   libdispatch.dylib                 0x00007fff7e833129 _dispatch_lane_barrier_sync_invoke_and_complete + 60
7   com.apple.MediaToolbox            0x00007fff572b0dc3 0x7fff56e0d000 + 4865475
8   com.apple.MediaToolbox            0x00007fff572b0d17 0x7fff56e0d000 + 4865303
9   com.apple.MediaToolbox            0x00007fff571ee100 0x7fff56e0d000 + 4067584
10  libdispatch.dylib                 0x00007fff7e82763d _dispatch_client_callout + 8
11  libdispatch.dylib                 0x00007fff7e82d8e0 _dispatch_lane_serial_drain + 602
12  libdispatch.dylib                 0x00007fff7e82e396 _dispatch_lane_invoke + 385
13  libdispatch.dylib                 0x00007fff7e8366ed _dispatch_workloop_worker_thread + 598
14  libsystem_pthread.dylib           0x00007fff7ea67611 _pthread_wqthread + 421
15  libsystem_pthread.dylib           0x00007fff7ea673fd start_wqthread + 13

So we just need to use AppleGVA's settings for a known working SMBios instead of actually changing the SMBios.


Explanation of the shiki boot flags bitmask can be found here: https://github.com/acidanthera/WhateverGreen/blob/master/WhateverGreen/kern_shiki.hpp

shikigva=32 is the ReplaceBoardID flag, and needs to be followed by the shiki-id flag to specify the board id for AppleGVA. According to that link, AddExecutableWhitelist is required for iGPUs, which has a value of 8, so 8+32 would make the bitmask 40. So if you have an iGPU use shikigva=40 instead. I don't personally have an iGPU so I can't confirm whether or not that works.


P.S. Preview and Quicklook for JPEGs still work fine since we aren't changing anything for AppleVPA.framework



Worth noting: The bootflag is shikigva, not shikivga :thumbsup_anim:

Edited by jamiethemorris
  • Like 1
Link to comment
Share on other sites

Thanks jamiethemorris


your solution worked for me , I use the MacPro 6.1 SMBios  , only added the  "shikigva=32 shiki-id=Mac-7BA5B2D9E42DDD94" boot flag, now I can use iTunes on 10.14.5


Thanks again for helping us all ....  

Screen Shot 2019-05-18 at 10.53.32 AM.png

Edited by oskr66
Link to comment
Share on other sites

Worked for me , MacPro 6.1 SMBios  , only added   "shikigva=32 shiki-id=Mac-7BA5B2D9E42DDD94" boot flag, and changed  the USB patch ;


If you are not using an SSDT  the USB patch can be used to inject missing USB3 ports by increasing the port limit.

  1. Mount EFI Partition with Clover Configurator
  2. Navigate to /Volumes/EFI/EFI/Clover/
  3. Right-click open config.plist with Clover Configurator
  4. Click Kernel and Kext Patches under SECTIONS of Clover Configurator
  5. Click the “+” button near the bottom to add this patch:
    1. Patch #1:
      • Name*: com.apple.iokit.IOUSBHostFamily
      • Find* [HEX]: 83FB0F0F
      • Replace* [HEX]: 83FB3F0F
      • Comment: USB Port Limit Patch 1 PMHeart/DalianSky
      • MatchOS: 10.14.x
    2. Patch #2:
      • Name*: com.apple.iokit.IOUSBHostFamily
      • Find* [HEX]: 83E30FD3
      • Replace* [HEX]: 83E33FD3
      • Comment: USB Port Limit Patch 2 PMHeart/DalianSky
      • MatchOS: 10.14.x
    3. Patch #3:
      • Name*: com.apple.driver.usb.AppleUSBXHCI
      • Find* [HEX]: 83FB0F0F
      • Replace* [HEX]: 83FB3F0F
      • Comment: USB Port Limit Patch 3 PMHeart/DalianSky
      • MatchOS: 10.14.x
    4. Patch #4:
      • Name*: com.apple.driver.usb.AppleUSBXHCI
      • Find* [HEX]: 83FF0F0F
      • Replace* [HEX]: 83FF3F0F
      • Comment: USB Port Limit Patch 4 PMHeart/DalianSky
      • MatchOS: 10.14.x
  6. Save config.plist
  • Like 1
Link to comment
Share on other sites

Yay!  The fix worked for me, thanks!  Now I'm more comfortable about wiping my last computer (whose motherboard has been dying for the last year) -- iTunes was the last main issue with migrating from my 2016 Hackintosh (that's still running 10.11.4).

  • Like 1
Link to comment
Share on other sites

  • 3 months later...

  • Create New...