Jump to content
dsforsaken

Black screen before installer... (z77 i3570k / RX570)

5 posts in this topic

Recommended Posts

Posted (edited)

Hey Guys, Ive been trying to install mojave on my Z77 Extreme 4 i5 3570K (Ivy) /w Radeon RX 570 4GB.  I get through the clover bootup process (apple logo) but it goes to black screen after that.  I think something may still be happening in the background because If I leave it long enough, my PC will go to sleep and I can wake it back up to the black screen.  Im connected to DP on my video Card.  Ive tried all the DP outputs using a Mini DP -> DP cable.  I tried the HDMI as well using HDMI cable.    Ive tried a couple Config.plists but im out of Ideas now.  Any help is greatly appreciated! 

 

(I've attached both config.plist attempts)

config.plist

config_orig.plist

Edited by dsforsaken

Share this post


Link to post
Share on other sites
Advertisement

Thanks! Ill try that out.  Is there a way to generate an SSDT in windows or only linux/masOs? I tried to use AIDA64 but the new version (5.99) doesnt have the ACPI Tool and the old version (2.30) doesnt seem to work anymore.

Share this post


Link to post
Share on other sites

Same problem for me. I tried everything but screen always black when i boot from USB before intalling. I use latest lilu and weg kexts, monitor connected with HDMI. Once i succesfully installed the Mojave, but my old SSD is broken and i bought a new SSD and can't the install system because for the black screen.

Here is my config.plist

 

config.plist

Share this post


Link to post
Share on other sites
Posted (edited)

This is the boot flags what i using npci=0x2000 keepsyms=1 debug=0x100 -v

And i tried -radvesa -x

Edited by Addrii30

Share this post


Link to post
Share on other sites

So Ive got this booting now!  I had to keep messing around with a combination of DP-DVI adapter connected to  a DVI->HDMI adapter connected to my monitor.  For some reason straight DP or straight HDMI wont work lol...  It also boots in ypbpr mode, I think i may have to patch the EDID to force RGB though. Thanks for your help.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×