Jump to content

Installing Mac OSX on Asus ROG G51J (MB Ver. G60Jx)


5 posts in this topic

Recommended Posts

Hi ! I have issues trying to install Mac OSX on my ASUS ROG G51J laptop (with "MB Ver. G60Jx" written on the back).

I followed the steps of this tutorial: https://www.insanelymac.com/forum/topic/283111-installing-os-x-1082-windows-8-dual-boot-on-asus-g51jx/, however I couldn't boot directly on the bootable Lion USB (not ML) created with myHack, the laptop would just reboot without doing anything. So I tried multiple bootloaders, such as Empire EFI, but I still couldn't get to the installation screen. With Empire EFI, I got stuck on "PCI configuration begin", on [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] I got a kernel panic error with something like "unable to find driver for this platform: acpi...." and I couldn't get Chameleon to boot on a USB flash drive. The specs on this laptop are the following:

Intel i7-720QM

GeForce GTS 360M

8GB RAM

500GB HDD

I tried multiple boot flags, like -v, -f, -x, GraphicsEnabler=No, PCIRootUID=1, cpus=1, npci=0x2000/npci=0x3000.

Also, the options in the BIOS are very limited, I couldn't find something related to a SATA Mode option. Although I think the BIOS isn't updated to its latest version but I don't know if it would change something.

Should I try another distro/version of OSX or another bootloader ? Thanks in advance !

Sorry if my english is not very good.

 

 

Edited by SmilexD

Can you post a zipped copy of the Extra folder you're using for that laptop? Lion is really old and your platform is capable of running HighSierra as standard, Mojave probably too with some little tricks for the Tesla dGPU (officially unsupported).

 

With Chameleon, you'll need to set GraphicsEnabler to Yes. Ideally, set HDD mode to AHCI in BIOS. Lion used to require to rollback an older AppleACPIPlatform kext v1.3.5/v1.3.6 from Snow Leopard 10.6.7/10.6.8 to avoid getting a KP on boot. Check that your Extra folder contains that kext.

AppleACPIPlatform.kext.zip

 

Edited by Hervé

Hi, thank you for the answer. Here is the Extra folder I'm using: https://mega.nz/#!uuJmGYZT!mkmNQvLGZIj1UamD21vGBySR-RwAk7s5f0dPy6VbfvQ

I managed to boot on Chameleon and replaced the AppleACPIPlatform kext but I still got the Kernel panic error (the kext on the archive might be different from the one you linked because I tried another version after).

I posted pictures to give more details, thanks in advance !

IMG_20190412_220624.jpg

IMG_20190412_220416.jpg

Your Extra folder seems incorrect and incomplete to me. Try this basic one with myHack. Copy it to your USB installer then run myHack on it and point to that new Extra folder so that myHack does its update with it.

Extra.zip

 

it'll not support all the hardware but we can add the required drivers as you identify the rest of your hardware on that laptop.

 

Thank you for your help but unfortunately that didn't work, I replaced the Extra folder with myHack and still get the same error. Should I create a new installer with High Sierra ?

×
×
  • Create New...