Jump to content
AnttiAnon

AppleUSBHostController

4 posts in this topic

Recommended Posts

Hey,

 

I've been following Shaneee's tutorial on AMD OSX: https://forum.amd-osx.com/viewtopic.php?f=24&t=5902

I got to the point where I had to boot to single-user mode to input the commands written by XLNC, because my system always rebooted in Data&Privacy.

Now when I try to boot into the OS without '-s' I get this:

 

 

That AppleUSBHostController error was there when I was booting into the installer too, but it still booted after a while.

Using USB 2.0 ports wouldn't boot the installer at all, but I found out I needed to use USB 3.0.

When I tried booting into the system though, I waited 30 minutes and it didn't help.

 

I have tried many different prelinkedkernels. Some of them don't cause the USB-errors to flood the screen in single-user mode, some do.

None of them can boot into the system though, and always have that error shown in the video.

I have also tried disabling/enabling CSM and EHCI hand-off in bios, but that didn't help either.

I've seen many others having this issue as well, but found no solution.

 

I had High Sierra 10.13.6 almost fully working on this PC, so I don't think it's my BIOS settings' fault.

Any help would be appreciated, thanks!

Share this post


Link to post
Share on other sites
Advertisement

Had the same problem when installing Mojave on my AMD desktop.

Just download this kext (thanks to XLNC) and put it in your EFI/CLOVER/kexts/Other folder.

 

https://files.amd-osx.com/XLNCUSBFix.kext.zip

 

Be aware I'm facing problems with the latest CLover versions. Breaks my USB again. Stick with CLOVER 5033 till problem solved.

good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×