Jump to content
Sign in to follow this  
Followers 0
olvko

DiskArbitrationFixup - disable alert for non-macOS partitions - binary kext

1 post in this topic

Recommended Posts

As I found no binary kext for DiskArbitrationFixup Lilu plugin from https://github.com/Goldfish64/DiskArbitrationFixup, I compiled current version. Attached below, as it may be useful for other people.

 

This Lilu plug-in disables error "The disk you inserted was not readable by this computer" after macOS boot in case you have eg. Linux partitions in the same computer.

 

Compiled under macOS 10.14.3 without debugging symbols against Lilu 1.3.4 headers. Requires Lilu.kext (https://github.com/acidanthera/Lilu) alongside to work.

 

I do not give any warranty for its work and I am not an author of original code.

DiskArbitrationFixup-08032019.zip

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By headkaze
      English: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md
      Russian: https://www.applelife.ru/threads/intel-hd-graphics-3000-4000-4400-4600-5000-5500-5600-520-530-630.1289648/
      Chinese: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.cn.md
    • By monw3d
      hey everybody
       
      as title said lilu causing very long boot 5-6 mins on SSD
      my EFI is up to date and set properly, only usb3 not working looking for kext
       
      OS 10.14.5
      my mobo p61a-d3 with i5 2400
      when -liluoff is used bood time is under 30 seconds
       
      i have tried lilu 1.2.6 to 1.3.3 same results
       
      how can i get lilu bootlog?
      i dont know how to solve this problem
       
      edit - usb3 fixed and working
    • By poles89
      Hi guys,
       
      Though native graphics acceleration is supported on i3 from Mojave, I'm not able to manage to get it.
       
      This is my system configuration :
      Motherboard:  Asus Prime H370-Plus
      CPU: i3-8100 (UHD 630)
      OS: Mojave 10.14.2
       
      I'm trying every possible way to get full graphics acceleration. But whatever I try it shows only 4MB video memory or leads to Kernal Panic. Here are some ways I have tried so far:
       
      Prerequisites: 
      Installed latest Lilu+WEG on L/E. set DMVT prealloc to 64MB on bios.  
      Option 1: IntelGFX-> 0x3E928086, ig-platform-id-> 0x3E9B0007, Inject Intel = true. Output:  Kernal Panic
      Option 2: Blank IntelGFX, blank ig-platform-id, Inject Intel = false Output:  Kernal Panic
      Option 3:  IntelGFX-> 0x3E928086, ig-platform-id-> 0x5912000, Inject Intel = true.  Output: Booted Successfully but no graphics acceleration.
                     I knew that ig-platform-id-> 0x5912000 doesn't work in mojave and its works only for high sierra but I set this because with this ig-platform-id I can boot. Another way I can boot it by
                     setting invalid Fake IntelGFX value like 0x12345678.
      Option 4:  Downloaded Intel FBPatcher & followed this guide. But as I opened the app, its shows like this:
       
                     
                    
                     It clearly indicates it neither can detect Intel CPU generation nor GPU memory (currently shows 0 MB). I changed to different PlatformId from the drop down but no improvement. Anyway I
                     applied a patch with SMBIOS ->Macmini8,1 by someione's recommendation . I attached a config file (config_fbpather.plist) for this. Output:  Kernal Panic
       
      I have tried the upper mentioned methods with SMBIOS like  iMac14,2 / iMac18[1,2,3]  and Macmini8,1. I'm using HDMI port for display output. Now I don't know whats wrong with theses methods but maybe someone can help me to figure out this problem. I have also attached those config.plist files.
       
      Thanks in advance.
       
      config_fakeid_0x3E928086.plist
      config_fbpatcher.plist
      config_fbpatcher_with_device_id.plist
      config_platform-id_0x59120000.plist
    • By EduardoMenezes
      Good evening, friends of InsanelyMac.
      I have an Acer Aspire E5-571 notebook with Intel processor and Intel Graphics 5500 hd graphics card. When I was using the Sierra, the video card was recognized without problems. Now that I'm using Mojave I can not get the acceleration to work.
      I've been researching something about having to use Lilu.kext and whatevergreen.kext but I do not have enough knowledge to solve this problem.
      I need the help of someone who can explain to me how to solve this acceleration problem. I'm sure it will be of great value to other users like me.
      Thank you very much.

    • By macinsane
      What works? Everything. Sleep/Wake, NVMe, Airport, Spotlight, AMD-graphics

      Config:
      ASUS Prime B250M-C µATX-board
      Intel Core i5 7500 (Kaby Lake)
      Gigabyte Radeon RX560 4GB
      Airport-compatible PCIe-Card for Wifi and Bluetooth (BCM943602CS)
      2 NVMe drives: Samsung P961 with 1 TB and 256 GB

      Installed mac OS: 10.13.2
      Clover: 4334
       
      *Update 10.13.3*
      Added new config.plist and ssdt for AMD injection (config_amd_ssdt_10133.zip). With this config and Intel IGPU activated you'll get Metal2 (macOS GPUFamily1 v3). What did I do? Had to fake Skylake graphics or to prevent apps like iMovie or FinalCut from crashing. With Kabylake kexts loaded and IGPU as secondary graphics card, the computer will hard reset whenever the Intel GPU is utilised. Only Skylake kexts and activated IGPU will give you working Metal2 for the RX560.  
       
      *Update 10.13.2*
      Since this update a new approach is advisable to get the RX560 up and running (works for 10.13.1 and GM as well). I've added a working SSDT and injector kext that gives you graphics and HDMI audio. Sleep works fine too if you add the DSDT I compiled.  
       
      Credits go to @Toledo @Mork vom Ork and @Mieze because their work made this possible.
      *Update* I've added NEW config.plist and DSDT. For proper graphics power management you have to activate onboard graphics in BIOS but make PCIE the primary display. Furthermore you have to inject ig-platform-id 0x59120003 and let Clover patch GFX0 to IGPU. This is the only way to avoid crashes of iMovie, FinalCut or slowdowns after video playback.

      This may be the smoothest Hackintosh of my life. It is easier than Sierra install due to native support for most of the used hardware in High Sierra. Not much to do, using an up-to-date Clover version like 4184. Make sure you have apfs.efi in /Clover/drivers64UEFI/ on your EFI partition and that you delete EmuVariableUEFi.efi (downside: iMessage doesn't work without it). Somehow Rehabman's SSDT in /Clover/ACPI/patched helps avoiding crashes in iTunes.

      Needed kexts (on your EFI into /Clover/kexts/Other): FakeSMC, IntelMausiEthernet for ethernet, USBInjectAll and XHCI-200-series-injector for USB, Lilu and AppleALC for audio, Whatevergreen for AMD graphics, IntelGraphicsFixup and AMD9xxxControllerPatcher.kext.
       
      DSDT and SSDT go into EFI/Clover/ACPI/patched.
      config.plist.zip
      AMD9xxxControllerPatcher.kext.zip
      SSDT-HDMI-AMD-PEG0.aml.zip
      DSDT.aml.zip
      config_amd_ssdt_10133.zip
×