Jump to content

Boot errors on 10.8.5 (stuck)


18 posts in this topic

Recommended Posts

Hi guys,

 

Have any of you encountered these errors? Are these show stoppers? Should it boot even with these errors? Cause in my case, it's stuck at the last line you see in the screenshot below.

 

The hardware I'm trying to get to work is the one in my signature. So...that graphics card I'm sure is not supported. But I tried faking the ID...and still got nothing. Also, I've got the same thing booting with the on-board graphics, as well. So...I'm not sure that's the cause. Also, it does boot in Safe Mode (-x), but of course, that also means no EFI, and no kexts (I'm trying to use Clover's kext injection feature from Clover/Kexts/Other)

 

I've spent a lot of time googling around, and tried a lot of different combinations of Clover + FakeSMC... The installer works. But booting into the installed OS does not. Funny is that, the first time I installed the OS, I was actually able to boot into the OS, and both cards (iGPU and dGPU) were recognised, though the last one was showing 31MB of VRAM. So that's that (and I've got no acceleration). :)) But, at least I was able to boot. After the os update (and I feel like that Supplemental Update might have broken something), I just can't boot into the OS anymore.

 

And before asking why the hell would you want to install Mountain Lion, well, just because I want to challenge myself to make it work. I don't really need it. I'm actually typing this from a perfectly working Mojave installation. But I never tried older versions of Mac OS (OS X). I actually started with Mavericks. So..I was only curious if I can get it to work. Aaand...so far, I've only got partial success. I was able to boot into the installer and install the OS, but, as I told you above, not so much after that. :)

 

If you guys know what could be the cause of the computer getting stuck there in this case, please, do let me know. :)

 

Aside from the hardware in my signature, I'm using Clover 4200 (newer versions don't work anymore), UEFI mode, and an iMac14,2 SMBIOS. AHCI is enabled in BIOS (it's actually enabled by default), CSM is also enabled right now, although I tried disabling it as well (in order to have a full UEFI experience), but that didn't really make any difference. Have tried multiple SMBIOSes, as well... Not really sure if that's supposed to make any difference. But it kinda didn't. On the contrary. I had more errors with something like MacPro3,1 or MacPro5,1 for example. Most likely because of the CPU. So...I don't really care which SMBIOS it is, as long as it works.

 

Also, probably stupid question, but if the RX 580 is officially supported with Mojave, can I somehow use the driver in Mountain Lion?

 

IMG_20190216_121122.thumb.jpg.a75d3bc73cf3ada42c4867ca8f718175.jpg

Edited by arsradu

1st of all, you can forget about getting the RX580 working under Mountain Lion; you should have sussed that out by yourself by now...

 

It's going back a few years now but, if I remember well, Mountain Lion -like Lion- usually required to replace vanilla AppleACPIPlatform kext by version v1.3.6 from Snow Leopard. Well at least, on all those Dell desktops and laptops I installed it on.

 

Edited by Hervé
  • Like 1
11 minutes ago, Hervé said:

1st of all, you can forget about gettin the RX580 working under Mountain Lion; you should have sussed that out by yourself by now...

 

It's going back a few years now but, if I remember well, Mountain Lion -like Lion- usually required to replace vanilla AppleACPIPlatform kext by version v1.3.6 from Snow Leopard. Well at least, on all those Dell desktops and laptops I installed it on.

 

 

Hi Hervé!

 

Yeah, I wasn't really expecting a newer card like the RX 580 to work by default with an older OS. :)) After all, the support for it has been introduced with 10.12.6 if I'm not mistaken. So yeah. :)) But I thought maybe using the driver from a supported version of MacOS might work. So far, no success. And, as you said, it probably will never work. :))) But, I don't really mind that. As I said, I only wanted to get it to to boot properly (which I did, at the beginning, not sure why it doesn't work anymore). Not really to have it as a daily driver.

 

I'll explore more into the AppleACPIPlatform idea you mentioned above. :D Thank you very much.

Edited by arsradu

If you can currently boot without replacing the AppleACPIPlatform kext, then I guess it's not required. ML 10.8.5 supported Haswell platforms so, one would expect you'd be able to run on the HD4600 iGPU. I guess you know what to do in that respect...

 

6 hours ago, Hervé said:

If you can currently boot without replacing the AppleACPIPlatform kext, then I guess it's not required. ML 10.8.5 supported Haswell platforms so, one would expect you'd be able to run on the HD4600 iGPU. I guess you know what to do in that respect...

 

 

Yeah, I can boot, but only to the installer (using the USB drive), and after installation completes and I have to boot into the OS (from the HDD), only in Safe Mode.

 

Actually, I moved my kexts from Clover/kexts/Other to S/L/E and now I was able to boot. Still only in Safe Mode, but since the kexts are in S/L/E instead of Clover/kexts/Other (EFI), at least the Ethernet kext is loaded, so I can type this. :))

 

Wanna hear something funny? I've got the OS (and the installer) running in full 4K, by default. :)) No acceleration, as I said before (at least not with the RX 580). But in full resolution. Which is pretty cool considering we're running Mountain Lion here. Looking at the Graphics section in System Report, I'd say I probably will have acceleration with the iGPU. So I might give that one another try, as well. :) Also, the CPU seems to be correctly identified, for as far as I can tell. 

 

Not sure why it doesn't wanna boot in normal mode though. Probably the Graphics (the RX 580)... Probably something else. No idea. Well, so far so good. At least I can boot the OS and I can play around with it for a little while. Pretty cool!

 

943598343_ScreenShot2019-02-16at8_35_25PM.png.2a84db07055b8d0130cca238a5ae4bec.png447466661_ScreenShot2019-02-16at8_37_49PM.png.85fb870276e3da321a08c3ecc5cda042.png

 

 

1280471850_ScreenShot2019-02-16at8_44_31PM.png.4036c704f5aa86bbfc264bb5fe43c05a.png1897852417_ScreenShot2019-02-16at8_46_26PM.png.8f67ceeb8d579454821427987100c617.png

 

And Clover's Graphics injection feature seems to recognize my RX 580 as RX 480. It's not really wrong, since if I'm not mistaken, the IDs are the same between the two (0x67df1002).

 

Update: using the iGPU, I'm scaled down to 1080p max via HDMI. Probably intended...? Unfortunately, still no acceleration.

 

540537213_ScreenShot2019-02-16at9_00_26PM.png.9861f040803f9a60b284f29698ed50ff.png

Edited by arsradu

Without graphics acceleration, you're limited to VESA mode which will try and apply the max. resolution to the output screen.

 

Why don't you post a zipped copy of your Clover EFI folder?

 

Edited by Hervé
55 minutes ago, Hervé said:

Without graphics acceleration, you're limited to VESA mode which will try and apply the max. resolution to the output screen.

 

Why don't you post a zipped copy of your Clover EFI folder?

 

Sure! Here it is. :)

 

It's probably messy, since I tried different combinations of things. Probably some of them not really compatible with each other. But I just don't know what to try anymore. I mean, I'm glad I got it to work as it is. :))) I'm not really hoping for more, from this point forward.

 

But anyway, thank you very much for your replies and for taking the time to take a look at this. Appreciated. :) 

CLOVER.zip

  1. Remove "Inject ATI" and try iMac14,4 SMBIOS (that model ran in HD5000 iGPU).
  2. I think you'd have to generate your CPU PM SSDT.
  3. I'd also remove Lilu + WEG to begin with. You're not going to get any support for your AMD card anyway, so... Ideally, disable the PCIe GPU in BIOS if possible.
  4. USBInjectAll can be removed, that's only applicable as of El Capitan.

 

Finally, can you extract your DSDT so that we look at it and evaluate the need for further patches (like renaming if the iGPU device)?

Edited by Hervé
  1. Remove "Inject ATI" and try iMac14,4 SMBIOS (that model ran in HD5000 iGPU).
  2. I think you'd have to generate your CPU PM SSDT.
  3. I'd also remove Lilu + WEG to begin with. You're not going to get any support for your AMD card anyway, so... Ideally, disable the PCIe GPU in BIOS if possible.
  4. USBInjectAll can be removed, that's only applicable as of El Capitan.
 

Finally, can you extract your DSDT so that we look at it and evaluate the need for further patches (like renaming if the iGPU device)?

 

1. Done.

2. OK. Added Generate C-States and P-States in Config -> ACPI -> SSDT.

3. Removed. Can't really disable it entirely since I still use it for Mojave.  Also, it wasn't for the AMD card support, it was for better support of the iGPU. At least that's why I'm using it on my Mojave installation. Anyway, it's removed from the ML installation.

4. Removed.

 

Original DSDT attached. Generated from Clover 4877, the one I'm using to boot my main Mojave installation, since I can't access my EFI partition from ML. And I thought there shouldn't be any difference anyway. Since it's the same hardware for both.

 

Also, now I have a new interesting problem (it was there before making the changes above, so I'm sure they're not related), after upgrading everything in the OS: trying to open Launchpad freezes the entire system. Everything else seems to be working. But when clicking the Launchpad icon in the Dock, everything freezes.

 

 

origin.zip

 

Update: SMBIOS iMac14,4 might be a bit too new for ML. I'm getting platform unsuported error upon booting.

92b2357d3f2aa84bc138dce69ba34e25.jpg

Edited by arsradu

Why on earth did you activate Generate P States + Generate C States ? That's for C2D/C2Q and 1st gen Intel "i" Core CPUs. For Haswell and ML, I'm pretty sure you have to generate your own CPU power management SSDT with Pike R Alpha's well-known SSDT generator. You already have KernelPm patch enabled so that's Ok.

 

Sorry for the SMBIOS, I did not check which platforms were supported...

 

Having had a look at your raw ACPI tables, adjust your Clover ACPI config with the following device renaming/patches:

  1. rename GFX0 to IGPU
  2. rename BOD3 to HDAU

 

Edited by Hervé
1 minute ago, Hervé said:

Why on earth did you activate Generate P States + Generate C States ? That's for C2D/C2Q and 1st Intel "i" Core CPUs. For Haswell and ML, I'm pretty sure you have to generate your own CPU power management SSDT with Pike R Alpha's well-known SSDT generator. You already have KernelPm patch enabled so that's Ok.

 

Sorry for the SMBIOS, I did not check which platforms were supported...

 

 

Well, I thought that's what you meant by generate CPU PM SSDT.  So…I thought I could give it a try. My bad. :D For as far as I know, for Haswell, PluginType should work just fine. But sure, we can try Pike's SSDT generator, as well, if you think it might make a difference. :)

 

Also, don't worry about the SMBIOS thing. I set it to iMac14,1 for now to match (well, at least as close as possible), the CPU I'm using (i5 4570).

iMac14,1 is indeed going to be Ok; iMac14,2 might be a little better since that was sold with an i5-4570...

 

Re: CPUPM, I meant this:

https://github.com/Piker-Alpha/ssdtPRGen.sh

Don't you remember?

 

If you appear to have full CPU power management/SpeedStep, then Ok, forget about the CPU PM SSDT. But then, if you're running XPCM, you should not drop any power management SSDT in your Clover Config. Your config does not appear kosher to me on that matter at the moment. But maybe I'm wrong.

 

If you still don't get full graphics acceleration on your HD4600 iGPU, try and add Rehabman's FakePCIID + FakePCIID_Intel_HD_Graphics kexts. Those should sort you out. I don't know if Lilu + WEG are actually supported in ML ; they came out much much later...

 

Edited by Hervé
28 minutes ago, Hervé said:

iMac14,1 is indeed going to be Ok; iMac14,2 might be a little better since that was sold with an i5-4570...

 

Re: CPUPM, I meant this:

https://github.com/Piker-Alpha/ssdtPRGen.sh

Don't you remember?

 

If you appear to have full CPU power management/SpeedStep, then Ok, forget about the CPU PM SSDT. But then, if you're running XPCM, you should not drop any power management SSDT in your Clover Config. Your config does not appear kosher to me on that matter at the moment. But maybe I'm wrong.

 

If you still don't get full graphics acceleration on your HD4600 iGPU, try and add Rehabman's FakePCIID + FakePCIID_Intel_HD_Graphics kexts. Those should sort you out. I don't know if Lilu + WEG are actually supported in ML ; they came out much much later...

 

 

Lilu probably is… I've read on the AppleALC thread that it should be. WEG most likely not. Actually, it's even ignored on boot. So yeah, that doesn't' work, for sure.

 

Actually I never used that script before. I know about it. But I never really thought I needed to use it… Maybe I was simply lucky with this CPU. I don't know. But anyway. Attached you can find the generated data from that script. Not sure what should I be looking for though. :))

 

So, I don't know. Does it look ok?

 

Also, I'll try FakePCIID + FakePCIID_Intel_HD_Graphics.kext.

 

1552830104_ScreenShot2019-02-17at12_44_30AM.png.ed55ff7ee040eec78f3c61cc26229009.png

 

As for the SMBIOS, yeah, I thought iMac14,2 is actually perfect for my CPU. Still, now when I looked at that in Clover Configurator, I saw an i7 4770 or something like that… So…either that's wrong…or I don't know.

Data.zip

4 hours ago, Hervé said:

You're meant to place the generated SSDT.aml in Clover's ACPI/patched folder...

 

 

You can tell I never used that script before, can't you? :)) Anyway, even with that SSDT in ACPI/patched, I still can't boot in normal mode. Also FakePCIID and FakePCIID_Intel_HD_Graphics.kext didn't make any difference to the iGPU's acceleration.

 

I think I'm just gonna use it in Safe Mode and that's it. :) Safari can't open some of the pages anymore (such as github). So yeah, I can say I successfully satisfied my curiosity and it's time to move on to maybe something more recent. :)) 

 

Thank you very much for all the help.

Edited by arsradu
7 hours ago, ellaosx said:

there are 2 things i remembered most with my HD4600.

1. Min OS is 10.9

2. ig-platform-id = 0x0a260006

 

Hi Ella!

 

Funny you mentioned 10.9. Last night, I installed it, just to see what happens with that one. Aaand...I've got the exact same issues booting into that, that I had booting into Mountain Lion. With the only difference that, with Mavericks, I could use the latest version of Clover. Different Clover version, different config, but same issue. Also tried to boot with the same Clover as Mountain Lion and again, same issue. I can boot, but only in Safe Mode. No matter if I'm connected to the dGPU or the iGPU at the time. And regardless whether or not I've got Inject ATI or Intel or no inject whatsoever. 

 

Also, isn't 0x0a260006 for Laptop GPUs? Cause I remember they were different. Anyway, I can give that one a go, as well, tonight. But the problem might be somewhere else in my case. Anyway, as I said, this was just a fun little project to remember some of the earlier versions of OS X. Not really important.

 

But thank you very much for your feedback! :) 

Edited by arsradu
×
×
  • Create New...