Jump to content
valueimagery

Lost Location Services with 10.14.3 Update

8 posts in this topic

Recommended Posts

Hello,

I've updated via system preference fro 10.14.2 to 10.14.3 successfully. However, I've lost location services for Siri and Maps.

Anyone else?

I've tried a little trial and error troubleshooting but no luck...
SysPref->Privacy->Location Services is enabled with all settings checked. I've tried to disable and enable, but not luck.

I tested booting from previous backup of 10.14.2 install/uefi (pre update) and Location Services worked.

Prior to OSX update I also updated to latest clover, WEG, Lilu, AirportBrcmFixup, AppleALC.

So I tested by downgrading all of the above one at a time to the previous state, and still no Location services on 10.14.3

I've used kext utility to repair any broken kexts.

I've also tried forcequiting from activity monitor:
com.apple.geod

And I've Try Deleting:
Library/Preferences/com.apple.GEO.plist
Library/Containers/com.apple.geod

I've booted into a guest user and this did not allow location services either.

My build is using a native Broadcom BCM94352Z Dell DW1560 and BrcmPatchRAM2.kext + BrcmFirmwareRepo.kext

Any thoughts?

Share this post


Link to post
Share on other sites
Advertisement

i have icloud cleaning process bookmarked which has worked for me with similar issues, so pasting below,

because from my experience any icloud issues disable location services so i think they are linked.

your guest comment is concerning. but posting this anyway.

 

Icloud

Go to Finder and select your user/home folder. With that Finder window as the front window, either select Finder/View/Show View options or go command - J. When the View options opens, check ’Show Library Folder’. That should make your user library folder visible in your user/home folder. Select Library. Move the following to the Trash and restart.

 

Close all running apps. Put the following items in the trash:

 

1) In the ~/Library/ folder, put the Caches folder in the trash.

 

2) In the ~/Library/Application Support/ folder, put the folder iCloud in the trash.

 

3) In the ~/Library/Preferences/ folder, put the file MobileMeAccounts.plist in the trash.

Edited by millusions

Share this post


Link to post
Share on other sites
17 hours ago, millusions said:

Close all running apps. Put the following items in the trash:

 

1) In the ~/Library/ folder, put the Caches folder in the trash.

 

2) In the ~/Library/Application Support/ folder, put the folder iCloud in the trash.

 

3) In the ~/Library/Preferences/ folder, put the file MobileMeAccounts.plist in the trash.

Thanks for the reply and the advice.

I tried your suggestion but unfortunately still no location services.

I think you are right to think that the guest user not working as concerning as well.

 

So something bigger happening here...

 

Share this post


Link to post
Share on other sites

how about icloud stuff? is it working?

maybe a new smbios.

 

for repairing kexts and caches KCPM Utility Pro is a must have.

 

hey. from memory, the BCRM things, i think you're supposed to only use one? just shooting from memory here, i could be wrong.

 

apart from 2 hacks, i have a i7 (2012) mac mini and a 27 (2013) inch imac, i rolled both back to 10.14.0,

the mac mini kept losing remote control connection, it's fine on 10.14.0. haven't had one issues in about 10 days since downgrading.

the imac, which i did this morning, had some sometimes weird white/gray screen on resume from sleep, with some progress bars on bottom they looked like something from an iphone.

i think i'll wait till 10.14.6 for both machines.

 

 

 

Share this post


Link to post
Share on other sites
2 hours ago, millusions said:

how about icloud stuff? is it working?

Handoff, iMessage, iCloud, Facetime, all work fine.

 

2 hours ago, millusions said:

maybe a new smbios.

Haven't tried this yet... would I try to use iMac Pro smobios?

 

Looking at Rehabman's readme concerning the kext at https://github.com/RehabMan/OS-X-BrcmPatchRAM

It says to use either BrcmPatchRAM.kext or BrcmPatchRAM2.kext depending on OS version.

And to use either BrcmFirmwareData.kext or BrcmFirmwareRepo.kext depending on injection type.  Originally I had all my kexts loaded in the other folder and injected via UEFI.  However, once upgrading to 10.14.3 and reading that it's better to use a kext installer rather than the UEFI method I opted to use the  BrcmFirmwareRepo.kext instead of the BrcmFirmwareData.kex (which can only be injected by UEFI)

 

I'm going to try and revert to the  BrcmFirmwareData.kext via UEFI to see if that changes anything.

 

If that doesn't work I'll just hope that the next release 10.14.4 solves the issue...

 

Share this post


Link to post
Share on other sites

not sure mate, not a guru, just have several hundred hack reboots under my belt ha ha.

 

make a copy of config.plist name it MacPro5.plist, press space bar at clover, maybe make an imac one while you at it..

 

i had a similar issue years ago with Mavericks, location services was grayed out and not selected/selectable never got to the bottom  of it. can't remember, i think re-install fixed it.

 

if it was me i'd roll back instead of waiting for a fix, i rarely do updates on hacks. running like 10.13.2 cuz of 1070 GTX. it's rock solid.

when i was doing Brcm stuff, i didnt follow instructions, trial and error, and just AirportBrcmFixup kext is all it took to work 100%. but i guess you have wifi and no bluetooth?

 

sorry, thats my 5 cents, and it's pretty much all i had

Share this post


Link to post
Share on other sites

Appreciate the help.

 

I reckon a fresh install would be the go.

 

And bluetooth does work fine.  Always has, including location services, but something about this upgrade didn't jive.

 

At the end of the day, I can live without location services.   Thanks again for the advice!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By glasgood
      CLOVER DUAL BOOT MOJAVE & WINDOWS 10 GUIDE 
       

       
       
      INCLUDES  MBR / LEGACY BIOS  TO  GPT / EFI CONVERSION
      USING MBR2GPT TOOL
       
       
      PREREQUISITE: Two physical discs ( SSD’s or HDD’s )
       
       
       
       
       
      STEP 1 - Clover dual boot configuration 
       
      Open config.plist with Clover Configurator
       
      Boot
       Legacy = PBR Timeout = True ( will remove the Timeout countdown, from Clover boot menu)  

       
      GUI 
      Scan / Custom
       Entries = True  Tool = True  Legacy = False ( removes extra Windows 10 entries )  
      Hide Volume
      - Preboot ( macOS Preboot )
      - Recovery ( macOS Recovery )
       

       
      So at boot you will have two options: boot macOS Mojave or Windows 10 
       
       
       
       
       
       
       
      ————————————————————
       
       
      STEP 2 - Using a drive without Windows 10 installed
       
      Disconnect system drive that contains your macOS Mojave install from computer ( This is so that Windows does not overwrite existing macOS Mojave boot loader )
       
      Proceed with a Windows 10 UEFI install.  
      After installation reconnect macOS Mojave Drive, the Windows installation should now be detected and usable in Clover. 
      If Windows 10 is not detected or able to boot,  then verify you installed Windows 10 as UEFI and not MBR ---->  ( Read step 2 - For a drive with Windows 10 installed )
       
       
      OR
       
       
       
      STEP 2 - Using a drive with Windows 10 already installed
       
      Verify your Windows install is  GPT / UEFI or MBR / Legacy BIOS.   
      If Windows install is GPT UEFI then Windows 10 install is ready to use at Clover boot menu, you should be able to boot into Windows directly from Clover boot screen. 
       

       
       
      But if  Windows drive is detected at Clover boot screen, but when booting Windows you get a black screen with a cursor on the top left,
      then this is most likely because Windows drive is MBR ( Legacy BIOS ).  You can easily convert MBR to GPT using  Windows MBR2GPT tool ( this saves hours work having to reinstall Windows 10 and setting up all your applications again  ) 
       
      If Windows 10 install is MBR / Legacy BIOS  then simply convert to GPT / UEFI  following instructions below ( read video summary and view video )
       
       
      ** To use Windows 10  MBR2GPT tool  you must have Windows 10 version 1703 ( creators update  ) or later and less than 3 partitions on 
      the Windows 10 drive **
       
      Video summary:
       
      Confirm Windows 10 drive is MBR Legacy BIOS ( in Windows Disk Management ) Reboot into Windows PE ( Advanced Startup ) Convert from MBR Legacy BIOS to GPT UEFI ( using commands below ) mbr2gpt /validate mbr2gpt /convert Restart Verify Windows 10 drive has changed to GPT UEFI ( in Windows Disk Management )  
       
       
       
      After conversion Windows 10 is ready to use at the Clover boot menu 
       
       
    • By gk12345
      hello to everyone, i managed to install mojave on my asus ux303ub with i5 cpu and now sleep does not work when i press sleep display turns black and pc stays on and then i have to force shut down by holding power button in order to restart pc ,by the way i used the clover folder from a guide on the internet, any help would be appreciated, thanks
    • By Bahaa
      Need help here
      My graphic card is detached 7mb
      and I try a lot of solution and no one work 
      can any one help
       

    • By Gracie
      Hello, insanely kind people! 
      I had full working Speedstep on my system with El Capitan, but after installing Mojave i cant make it working again!
      Help me please. Actually system is working only with NullCPUPowerManagement.kext. As soon as i remove it from Extensions directory i've got kernel panic at the boot.
      I tried to put SSDT.aml from my previous ElCapitan clover, tried to make new by different utilities, but still no luck.

      My system is:
      Pentium G3258
      Asus Z97-K USB 3.1
      Nvidia GTX 670


      i''m attaching my new clover.plist of Mojave and old El Capitan one, which makes Speedstep fully working and overclocking my little Pentium from 3.2 to 4.5GHz. Now i see huge speed loss without SpeedStep on Mojave  Please help, anybody! Also im attaching my working SSDT.aml from El Capitan.
      El Capitan SSDT.aml
      El Capitan config.plist
      Mojave config.plist
    • By guitar201
      I’m currently getting around 30seconds on the brucex test and think I can do better.   Ive tried disabling dgpu in the bios and enabled to no availe.  Currently running 10.14.3 with corps dsdt script.  
       
      System is a:
       
      ​
       
      Core i5-8400 / Gigabyte Z370 SLI XP mobo
       
       
      Vega 64
       
       
      GC-Alpine Ridge Thunderbolt 3 card
       
       
      [https://pastebin.com/W3PVZCxh](https://pastebin.com/W3PVZCxh) My Config.plist
       
       
       
      [https://imgur.com/a/KZ9qgop](https://imgur.com/a/KZ9qgop) Contents of my EFI folder
       
      Any suggestions is appreciated.  Thanks. 
×