Jump to content

Wake from Sleep failing - Mojave Vega 56 + GTX1080ti


7 posts in this topic

Recommended Posts

I'm having a issues with wake from sleep from Mojave. When I press the keyboard or mouse to wake, the keyboard lights up and fans start and then keyboard lights turn off - screens remain off the whole time. I can't access the system remotely either. The only way is to hard reboot & then on start it tells me it restarted due to kernel panic.

I recently added a Vega 56 graphics card to slot 6, and have my GTX1080ti in slot 1. I have upgraded to Mojave and applied the spoof SSDT to disable the NVIDIA from the following thread:

Web drivers are not installed & the NVIDA doesn't show up under graphics cards in system report, I only have the Vega listed and I can see the NIVIDA shown only as #display in PCI devices with no driver loaded.

I've tried whatevergreen, but causes issues with rotation settings on 2nd monitor & doesn't fix the problem. Tried different darkwake settings, and quite a few other things with no luck.

Would really appreciate any help of guidance on this. Everything else is working fine, except wake.

Attached are the problem reporting files

Report Files.zip

Link to comment
Share on other sites



I think you are misssing the method to shut off the NVDA at  wake from sleep.

Look here: https://github.com/RehabMan/OS-X-Clover-Laptop-Config/tree/master/hotpatch at the

But use only the nvda methods to not shut off your AMD.
In config.plist you have to insert the corresponding DSDT patches, add boot argument "nv_disable=1", add for nvda the add properties from this config.plist: https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD515_520_530_540.plist
In graphics activate inject NVDA.
Have fun.



  • Thanks 1
Link to comment
Share on other sites

Hi @styrian,


Thank you for the reply ! Yes that sounds logical that the off method is missing from the SSDT for wake. Sorry I'm not that expert on how to apply to dsl to the SSDT I have. Is there any chance you could help ? The current SSDT is attached.


Really appreciate your help


Edited by ccozmo
Link to comment
Share on other sites

Thanks, I tried the files you attached but the WAK doesn't comply and the path seems wrong for my NVIDIA which is _SB.PC02.BR2A.SL05


I redid the files from the original link, not sure if they are correct (attached)


I am still getting the same issue, wakes and hangs, and when reboot says kernel panic. Attached are the new report logs.


Any help really appreciated




Edit: Realised the WAK SSDT was in dsl, not ami. Have retested and still the same. New files uploaded instead








Edited by ccozmo
Wrong files
Link to comment
Share on other sites


  • Create New...