Jump to content
Sign in to follow this  
Followers 0
SardusX86

Install macOS Mojave by converting / formatting a partition from HFS + to APFS in a multiboot system

2 posts in this topic

Recommended Posts

Hi All,
I would like to replace macOS Sierra with macOS Mojave in a Sierra / High Sierra multiboot system in the same ssd (Asus P5G41T-M LX mb - Intel Core2Duo E8600 cpu - legacy-bios mode with Clover bootloader).
Unfortunately both existing partitions are HFS + and I read that installing MacOS Mojave requires an APFS partition.
Is it possible to format/convert, for example, the existing macOS Sierra partition from HFS+ to APFS without deleting the other existing macOS High Sierra partition?

Thanks in advance for Your help

Share this post


Link to post
Share on other sites
Advertisement

Mojave does not require APFS.  APFS is only installed by default if you have an SSD drive.  My experience is that if you format your disk to HFS+ before install, the Mojave installer will leave it as such during the install.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By am_yvr
      Asus Prime B360M-A or Asus Prime H310M-E :

      Which of these two motherboards would give less hassle in a Hackintosh build - requiring fewer after install fixes/updates to get everything working in Mojave or High Sierra?
       
      These are the only two Asus models that I can afford, fit the form factor in my build, and already have had a BIOS upgrade by Asus to 9th-generation - if I want to replace the CPU with an i9 in the future (for now I'll be using i7-8700 or even i3-8350k but I want to future proof a bit)
       
      Thanks guys!
    • By thomazella
      Hi guys. Just wanted to say this is my new favorite forum for mac hacks

      I'm trying to get mojave to work, and using the guide's (moderator made, on the front page) clover folder I ALMOST got it! T.T

      There's something still wrong tho. lol.

      - Install to a HDD formated as case-sensitive APFS goes black at 2 minutes remaining. Is it supposed to fill the progress bar 100%? If so then I have a problem.
      - Assuming the install went well, I tried to boot to "MacOS Prebooter" from clover screen and got that error.

      I have a Z170m ASUS, awesome board. I'm sure it can be done. With Intel 6700k.
      Latest clover. Guide's clover config!!

      What do you guys think?
      - mobo config problem
      - other hardware thing (I have many harddrives connected?)
      - clover config
      - need some driver/kext
      - something else

      THANK YOU!

      PS: I've tried upgrading with the App store download on a Sierra system to arrive in the same screen, with the same error.
      I'll also spend some time today searching the forums. Just busy atm, and thanks for any help or tips!!

    • By JoeMaya
      Hi. I'm currently on AppleALC.kext with layout ID 3. Clover's a boot argument contains alcid=3. 

      Problem:
       
      Case: Happens only in case of earphones.
      Problem description: The sound is somewhat like an echo where I'm hardly able to hear the vocals of a song. And the music sounds as if it's being playing under water. I later went to audio devices and tried checking the checkbox shown in the image below. I did improve the sound and I was finally able to hear vocals of a song in a much better way, however, it still doesn't sound like a proper sound. Is there any more configuration that I need to make? 

      The reason I'm able to differentiate the bad and the good sound output is because on High Sierra, using AppleHDA patch, the sound worked fine using AppleHDA patcher.

       

    • By sp4ge
      Im new on this forum and hackintosh thing and got success on installing mojave on my PC.
      But.. i have a trouble to get connected to internet through my TP Link dongle, anybody have to suffer this problem before?
       
      Thankyou.
       
      My PC Spec
      GA-H81M-S1
      Intel i7-4790k
      GTX 970
       
    • By Luk3_90
      Buongiorno a tutti,
       
      La scorsa settimana ho aggiornato High Sierra a Mojave seguendo le rispettive guide per l' aggiornamento dei Kext all' interno della partizione EFI. Tutte le periferiche funzionano correttamente audio compreso ( di solito non parte al primo riavvio ), tranne la Vram della scheda grafica integrata in firma ( 7 MB riconosciuti). Premesso che:
      - Ho aggiornato Lilu e aggiunto WhateverGreen nella cartella EFI/Clovers/Kexts/10.14 & EFI/Clovers/Kexts/Other
      - Ho rimosso IntelGraphicsFixup & Shiki
      - Ho rimosso Inject Intel con il relativo platform Id della scheda video ( era necessaria per High Sierra)
      - Con Clover configurator ho aggiunto sotto Device -> Proprieties  platform id, device id, Framebuffer-unifedmem ecc. ecc. ( Vedere config.plist in allegato)
      Al boot mi esce il messaggio [IGPU] Failed to initialize graphics firmware e si blocca la schermata. Qualora dovessi mettere un FakeId o semplicemente fare da clover Inject Intel + Platform Id: 0x00001912 ( se metto il Platform giusto 0x19120000 mi da sempre il solito errore), il sistema ovviamente parte senza problemi ma con 7MB di VRam.
       
      Mi è sfuggito qualcosa?
       
      Grazie in anticipo
      config.plist
×