Jump to content
Andrew+

Help with Realtek ALCS1120A

9 posts in this topic

Recommended Posts

Advertisement
14 hours ago, MaLd0n said:

CLOVER.zip

use full clover folder, dont change nothing

let me know if work

 

I did a clean install and use your clover folder sound works thanks but I now have two issues

 

1. Now I can't install Nvidia Web Driver any I ve tried many things with no success 

2. No Sound from HDMI

 

thanks 

Edited by Andrew+

Share this post


Link to post
Share on other sites
21 hours ago, MaLd0n said:

 

what method did you used to repackage the web driver?

Nvidia GTX 1070 6GB

 

Thanks for all you help :)

 

Update: I manage to get it working by editing the Nvidiastartupweb kext and change the build reqirement to match the current OS Build but system report is only showing 8 MB of VRAM when I should have 6GB

 

Update2: I manage to get it register the correct VRAM with the following below and correct about information as well but I still like to know how you 

 

Quote
 Open a terminal and enter the following commands:
 

sudo chmod -R 755 /Library/Extensions/NVDAStartupWeb.kext
sudo chown -R root:wheel /Library/Extensions/NVDAStartupWeb.kext
sudo touch /System/Library/Extensions && sudo kextcache -u /
sudo touch /Library/Extensions && sudo kextcache -u /
 
vii.) Reboot.
 
1.) Open a terminal and use the following commands:

cp /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/English.lproj/AppleSystemInfo.strings ~/Desktop/

sudo mv /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/English.lproj/AppleSystemInfo.strings /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/English.lproj/AppleSystemInfo.strings-Backup
 
2.) Open "AppleSystemInfo.strings" on your Desktop with TextWrangler and change

<key>UnknownCPUKind</key>
<string>Unknown</string>

 

to what ever you want. In my case I choose:


<key>UnknownCPUKind</key>
<string>4,5 GHz 18-core 36-thread Skylake-X i9-7980XE</string>
 
Save  "AppleSystemInfo.strings"
 
 
3.) Run the following terminal commands:

sudo codesign -f -s - ~/Desktop/AppleSystemInfo.strings

sudo cp ~/Desktop/AppleSystemInfo.strings /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/English.lproj/
 

 

Edited by Andrew+
Update2

Share this post


Link to post
Share on other sites
2 hours ago, Andrew+ said:

 

what method did you used to repackage the web driver?

Nvidia GTX 1070 6GB

 

Thanks for all you help :)

 

Update: I manage to get it working by editing the Nvidiastartupweb kext and change the build reqirement to match the current OS Build but system report is only showing 8 MB of VRAM when I should have 6GB

 

Update2: I manage to get it register the correct VRAM with the following below and correct about information as well but I still like to know how you 

 

 

just use it, dont loose time :P 

 

HIGH SIERRA

sudo /usr/libexec/PlistBuddy -c "Set :IOKitPersonalities:NVDAStartup:NVDARequiredOS "$(sw_vers -buildVersion) /Library/Extensions/NVDAStartupWeb.kext/Contents/Info.plist

 

SIERRA
sudo /usr/libexec/PlistBuddy -c "Set :IOKitPersonalities:NVDAStartup:NVDARequiredOS "$(sw_vers -buildVersion) /System/Library/Extensions/NVDAStartupWeb.kext/Contents/Info.plist

 

NvidiaPatcher.command.zip

 

and run kext utility after

Kext Utility.app.zip

 

Processor use it

MaLd0n 2018-05-03 às 11.06.41.png

MaLd0n 2018-05-03 às 11.06.53.png

Share this post


Link to post
Share on other sites

the cpu type you gave was inaccurate (wrong cpu) the way I did was to manually enter the cpu name in file AppleSystemInfo.strings :) simple but effective and the kext ult app fix the permissions of Extensions Folders

 

I Thank you for getting me a working Hackintosh :) I ve done them in the past but on a X299 was more difficult than usual  

 

Only thing is I still lost Audio from HDMI (if I can't get back I can live with if its not possible)

About.jpeg

Edited by Andrew+

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×